Windows 7 Home Premium not seeing network drivers in Hyper V


  1. Posts : 35
    Windows 10 Pro/Fedroa 24 Workstation
       #1

    Windows 7 Home Premium not seeing network drivers in Hyper V


    Hey how's everyone doing?

    So I got Hyper V installed on my computer last night and I followed the tutorial and set up Windows 8.1 Pro and installed Windows 7 Home Premium installed. Here's where my problem begins Windows 8 has no problem seeing my network in VM but I can't get Windows 7 to see any network drivers. I go under device manager and I don't see any network drivers but I do see 2 Unknown devices I assume are the drivers I need but how do I install them with no internet? I goolged my problem but Microsoft Tech Net said to install Integrated services but I don't see anything on how to install them. Any help would be awesome. I can post screen shots tonight when I get off work.

    Thanks
    Joseph P


    Here's the link where I found the info about integrated services

    Hyper-V guest OS has no network adapters
    Last edited by jpolacko; 12 Aug 2016 at 13:19. Reason: add link
      My Computer


  2. Posts : 35
    Windows 10 Pro/Fedroa 24 Workstation
    Thread Starter
       #2

    Windows 7 Home Premium not seeing network drivers in Hyper V-screenshot-1-.png

    I got it figured out. I had to change my network adapter from regular to a legacy network adapter and Windows 7 found it on boot.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 22:26.
Find Us




Windows 10 Forums