Hi, I hope someone may be able to point me in the right direction.

I am installing win 10 pro on my machine, which goes fine, then when i try to install hyper-v (add program and features) it seems to go well, reboots, tells me installing features, reboots again, then just sits there forever with the blue windows symbol on the black page with the little dots circling below. No errors and no progression. I have tried multiple times and the same result.

This is on a HP ML10V2 server I bought new and cheap. The OS is installed to a new samsung 750 ssd on port 1 of the std connector, which is a B120i raid setup (std for this server). I am running single disk raid 0, as this is the way the system likes it. No other disks. 16gb ecc ram. No other apps, firewalls, AV installed, I just install windows, then try to install hyper-v.
CPU is a xeon e3-1240v3. I tried running systeminfo.exe and it confirmed 4 yes's for hyper-v.

On previous occasions I have tried installing other apps etc before hyper-v and everything seemed fine excpet the hyper-v install. I have tried before installing up updates and after. When time it stalls I have tried repairs, etc with no success. I always go back to clean installs.

I believe the bios and firmware of the server are all up to date.

The system was running fine for weeks under xpenology, so I do not suspect a HW issue.

Any ideas please?