Local Resources not showing for Win 10 Pro Hyper-V VM

  1.    15 May 2016 #1

    Local Resources not showing for Win 10 Pro Hyper-V VM

    I've been troubleshooting this for ages, and am getting no-where fast!

    I'm basically trying to get a webcam to be available in the Windows 10 Pro Gen2 VM using Hyper-V.
    My host is Windows 10 Pro (on the same PC).

    I've read that I need to use RDP to connect (to redirect the local USB resources) to the target VM, and I believe I have everything setup right.

    Here's what works:
    - I can connect using Hyper-V and RDP fine
    - I can select to bring a local USB drive through to the target VM and it works fine

    Here's what doesn't work:
    - I don't see my PnP usb devices in the RDP option dialog box (I can see drives but not UBS devices). The webcam is not shown in 'Other supported Plug and Play (PnP) devices section'
    - I can't see the printer icon (enhanced session mode icon?) on the RDP top bar

    Here's what I have tried:

    - I have edited the group policy on both host and remote to allow the redirect (well at least I think I have the right setting)
    - I have set the Hyper-V setting to enable enhanced mode

    Imgur: The most awesome images on the Internet

    Any help would be really appreciated :)

      My ComputerSystem Spec

  2. jimbo45's Avatar
    Posts : 6,551
    Windows / Linux : Centos, Ubuntu, OpenSuse
       15 May 2016 #2

    Hi there

    If you can direct the USB controller to the VM does installing the driver (add new hardware) work. In theory it should since if the VM can see the USB controller you should be able to load whatever driver you like on to the VM whether or not the Host even recognizes it.

    That's how I connect some Vinyl cutting hardware and a minidisc recorder (professional model) to an XP VM - the Host doesn't even know about those devices.

    So long as the VM can see / access the USB controller then devices should be installable. Note in the initial instance simply plugging the device in won't cause windows to detect it if the driver isn't there --it's not a USB mass storage device which are PNP usually --try installing the driver and then see if the hardware works.

    Using VMWARE is no problem because it's working on "Para-Virtualisation" so the Virtual Bios handles the USB controller(s) -- however pass thru on HYPER-V in Enhanced mode is trying to use "Full Virtualisation" so the VM can use more of the actual Native hardware which require full windows drivers.

    How Passthru is implemented for USB on HYPER-V is still a bit of a mystery -- and as HYPER-V is usually intended for "Enterprise" / Work type servers and VM's it may be that limiting the full range of USB connectivity is all that's necessary for those types of servers.

    IMO if you need more sophisticated hardware than basic USB sticks / HDD's I'd look at alternative VM software - if you can get HYPER-V to work --well done but I think on this one you could be flogging a dead horse. If you DO get it to work please post back -- I suggest though install from within your Windows VM the actual webcam hardware driver with the USB plugged in - even if at first the Windows VM doesn't recognise it.

      My ComputerSystem Spec

  3.    15 May 2016 #3

    With a Windows 10 host and a Windows 10 guest, you should be able to use "Enhanced Session Mode" with Hyper-V.
      My ComputerSystem Spec

  4. jimbo45's Avatar
    Posts : 6,551
    Windows / Linux : Centos, Ubuntu, OpenSuse
       15 May 2016 #4

    kebero said: View Post
    With a Windows 10 host and a Windows 10 guest, you should be able to use "Enhanced Session Mode" with Hyper-V.
    Hi there

    I believe that's what the OP is trying but he can't get it working. I merely suggested trying to install the Native hardware driver (webcam) on the W10 Vm as usually the VM PNP on VM's works for mass storage devices (USB sticks, HDD's) -- more eseoteric devices such as Webcams, some cameras, lab equipment etc aren't PNP and need hardware drivers to be installed on the VM.

    I have for example a Samsung S5 phone -- on a Linux Host for example I can only get "Photo transfer mode" - only image files and the Host only sees the Internal phone as one device -- can't see the internal micro SD card at all.

    (Linux KVM is approx equiv to Windows HYPER-V - so you will need a load of fiddling around to get full USB passthru - even in enhanced mode --it *Might* or *Might not* work depending on the actual hardware).

    If I Plug / attach the phone to a W10 VM then it sees BOTH the internal phone and the micro sd card and can transfer as DATA. Works fine on Linux KVM Host with USB pass thru -- but it took a lot of fiddling around to get USB passthru to work - although phone now connects on the W10 VM both on USB2 and USB3 (much faster).

    If it still doesn't work I'd recommend trying VMWARE PLAYER (still free) as you can use your current VM as is -- V2V conversion (Free program) also availlable from VMWARE site too.

    For pure file transfer / media servers / basic office stuff / email / surfing / photoshop / stock trading programs etc things like HYPER-V are great - but once you start wanting to use a load of REAL Hardware then it's usually simpler to go the para virtualisation route (VBOX/VMWARE/QEMU etc), but if you CAN get HYPER-V to work then eventually you can run your VM's with a tiny OS on the HOST which should yield much better performance overall.

    You need to work out what your VM's need to do and then decide on how to virtualize them -- most of the posts I see on this section are of the type "I like the Idea of a VM - I'll install Windows and then see what happens".

    It's a great learning and testing tool and don't be discouraged but if you want your VM to be used for serious work you really need to decide on its workload / workmix and then you can make a good decision on how to Virtualise it.

      My ComputerSystem Spec

  5.    15 May 2016 #5

    Thanks for your help Jimbo45.
    So I've got some progress-

    I can now see the local resources in the RDP options tab. Basically, I'd changed the group policy to allow the redirection (shown in my earlier screenshots), but I hadn't rebooted since that last change (I'd done a gpedit.exe /force, but apparently that doesn't work for 'computer' GP edit's).

    So for example if I plug in a webcam to my host PC, I see that shown as 'USB Camera 2.0' under 'Other supported devices RemoteFX USB Devices'.

    I tick that device, then connect.

    Alas, I can't see that hardware in my target VM. No mention of USB devices at all in device manager.
    I've tried installing the device drivers, but they fail as the device cannot be detected.

    I've actually tried 2 cameras and a USB headset just for good measure, and nothing shows up. I wonder if I need to install some kind of USB controller in the target VM?

    I also noticed that if I add a USB drive in this way, it shows under network/TS Client- not sure if that's a clue.. oh, and I do not see the printer icon on my RDP top banner.

    Appreciate the help guys!
      My ComputerSystem Spec


Related Threads
Any clue why one of my local drives doesn't show in navigation pane? 76288
Hi I have a two laptops with Windows 10 x64. Recently I noticed new partition with next available letter. Size is 128mb and it can't be accessed. I checked in Disk Management but this partition is not listed there as per the below screen: ...
Hi everyone. I've upgrade 3 of my 4 W7 ultimate dekstops to W10 Pro, and so far 2 of my 6 laptops. For the most part I'm quite happy, but I have a particular problem with RDP to one of the machines. Although in local resources I've selected...
System specs are below. Virtualization is turned on in BIOS. Hyper-V is installed. When I start Hyper-V Manager it's not connected to a server. I click Connect to Server->Local Computer and get the error message (see below). I can see none of...
I paid for the app and it just started in windows 10 build 10056 not showing as paid. Is anyone else having this issue with paid apps in this build?
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 14:14.
Find Us