Windows 10: Help with mstsc to prevent "requested session access is denied" w/ RDC

  1.    20 Feb 2016 #1

    Help with mstsc to prevent "requested session access is denied" w/ RDC

    My problem in short: With Remote Desktop Connection I Get the error: “the requested session access is denied” with enhanced mode trying to login into my non-admin account on a VM. I can connect fine using non-enhanced mode.

    So I am running win 10 pro, and within it a win 10 pro VM via hyper-v. Since I want to hear audio in the VM I am trying to connect with enhanced session mode. The remote desktop connection and audio works fine if I log into the VM with it’s adminaccount. However when trying to login to my non-admin account on the VM I get the error: “the requested session access is denied”.

    I think the answer is already here:

    The answer in the link in short says:

    A user trying to connect to a RDS host 2008 R2 (workgroup environment) got the error message "requested session access is denied". The user is member of the local remotedesktop user group and
    the permission "Allow logon via Remotedesktop servies" is granted.
    When granting administrative rights the issue will not appear.

    Solution: Remove the /admin parameter in the remote desktop connection. The user was trying to connect to the RDS host console session. This of course will not work with user rights.

    mstsc /admin
    mstsc /console

    My admin skills are still developing and I don't really know what I am supposed to do here. Do I run this on this mstsc command on the host? Do I need to make sure some users are in the list before removing admin, and if so how?

    Also note on my VM I added the VM’s Admin andthe non-admin account to allow logons through Remote Desktop Services via: Computer Configuration -> Windows settings -> Security Settings -> Local policies -> User Rights Assignment
    These services already contained Administrators as well.

    Last edited by inertia; 20 Feb 2016 at 10:58.
      My ComputerSystem Spec

  2.    21 Feb 2016 #2

    It turns out my Pro version of windows was not whole because I upgraded it from Home to Pro and it was missing some features. Some Remote Desktop Policies were missing, which is why I was having issues. I hope to repair my install or may have to do a clean install.
      My ComputerSystem Spec


Related Threads
W10 guest running on Fedora 23 in Virtualbox. Ok, I did something stupid. I deleted the Winsock entries in my registry without saving them first. Yes, cynical laughter is appropriate. However, after doing some frantic research, I found the...
So I bit the bullet and "upgraded" my laptop from Windows 7 to 10. I expected to find a few things that didn't work anymore, but not so soon as this. I keep it in sync with my desktop PC (running XP) by net-sharing its hard drive, with...
Hi, hopefully someone has overcome this issue already. I received the Windows 10 upgrade and things worked fine - including copying files to my NAS. However I decided to do a clean install on a new SSD drive and when logged into that Windows 10 I...
ERROR MESSAGE Access Denied You don't have permission to access "" on this server.Reference #18.b1f31502.1439008845.47ab9a03 Hello there, I use steam. So basically what's happening...
Unable to delete folder, unable to change permissions, and unable to get One Drive to read to Documents folder correctly. I have attempted five times and each time it fails. So I try to delete the One Drive folder so I can reboot and try again,...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 23:13.
Find Us