Windows 10: My VMware Player has been crashing a lot Solved


  1. Posts : 478
    Windows 10.0.16299.19 (1709) Home 64-bit
       15 Dec 2015 #1

    My VMware Player has been crashing a lot


    My VMware Player has been crashing a lot. In fact once there was a series of about 5 fatal error dialogs which cascaded in a rather aesthetic and soothing fashion. Before I go to VMware for help, does anyone here have any advice which might smooth out the process.
      My ComputerSystem Spec


  2. Posts : 478
    Windows 10.0.16299.19 (1709) Home 64-bit
    Thread Starter
       16 Dec 2015 #2

    (Sorry for posting the OP in the wrong place.)

    I narrowed down the cause of the crashes to the USB ports. I'm going to try changing the ports from 3.0 to 2.0. I can't find any information on this type of issue in the PDF docs or at the website. Maybe it'll crash again soon and generate a report/log which I can submit to VMware.

    Edited to add:

    Good news and bad new. The good news is that I now have an error report. The bad news obviously is that switching to 2.0 didn't work.
    Last edited by gregyurkon; 16 Dec 2015 at 03:09. Reason: Additional information.
      My ComputerSystem Spec


  3. Posts : 478
    Windows 10.0.16299.19 (1709) Home 64-bit
    Thread Starter
       16 Dec 2015 #3

    I'm a firm believer in the maxim, "If all else fails, read the instructions," but, in this case, the instructions didn't tell me anything I didn't already figure out. I uninstalled the Player and reinstalled it, to no avail. I did discover that, if I ignore the fact that the docs and the menus say that it's possible to switch the USB back to the host system, and leave it connected to the VM, things work just fine. Switching the USB back and forth worked when I first installed the Player. I don't know what changed.
      My ComputerSystem Spec

  4.    20 Dec 2015 #4

    This is really annoying - it's a VC++ runtime error regarding virtual protection - strangely enough USB swapping does not work on VMWare 12.1 on Linux either ( no error, just does not appear as a connected device on reconnect)
      My ComputerSystem Spec


  5. Posts : 478
    Windows 10.0.16299.19 (1709) Home 64-bit
    Thread Starter
       20 Dec 2015 #5

    Thanks for the information. Fortunately, right now, I don't need the USB ports on the VM; it's easier to transfer files with copy/paste. I just need to make sure that the VM isn't infected first.
      My ComputerSystem Spec

  6.    21 Jan 2016 #6

    My VMware Workstation 12 gets the C++ errors when I try using a USB device (that doesn't exist, but is labeled as one that does). Only fix: end the vmware process in taskmanager, which causes the VMware to think it's "running" and so I have to restart my PC because I can't take over the running but not running vm. I also get this error when trying to update MSDOS to Win 95...
      My ComputerSystem Spec


 

Related Threads
How to Install Windows 10 as Virtual Machine in VMware Player VMware Player is a free desktop application that lets you run a virtual machine on a Windows or Linux PC. This tutorial will show you how to install either the 32-bit or 64-bit...
After downloading VMware player 2.5.5-328052 yesterday & during the install phase my screen turned blue with a message "something went wrong with your PC & needs to restart" (close wording to that). After restarting VMware player is not listed in...
Solved VMware workstation 12 player in Virtualization
I have used Hyper V mainly, but have given the latest VMware a go. So far I'm liking it. Something it does that Hyper V didn't is allow me to connect USB device. I have not figured out the setting so I can see my host drives though. How do I enable...
VMWare Player 7.0 Released in Virtualization
VMWare Player 7.0 Released. So far the difference I see with the W Ten latest build VM as compared to Player 6.x is it gets to the Welcome Screen faster. Also it seems that W Ten is a bit more stable. Although Explorer Windows still open...
OK, lately I've been having issues with my DVD-ROM and recently replaced it with a new one as I thought that might solve the issue - that is it was randomly disappearing from the system, requiring a re-boot to get it back. Anyway I now realize...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 06:27.
Find Us