.ISO file is not mounting in windows 10


  1. Posts : 2
    Windows 10
       #1

    .ISO file is not mounting in windows 10


    I downloaded a game file which happened to be .ISO file and i could not mount it and because of that i can't install it in my computer. i thought it was a corrupted file i downloaded but i tried mounting another game which i had installed already but could not mount it either so i cannot mount any .ISO file on my computer by any means. I have tried daemon tools, virtual clonedrive but no luck with that. And this problem is in my windows 10 when i Google it i find this problem mentioned on windows 8.1 and gave it a shot but those methods mentioned for windows 8.1 does not seem to work for windows 10. would really appreciate the help.
      My Computer


  2. Posts : 69,318
    64-bit Windows 11 Pro for Workstations
       #2

    Hello prejwal, and welcome to Ten Forums. :)

    Do you have this issue with all ISO files, for example a Windows 10 ISO, or just these game ISO files?

    If you like, download and merge the .reg file for the listed ISO file listed in the table in OPTION TWO of the table below to see if that may help allow you to mount the ISO. It will restore the default associations for ISO files.

    https://www.tenforums.com/tutorials/8...dows-10-a.html
      My Computers


  3. Posts : 2
    Windows 10
    Thread Starter
       #3

    thank you,
    those files i tried were all game .ISO files i haven't tried any other type of .ISO files. i am at work right now so i can't try it but as soon as i go home will try to mount some other different type. But the thing is the same game file i mounted last week can't mount it now.
      My Computer


  4. Posts : 69,318
    64-bit Windows 11 Pro for Workstations
       #4

    Ok. I'll be here when you're ready. :)
      My Computers


  5. Posts : 3
    windows 10
       #5

    Hi Brink,
    I jump on this thread since I see there is not much activity here for a month now, but I have a similar problem with my Windows 10.
    A few days ago I used makemkv to convert one of my old iso dvd to mkv format, so I can watch it without the hassle of mounting, all the dvd menus etc. That worked fine, but since then I am unable to mount any iso file, with any software i downloaded. I tried first with daemon tools, then with virtual clonecd, and virtualcdEMU, and of course the native windows mounting option, but nothing works. I checked the registry with CCleaner, and also checked the windows event logs for any kind of error or warning message, but it seems that when I try to mount an iso file there is no event log created about it. If I use the native windows option, I get a popup window telling me: Sorry, there was a problem mounting the file.
    Any tips, or advice?
    Thanks in advance
      My Computer


  6. Posts : 197
    Windows 10 Pro x64
       #6

    Hi there! For an unknown reason, I'm having this same problem too in two W10 installations. Happens with all iso images.

    Edit: I just found it only happens with .iso files created from music CDs.
    Last edited by Ghost82; 05 Jan 2016 at 17:46.
      My Computer


  7. Posts : 3
    windows 10
       #7

    Nice, then this problem is not uniquely experienced by me. Sadly though my experience so far is that I can't mount any kind of iso file, not just music.
      My Computer


  8. Posts : 197
    Windows 10 Pro x64
       #8

    Nope, is not nice, hahaha.
      My Computer


  9. Posts : 3
    windows 10
       #9

    Finally I found a way to resolve my problem. Hope this helps others too in the future, and maybe Ghost 82, you could also check this out too. So...
    It turned out that since my dvd-rom is a bit old and I don't use it for years now, I have not noticed that somehow it disappeared from my drive list from 'This PC' and probably because windows somehow still detected it, since I could open or close the dvd-rom (so phisically it was still functional), it tried to give it a letter, but failed probably in the process. And surely that was why every time I tried to mount anything It got stuck at that point where the letter assignment should have taken place.
    First I tried to simply disconnect the dvd-rom from the motherboard, but the issue was still the same, so I checked the device manager in the control panel, and I saw a yellow triangle by the dvd-rom. In its properties panel, there was a warning, that it's driver had failed to update with the last win 10 update. I had to delete the whole device maybe 2 or 3 times and then detect it again, to download its proper driver. (at the first try the update failed again) After the successful driver update the device finally showed up in the 'This PC' window also, and luckily my mounting process encountered no issues afterwards.
    Hope this helps some.
    TL;DR: - Win 10 automatic update screwed up DVD-ROM driver and the Drive Letter system, had to delete the device from Device manager and re-detect it and reinstall it's drivers, so the Drive letters could be assigned correctly to mounted ISO files.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 17:12.
Find Us




Windows 10 Forums