1.    24 Nov 2015 #1
    Join Date : Nov 2015
    Posts : 2
    Windows 10

    .ISO file is not mounting in windows 10


    I downloaded a game file which happened to be .ISO file and i could not mount it and because of that i can't install it in my computer. i thought it was a corrupted file i downloaded but i tried mounting another game which i had installed already but could not mount it either so i cannot mount any .ISO file on my computer by any means. I have tried daemon tools, virtual clonedrive but no luck with that. And this problem is in my windows 10 when i Google it i find this problem mentioned on windows 8.1 and gave it a shot but those methods mentioned for windows 8.1 does not seem to work for windows 10. would really appreciate the help.
      My ComputerSystem Spec
  2.    24 Nov 2015 #2
    Join Date : Oct 2013
    Posts : 25,682
    64-bit Windows 10 Pro build 17046

    Hello prejwal, and welcome to Ten Forums.

    Do you have this issue with all ISO files, for example a Windows 10 ISO, or just these game ISO files?

    If you like, download and merge the .reg file for the listed ISO file listed in the table in OPTION TWO of the table below to see if that may help allow you to mount the ISO. It will restore the default associations for ISO files.

    https://www.tenforums.com/tutorials/8...dows-10-a.html
      My ComputersSystem Spec
  3.    24 Nov 2015 #3
    Join Date : Nov 2015
    Posts : 2
    Windows 10
    Thread Starter

    thank you,
    those files i tried were all game .ISO files i haven't tried any other type of .ISO files. i am at work right now so i can't try it but as soon as i go home will try to mount some other different type. But the thing is the same game file i mounted last week can't mount it now.
      My ComputerSystem Spec
  4.    24 Nov 2015 #4
    Join Date : Oct 2013
    Posts : 25,682
    64-bit Windows 10 Pro build 17046

    Ok. I'll be here when you're ready.
      My ComputersSystem Spec
  5.    30 Dec 2015 #5
    Join Date : Dec 2015
    Posts : 3
    windows 10

    Hi Brink,
    I jump on this thread since I see there is not much activity here for a month now, but I have a similar problem with my Windows 10.
    A few days ago I used makemkv to convert one of my old iso dvd to mkv format, so I can watch it without the hassle of mounting, all the dvd menus etc. That worked fine, but since then I am unable to mount any iso file, with any software i downloaded. I tried first with daemon tools, then with virtual clonecd, and virtualcdEMU, and of course the native windows mounting option, but nothing works. I checked the registry with CCleaner, and also checked the windows event logs for any kind of error or warning message, but it seems that when I try to mount an iso file there is no event log created about it. If I use the native windows option, I get a popup window telling me: Sorry, there was a problem mounting the file.
    Any tips, or advice?
    Thanks in advance
      My ComputerSystem Spec
  6.    05 Jan 2016 #6
    Join Date : Nov 2015
    Spain
    Posts : 165
    Windows 10 Pro x64

    Hi there! For an unknown reason, I'm having this same problem too in two W10 installations. Happens with all iso images.

    Edit: I just found it only happens with .iso files created from music CDs.
    Last edited by Ghost82; 05 Jan 2016 at 17:46.
      My ComputerSystem Spec
  7.    15 Jan 2016 #7
    Join Date : Dec 2015
    Posts : 3
    windows 10

    Nice, then this problem is not uniquely experienced by me. Sadly though my experience so far is that I can't mount any kind of iso file, not just music.
      My ComputerSystem Spec
  8.    03 Feb 2016 #8
    Join Date : Nov 2015
    Spain
    Posts : 165
    Windows 10 Pro x64

    Nope, is not nice, hahaha.
      My ComputerSystem Spec
  9.    03 Feb 2016 #9
    Join Date : Dec 2015
    Posts : 3
    windows 10

    Finally I found a way to resolve my problem. Hope this helps others too in the future, and maybe Ghost 82, you could also check this out too. So...
    It turned out that since my dvd-rom is a bit old and I don't use it for years now, I have not noticed that somehow it disappeared from my drive list from 'This PC' and probably because windows somehow still detected it, since I could open or close the dvd-rom (so phisically it was still functional), it tried to give it a letter, but failed probably in the process. And surely that was why every time I tried to mount anything It got stuck at that point where the letter assignment should have taken place.
    First I tried to simply disconnect the dvd-rom from the motherboard, but the issue was still the same, so I checked the device manager in the control panel, and I saw a yellow triangle by the dvd-rom. In its properties panel, there was a warning, that it's driver had failed to update with the last win 10 update. I had to delete the whole device maybe 2 or 3 times and then detect it again, to download its proper driver. (at the first try the update failed again) After the successful driver update the device finally showed up in the 'This PC' window also, and luckily my mounting process encountered no issues afterwards.
    Hope this helps some.
    TL;DR: - Win 10 automatic update screwed up DVD-ROM driver and the Drive Letter system, had to delete the device from Device manager and re-detect it and reinstall it's drivers, so the Drive letters could be assigned correctly to mounted ISO files.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
BSOD mounting ISO natively from samba share
To reproduce: 1) You need a network share drive on another device that is mapped locally as a drive. 2) Place an ISO image of some kind in a location on that shared drive. 3) Attempt to open the ISO natively (double-click or right click->...
BSOD Crashes and Debugging
Solved Mounting ISO file
I just recently updated from windows 7 to windows 10 I use ISO files regularly and need to get this fixed. I am unable to mount any iso files or even run and iso mounting software. I keep reading that all i have to do is select the file and i should...
Virtualization
windows 10 autoattended file ( answer file )
Do you have any idea how to create Windows 10 autoattended file ? It is normal for system builder use. Any help would be appreciated.:):)
Installation and Upgrade
Error found in File explorer / .iso mounting
Hi there Seems I've got a hideous error here -- Mounting a DVD (bog standard - not Blu ray) as an ISO file Windows explorer shows file size as a whopping 95 GB !!!!!!!! Handbrake then won't encode to mkv / mp4 file for my media streamer. ...
General Support
Upgraded by mounting iso and running setup.exe
Upgraded my Dell Inspiron 15R by mounting the iso I created from install.wim on a Oracle VB VM using WHS's ESD Converter tool. I copied the install.wim to the ESD Converter folder on my Lenovo 450K 3.4 Quad Core with 16GB ram and ran it there to...
Installation and Upgrade
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 13:23.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums