Windows 10: Networking woes again !!!!

Page 2 of 3 FirstFirst 123 LastLast
  1.    09 Oct 2014 #11

    badrobot said: View Post
    Hey Jimbo, I got 3 real machines and 2 virtuals (VMWare and Hyper-V). Not a single issue on network sharing. All 3 real machines see the 2 virtuals and the 2 virtual see the 3 real machines and tested file sharing across network including NAS. Everything is "A" okay...

    Attachment 6528

    Thank you @Kari for the step by step tutorial. This is my first time to use Hyper-V. I installed Win 7 Home Premium. However, Legacy Network Adapter did not work. I have to use the first method for Win 7 Ultimate and I got network connection right away. Thank you very much!

    Cheers!
    Hi there

    @Bad robot

    Did you try on a REAL W10 machine connecting a W10 VM on VMWARE 10 - Did you get ANY networking to work (I couldn't get ANYTHING in VMWARE when using a W10 HOST - no NAT / NO Bridged -- the adapters would not start ).

    I couldn't get any LINUX server either to connect to ANY W10 machine (real or Virtual) but the W10 machine COULD access the LINUX shares so not a complete disaster. The Linux machines could SEE the W10 machine and came back with the user name and password screen but then timed out.

    A Virtual W8.1 Machine running on Linux (using VMware) COULD access W10 though !!!

    I think this might be something to do with "Certificates" -- is there a way of disabling that whole kybosh. I'm running the ENTERPRISE version so it might be an added layer of built in security.

    However entering the full SMB address //jim@192.168.1.111 (address of the W10 VM) from a Linux server DOES give access so DNS too is hosed up somewhere along the line -- pinging greyfox (name of the remote W10 machine) returns different IP address to the actual address.



    Cheers
    jimbo
    Attached Thumbnails Attached Thumbnails snapshot38.png   snapshot37.png  
    Last edited by jimbo45; 09 Oct 2014 at 02:42.
      My ComputerSystem Spec


  2. Posts : 4,336
    Win 10 Pro x64
       09 Oct 2014 #12

    I don't have VMware installed on Win 10 real machine but this Win 10 real machine and the Win 10 virtual machine (VM on Win 8 host) and see and share file with each other.

    I haven't tried on Linux yet so I can't comment.



    @Kari, the Win 7 Home Premium on Hyper-V had an erratic network connection last night (it disconnects itself). So this is the network configuration right now and so far I'm not having any issues:

    Click image for larger version. 

Name:	hyperv_network.jpg 
Views:	45 
Size:	494.1 KB 
ID:	6678
      My ComputerSystem Spec


  3. Posts : 1,468
    W7 Ultimate SP1 (64 bit), LM 18.1 MATE (64 bit), W10IP VM, W10 Home
       09 Oct 2014 #13

    Once I set my DNS server to the IP address of my friend's Linux PC (it has a local DNS server) I could connect my W10TP VM to my host PC and my friend's PC without any issues.

    Note:
    I'm running W10TP on the Linux version of VMware Player (on Linux Mint 17).

    Playing a video via the network:

    Click image for larger version. 

Name:	Networking - Playing Video.png 
Views:	41 
Size:	248.4 KB 
ID:	6708

    I love the new "Window Snap" options.
    Last edited by lehnerus2000; 10 Oct 2014 at 01:18. Reason: Picture Added
      My ComputerSystem Spec

  4.    10 Oct 2014 #14

    Hi there

    I think people have MISUNDERSTOOD the problem.

    It's NOT W10 accessing other computers -- W10 can see and access the other computers (including another W10, Linux, W7, XP and W8.1) both REAL and Virtual.

    IT'S THE OTHER WAY AROUND. (FROM computer X TO W10).

    The problem is other than W8.1 and W10 computers the other machines CANNOT ACCESS W10's even though they can see them on the network.

    Access only seems to be possible if you actually type in an IP address (IPV4 type on a LAN such as 192.168.1.x). Doesn't work via Hostname.

    Might work on a domain -- that's overkill for a HOME network which usually has 3 computers active at any one time.

    So "peeps" - please try ACCESSING the W10 machine FROM a computer with an earlier OS than W8.1 -- for example W7 and if possible a Linux machine too.


    Cheers
    jimbo
      My ComputerSystem Spec


  5. Posts : 1,468
    W7 Ultimate SP1 (64 bit), LM 18.1 MATE (64 bit), W10IP VM, W10 Home
       10 Oct 2014 #15

    Aha!


    I see what you mean.

    When I ran the Troubleshooter it gave me this message:

    Click image for larger version. 

Name:	Networking - Missing Protocols.png 
Views:	130 
Size:	14.7 KB 
ID:	6797
      My ComputerSystem Spec

  6.    11 Oct 2014 #16

    lehnerus2000 said: View Post
    I see what you mean.

    When I ran the Troubleshooter it gave me this message:

    Click image for larger version. 

Name:	Networking - Missing Protocols.png 
Views:	130 
Size:	14.7 KB 
ID:	6797
    Hi there

    Thanks for testing --it's often difficult to describe accurately and understandably what a Network problem is - especially if it partially works.

    Note you can still access W10 Shares FROM from Linux / XP / W7 by typing in the IP address of the W10 name -- from Linux get it via NSLOOKUP (PING returns some sort of silly address) and on windows machine itself IPCONFIG works.

    I hope this is fixed before final release - I don't want to maintain manual hostnames and addresses in various config files.

    Note VMWARE is also releasing VMWARE Workstation 11 and the update for VMPLAYER next month so NAT and BRIDGED networking might be fixed when running VMWARE on a HOST W10 machine.

    So two problems - SHARING FROM Linux / W7 /XP etc machine TO W10 (It's OK from W8/W10 to W10) and when installing VMWARE on a W10 HOST networking doesn't work.

    Cheers
    jimbo
      My ComputerSystem Spec


  7. Posts : 1,468
    W7 Ultimate SP1 (64 bit), LM 18.1 MATE (64 bit), W10IP VM, W10 Home
       11 Oct 2014 #17

    My VMware Player is set to NAT.
    I haven't tried "Host Only" or "Bridged".

    I can't access W10 from Linux Mint using the IP Address either, as Caja rejects it as a valid path, no matter how many slashes I include before it.
    I also tried to access it using Firefox (on LM17) but that failed too.

    Using "smbclient" in the Terminal shows the correct shared folders on the W10 VM.
    Last edited by lehnerus2000; 11 Oct 2014 at 07:25.
      My ComputerSystem Spec


  8. Posts : 1,468
    W7 Ultimate SP1 (64 bit), LM 18.1 MATE (64 bit), W10IP VM, W10 Home
       11 Oct 2014 #18

    Pebkac


    I've got Networking running now.

    It was a PEBKAC issue.
    W10 INCOMING connections - missing network protocols
      My ComputerSystem Spec

  9.    05 Jan 2015 #19

    Kari; the words legacy adapter caught my eye.
    Shipinomore here. I installed Ubuntu and no problems and connected to the internet.
    then I installed Vista home premium and noticed a note that said I should use a legacy adapter and not the Realtek that worked with Ubuntu.
    right now I am trying to find out if legacy is something in the bios? I thought I have seen it there.
    I am using a
    HP Touchsmart AIO 23
    8 gig memory
    putting all files created by Hyper V on a ext. 2t hard drive.
    any help would be appreciated.
    Larry
      My ComputerSystem Spec


  10. Posts : 11,237
    Windows 10 Pro
       05 Jan 2015 #20

    shipinomore10 said: View Post
    Kari; the words legacy adapter caught my eye....
    ...
    I am trying to find out if legacy is something in the bios? I thought I have seen it there.
    Legacy adapters in Hyper-V work exactly as normal Hyper-V virtual adapters, and they are connected to exatcly the same virtual switches than normal virtual network adapters. The difference is in what and how they emulate.

    From Microsoft TechNet:

    • A network adapter requires a virtual machine driver in order to work, but offers better performance. This driver is included with some newer versions of Windows. On all other supported operating systems, install integration services in the guest operating system to install the virtual machine driver. For instructions, see Install a Guest Operating System. For more information about which operating systems are supported and which of those require you to install integration services, see About Virtual Machines and Guest Operating Systems (About Virtual Machines and Guest Operating Systems for Hyper-V).
    • A legacy network adapter works without installing a virtual machine driver. The legacy network adapter emulates a physical network adapter, multiport DEC 21140 10/100TX 100 MB. A legacy network adapter also supports network-based installations because it includes the ability to boot to the Pre-Execution Environment (PXE boot). However, the legacy network adapter is not supported in the 64-bit edition of Windows Server 2003.
    Example from my Vista vm. After creating the vm and noticing it did not have network connectivity, I removed the "normal" Hyper-V network adapter and added a legacy adapter:

    Click image for larger version. 

Name:	2015-01-06_00h21_42.png 
Views:	31 
Size:	57.1 KB 
ID:	10093

    Then I connected this legacy adapter to my external LAN switch which uses the host's Realtek NIC:

    Click image for larger version. 

Name:	2015-01-06_00h23_07.png 
Views:	32 
Size:	66.0 KB 
ID:	10094

    You don't have to / need to create different virtual switches for legacy adapter. Read more about Hyper-V virtual switches: Hyper-V Virtual Switch Manager.

    Kari
    Last edited by Kari; 05 Jan 2015 at 19:09. Reason: Lots of typos!
      My ComputerSystem Spec


 
Page 2 of 3 FirstFirst 123 LastLast

Related Threads
Installation woes in Installation and Upgrade
Have this on 3 different machines of different configs and I am now trying to get it on a shuttle XPC to test with xbmc but not having no luck just keep getting same error. seems really slow to get as far as it does but then falls over. windows...
Networking woes again (W10) in Network and Sharing
Hi there Networking connectivity seems to get broken every so often -- I have shares on two W10 machines (Local accounts) that connect just fine. If I come back to the computer say 45 mins later I get the computers can see each other but cannot...
So I think I figured out one of the main reasons I have had trouble sharing within my network. I have been tending to bounce back and forth between Microsoft account and regular local account on my systems. Not like every other week or something,...
Testing Networking in Network and Sharing
Testing 123 I have to be the first networking post. :)
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 07:01.
Find Us