"VMware Workstation Pro can't run on Windows" Message

Page 1 of 6 123 ... LastLast
  1. muchomurka's Avatar
    Posts : 710
    finally UPGRADED from ltsc to win7
       #1

    "VMware Workstation Pro can't run on Windows" Message - UPDATED


    Symptoms:

    After installing new Cumulative Update, VMware Workstation software cannot start. Furthermore, the following message is displayed:

    VMware Workstation Pro can't run on Windows
    Check for an updated version of this app that runs on Windows.
    Compatibility Assistant
    Check for updates - Dismiss


    "VMware Workstation Pro can't run on Windows" Message-1.png

    Affected software:

    VMware Workstation Player or Pro version 12 and 14, installed in Windows 10 version 1903.

    Cause:

    As part of Cumulative Update (September 26, 2019; OS Build 18362.387 or newer) installation, database of programs prohibited by MS was updated, and invasive "Compatibility Assistant" component now prevents older VMware Workstation programs from run.

    Resolution:

    To run VMware Workstation programs again, it is necessary to either override "Compatibility Assistant" default behavior or replace one of "Compatibility Assistant" database files with an older version (before Cumulative Update mentioned above was installed). Use one of the following methods.

    1. (quick and simple): Apply the following regfile to unblock VMware Workstation Player & Pro
    Code:
    Windows Registry Editor Version 5.00
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags]
    "{3d9912c3-cb54-4f34-ab71-1d429553bf96}"=dword:00000077
    "{66f21bbc-149a-411b-8e11-880af7c1266c}"=dword:00000077
    vmw.reg
    Also suitable for Group Policy deployment.

    2. (thanks to Biohazard): To gain full control over "Compatibility Assistant" at local computer, install Compatibility Administrator Tool & unblock WMware Workstation; see the post "VMware Workstation Pro can't run on Windows" Message for further info; the program to be run is:
    Code:
    "C:\Program Files (x86)\Windows Kits\10\Assessment and Deployment  Kit\Application Compatibility Toolkit\Compatibility Administrator  (64-bit)\Compatadmin.exe"
    Or - if you do not need to install it - extract the following zipfile.
    Compatibility Administrator (64-bit).zip

    3. (not working under some circumstances): Use Local or Group Policy to disable Application Compatibility components.
    "VMware Workstation Pro can't run on Windows" Message-pol.png
    Sadly, this method does not work in my test environment, someone else can try it too.

    The following two methods are now obsolete.

    4. If you use a backup program which allows granular restore (on per-file basis)
    - restore single and only one file C:\Windows\apppatch\sysmain.sdb from backup taken before the toxic Cumulative Update was installed

    5. In other cases, manually replace the file C:\Windows\apppatch\sysmain.sdb
    - in File Explorer, navigate to C:\Windows\apppatch folder
    - rightclick on file sysmain.sdb, click Properties, Security, Advanced
    - set Owner to Administrators, click OK
    - grant Full Control permissions to Administrators, click OK
    - rename the file sysmain.sdb to sysmain.bad
    - unpack AllowVmware.zip file attached below to your desktop; it includes older sysmain.sdb file
    - copy (not move) unpacked sysmain.sdb to C:\Windows\apppatch folder.
    AllowVmware.zip
    can be also downloaded here: AllowVmware.zip | Uloz.to

    While using one of last two methods,, be prepared to apply this resolution again after some (not necessarily all) future Cumulative Updates.

    Comments:

    1. VMware Workstation 12.5.9 is the last version which can be run on processors belonging to Intel Core2 family, so upgrading to VMware version 15 (moreover expensive) isn't an option for some users.
    2. The same symptoms arise for many other installers and programs; sometimes they can be resolved either by renaming the installer/program, or by using some method described here.
    3. Related thread: https://answers.microsoft.com/en-us/...f-fec7daec40d7
    Last edited by muchomurka; 09 Oct 2019 at 08:35. Reason: more solutions added
      My Computer

  2. Danielx64's Avatar
    Posts : 64
    Windows 10 Pro
       #2

    Oh dear, time to disable windows update.....
      My Computer

  3. jimbo45's Avatar
    Posts : 9,059
    Windows / Linux : Arch Linux
       #3

    Hi folks

    @muchomurka
    @Danielx64

    working fine for me on latest 18363 / 388 Windows build (1909) on bog standard HP envy laptop with core i5 processor.

    "VMware Workstation Pro can't run on Windows" Message-vmware2.png

    "VMware Workstation Pro can't run on Windows" Message-vmware1.png

    "VMware Workstation Pro can't run on Windows" Message-388.png

    If you have any problems with installing simply uninstall your previous version and download the new one manually. (Don't forget your serial number though when re-installing !!!). Re-boot after uninstalling previous version and re-install.

    I've tested both methods on 2 identical laptops (upgrade, uninstall and re-install new version) - both worked for me.

    Cheers
    jimbo
      My Computer

  4. muchomurka's Avatar
    Posts : 710
    finally UPGRADED from ltsc to win7
    Thread Starter
       #4

    working fine for me on latest 18363 / 388 Windows build (1909) on bog standard HP envy laptop with core i5 processor
    omg...

    i5 ∉ Core2
      My Computer


  5. Posts : 4
    Windows 10
       #5

    I've got the same problem. had to move to my backup OS until its resolved.

    Really annoying.

    Tried multiple VM versions even 15.5 same issue.
      My Computer

  6. sobakasu's Avatar
    Posts : 1
    Windows 10
       #6

    I am getting this message today after windows updated last night. I have VMware workstation 14 player
      My Computer



  7. Posts : 1
    windows
       #7

    Absolute legend!
    Was beginning to get quite frustrated as other solutions, such as disabling hyper-v hadn't worked.
    Thanks a ton.
      My Computer


  8. Posts : 1
    windows 10
       #8

    Thank you

    I'd left a job running over night and came in to find that not only had Microsoft decide that my PC could be rebooted, I had also lost access to VMware.

    Arrrgh...
      My Computer


  9. Posts : 514
    Windows 10 x64
       #9

    Many thanks muchomurka !
    Restored the file from a previous Windows image. Timebeing this works.
    Guess it is best to keep a copy of the sysmain.sdb readily available somewhere: am sure Microsoft will update at the next update...

    Again - many thanks!
      My Computer


  10. Posts : 2
    windows 10
       #10

    windows will NOT allow me to change permissions to administrator, it wont allow me to make any changes to permissions whatsoever
      My Computer


 

Related Threads
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 20:54.
Find Us




Windows 10 Forums