"VMware Workstation Pro can't run on Windows" Message

Page 2 of 7 FirstFirst 1234 ... LastLast

  1. Posts : 913
    CP/M
    Thread Starter
       #11

    prophat: change ownership before permissions.
      My Computer


  2. Posts : 2
    windows 10
       #12

    muchomurka said:
    prophat: change ownership before permissions.
    windows wont allow it

    - - - Updated - - -

    i've tried every work around i can think of
      My Computer


  3. Posts : 913
    CP/M
    Thread Starter
       #13

    To change file ownership you must be logged as member of administrators group.
    Regarding help request - it should include more info; workarounds tried, detailed description of failing action and exact text of error msg or screenshot needed.

    In the case the "cannot change file ownership" problem persists, I recommend to create another thread as it is not directly related to vmware.
      My Computer


  4. Posts : 83
    Windows 10 Pro
       #14

    jimbo45 said:
    Hi folks

    @muchomurka
    @Danielx64

    working fine for me on latest 18363 / 388 Windows build (1909) on bog standard HP envy laptop with core i5 processor.

    Attachment 250011

    Attachment 250012

    Attachment 250013

    If you have any problems with installing simply uninstall your previous version and download the new one manually. (Don't forget your serial number though when re-installing !!!). Re-boot after uninstalling previous version and re-install.

    I've tested both methods on 2 identical laptops (upgrade, uninstall and re-install new version) - both worked for me.

    Cheers
    jimbo
    Well that's great because you are running V 15.5, I'm not. I am still on V14.
      My Computer


  5. Posts : 675
    Windows 10 x64
       #15

    Just FWIW only ...
    I, myself, initially skipped/forgot the step: "grant Full Control permissions to Administrators, click OK"
    My mistake, of course, but Windows did not allow change permissions then.
    I needed to do that step and it worked fine. Maybe you skipped that step as well?
    I am not an expert, just my 2cents only...

    -
    "VMware Workstation Pro can't run on Windows" Message-snagit-06102019-081313.png


      My Computer


  6. Posts : 11,172
    Windows / Linux : Arch Linux
       #16

    Danielx64 said:
    Well that's great because you are running V 15.5, I'm not. I am still on V14.
    Hi there
    @Danielx64

    I think VMWare says that V14 isn't compatible with later versions of Windows --- either keep older versions of Windows, run VMWare on a Linux host with latest versions of Windows as a VM or use the FREE VMplayer at 15.5 release level program.

    Actually when something doesn't work (I'm not having a go at you BTW) it helps people to possibly find a solution if there is one to state the release / build of the product(s) that are giving trouble including the Host build e.g the Windows release level -- run winver to get that info easily.

    Seems fairly clear to me -- software sometimes needs to be updated when the OS is significantly changed. It's annoying at times but that's a fact of life with things I.T (or any technology --- who uses typewriters any more !!.)

    Cheers
    jimbo
      My Computer


  7. Posts : 913
    CP/M
    Thread Starter
       #17

    tfwul: The sequence must be Ownership - Permissions - Rename, nothing else works.

    Danielx64: Waste of time to argue with... You Know Who :)
      My Computer


  8. Posts : 2
    Windows 10
       #18

    This happened to me with V15 and I signed up just so I can download the older file.

    However I found if you simply rename this file vmware will start again but may break other things.

    I do not recommend any modification to sysmain.sdb as it's part of the Compatibility Assistant and may leave you broken and/or vulnerable. Upgrading to 15.5 solved the issue.
      My Computer


  9. Posts : 3
    windows
       #19

    Is this going to be the official MS position, so the older vmware software will "never" work again?
      My Computer


  10. Posts : 17,636
    Windows 10 Pro
       #20

    fpefpe said:
    Is this going to be the official MS position, so the older vmware software will "never" work again?
    Thinking this realistically, Microsoft cannot be held responsible for keeping all older software functional in Windows. That would be an impossible task.

    In this case, it is up to VMware to fix it, to provide an update.

    Kari
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 04:56.
Find Us




Windows 10 Forums