After August update Hyper-v Win10VM crashes when connecting via RDP

Page 3 of 3 FirstFirst 123

  1. Posts : 1
    Windows
       #21

    I have a customer who had this exact problem. After trying everything mentioned here (plus more) - the crashing of the VM persisted. After 4 hours we ended up restoring a backup from prior to the Windows update and set the vm to defer updates.

    We are anxious to hear if Microsoft gets this resolved - or if a better fix is identified.
      My ComputerSystem Spec


  2. Posts : 33
    Windows 10 Home x64 (Build 16299)
       #22

    Techface said: View Post
    Local Computer Policy -> Computer Configuration -> Administrative Templates -> Windows Components -> Remote Desktop Services -> Remote Desktop Session Host -> Remote Session Environment -> Using WDDM Remote Desktop Connection Video Drivers -> set to DISABLED
    I recommend to do it like so rather than editing the registry like I posted earlier. Even though it should come down to the same effect.

    Note: The setting needs a reboot to be effective!

    @Techface Good to know which update causes it. I wasn't sure but it couldn't have been there all along since 1903 was released. If memory serves, the troubles started only a few weeks ago in my case.
      My ComputerSystem Spec


  3. Posts : 1
    Windows 10 1903
       #23

    MontyP said: View Post
    Thanks for that tip.
    In the mean while, MS released (in the last 24 hrs) KB4512941 as a follow on to KB4512508. I tried it to see if it fixed the subject problem but, unfortunately, it didn't. -> Roll back KB4512508 and disable updates seems to be the way to go for now.
    Has this been fixed properly by Microsoft yet?
    I've just stumbled across this problem in the last couple of days when my Hyper-V Windows 10 VM upgraded to 1903. My Hyper-V Host however was still on 1803, which I'm upgrading now manually to 1903. KB4512508 isn't currently installed on my host, but I guess it must be on the VM...no it's not? What now....
    Code:
    Source        Description      HotFixID      InstalledBy          InstalledOn
    ------        -----------      --------      -----------          -----------
    AJNDESKTOPQA  Security Update  KB4515383     NT AUTHORITY\SYSTEM  14/09/2019 12:00:00 AM
    AJNDESKTOPQA  Update           KB4515384     NT AUTHORITY\SYSTEM  14/09/2019 12:00:00 AM
    The VM doesn't have internet either? There's no DNS returned with ipconfig /all and adding them manually doesn't work either?
    Code:
    Windows IP Configuration
    
       Host Name . . . . . . . . . . . . : AjNDesktopQA
       Primary Dns Suffix  . . . . . . . :
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No
       DNS Suffix Search List. . . . . . : gateway
    
    Ethernet adapter Ethernet 3:
    
       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : TAP-Windows Adapter V9
       Physical Address. . . . . . . . . : 00-FF-9E-87-EF-E1
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
    
    Ethernet adapter Ethernet 4:
    
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft Hyper-V Network Adapter #2
       Physical Address. . . . . . . . . : 00-15-5D-01-01-0C
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
    <snip>
       IPv4 Address. . . . . . . . . . . : 192.168.0.26(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Lease Obtained. . . . . . . . . . : Saturday, 14 September 2019 11:44:05 PM
       Lease Expires . . . . . . . . . . : Sunday, 15 September 2019 12:44:19 AM
       Default Gateway . . . . . . . . . : 192.168.0.1
       DHCP Server . . . . . . . . . . . : 192.168.0.1
       DHCPv6 IAID . . . . . . . . . . . : 385881437
       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-25-0E-82-5F-00-15-5D-01-01-0C
       NetBIOS over Tcpip. . . . . . . . : Enabled
    
    Ethernet adapter Ethernet 2:
    
       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : VPN Client Adapter - VPN
       Physical Address. . . . . . . . . : 00-AC-84-1F-62-F1
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
    Last edited by AjN3806; 5 Days Ago at 09:09.
      My ComputerSystem Spec


  4. Posts : 1
    Win10
       #24

    I can confirm having this problem. Seems to be related to enhanced sessions since August patch.
    This leads me to believe when MS fixed the Bluekeep vulnerability they also broke RDP connections to HyperV guests.
    I used to be able to "save" a machine in running state and just restore and continue where I left of.
    Now it all just hangs and productivity is down.

    Reverting to older versions would make me vulnerable to Bluekeep and put my host at risk since I analyze malware in the guests. Is my only way forward to switch virtualization environment ?
      My ComputerSystem Spec


  5. Posts : 1
    Windows 10 1903
       #25

    I've been pulling my hair out for the past month dealing with this issue since upgrading to 1903. I was about to downgrade to 1803 until I found the workaround to disable WDDM. Hoping MS will fix the issue properly so I can revert back to using WDDM which is supposed to be better/faster for RDP.

    Interestingly, I don't have this issue with Windows Server (2016 or 2019) using latest builds.
      My ComputerSystem Spec


 
Page 3 of 3 FirstFirst 123

Related Threads
Source: https://support.microsoft.com/en-us/help/4023057/update-to-windows-10-versions-1507-1511-1607-1703-1709-and-1803-for-up See also: FIX for: KB4023057 Fails - Error 0x80070643 (Windows 10 v1803) - Windows 10 Forums
Hi Guys, Im new to the Windows 10 world, I am working with a small company with very outdated software...and hardware for that matter. I am trying to upgrade a PC to a new Desktop running windows 10 pro, that was the easy part. All the other old...
I just bought a new X201 laptop off ebay and wanted to use it to access my main PC (a MacBook also running Windows 10 Pro) through the Hyper-V Manager. That is to use the Hyper-V manager on the X201 to access not just the local PC but to start/stop...
Hi guys, I am trying to connect a printer... and for the life of me can not get this to work, new to vm's and trying to get old tech to get along and play nice with some new tech at work. I have a win 10 pro running a hyper-v client of win XP SP3...
I installed virtual XP on Win 10 Pro. When trying to open it in Hyper-V Manager it fails to connect even though it shows in the manager small box that it loaded XP and was ready for use. According to SystemInfo my AMD-Gigbyte computer supports all...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 14:26.
Find Us