VMware 15.1.0 copy/paste issue. Solved

Page 1 of 2 12 LastLast
  1.    #1

    VMware 15.1.0 copy/paste issue.


    I am running 15.1.0 on a 1903 host with guest of 1903 too.

    This used to work for me in 1809 I am not sure when it stopped but here is a list of things I tried to fix it.

    1) repair VMware 15.1, uninstall and do the full install of 15.1
    2) make sure the latest VMware tools are installed.
    3) in setting Shared folders I enabled that option and pointed to mt C;\ drive download folder (that is where I move from host to guest.
    4)run VMware in admin mode in properties (I already have admin rights in the host as I am the only user).

    Googling this issue show it has been a widespread problem for yrs, I have tried all "fixes" I could, there was the one I think only works in workstation version, but I have the free player only.


    I am hoping maybe someone else had a similar issue and found a fix.
    Spent half a day trying many things.
      My ComputerSystem Spec

  2. jimbo45's Avatar
    Posts : 7,256
    Windows / Linux : Centos, Ubuntu, OpenSuse
       #2

    Hi there

    @EdKiefer

    What Host are you using and what guest is running.

    What application are you using on Host and Guest to cut and paste from / to. I'm also using VMWare workstation rel 15.1.

    I find things like ksnapshot / kwrite / dolphin (on KDE plasma workspace -- equiv in ubuntu / gnome desktop would be any screen capture / edit program / file browser) and general applications like the GIMP have no problems when being pasted into typical Windows applications -- I'm running CENTOS 7.5 with KDE plasma workspace as a GUI on a spare HP envy laptop as a test server with various Windows VM's and can't say I've ever had problems cutting and pasting with VMWare between Guests and HOST for ages now -- back even further than release 12 !!!.

    Click image for larger version. 

Name:	s1.png 
Views:	1 
Size:	258.7 KB 
ID:	236664

    I don't bother with specific shared / public folders - I share all the Linux HDD's I need to via SAMBA and that works perfectly.

    More info on your setup might help though to identify the problem

    Cheers
    jimbo
      My ComputerSystem Spec

  3.    #3

    jimbo45 said: View Post
    Hi there

    @EdKiefer

    What Host are you using and what guest is running.

    What application are you using on Host and Guest to cut and paste from / to. I'm also using VMWare workstation rel 15.1.

    I find things like ksnapshot / kwrite / dolphin (on KDE plasma workspace -- equiv in ubuntu / gnome desktop would be any screen capture / edit program / file browser) and general applications like the GIMP have no problems when being pasted into typical Windows applications -- I'm running CENTOS 7.5 with KDE plasma workspace as a GUI on a spare HP envy laptop as a test server with various Windows VM's and can't say I've ever had problems cutting and pasting with VMWare between Guests and HOST for ages now -- back even further than release 12 !!!.

    Click image for larger version. 

Name:	s1.png 
Views:	1 
Size:	258.7 KB 
ID:	236664

    I don't bother with specific shared / public folders - I share all the Linux HDD's I need to via SAMBA and that works perfectly.

    More info on your setup might help though to identify the problem

    Cheers
    jimbo
    Hi, thanks for the reply, I am using win10 pro-1903 for host and win10 home 1903 for guests. I am not using any programs to copy/paste, just system to system (tried copy/paste from right-click context menu, also tried to drag an drop).
    It copy/paste the field is grayed out on the guest VM and drag an drop shows a gray circle with a cross.

    Also forgot to mention flash drive doesn't show up in MV guest but honestly I am not 100% this worked before.
    I am using the free version of VMware player, latest version 12.1.0.46741.

    I am just trying to move files from host to VM guest desktop, well any folder.

    PS: I am a windows guy, I don't know Linux or any non windows OS

    I do use O$O shutup win10 privacy app but I don't see anything that would hinder, or any windows services. I was working fine back in 1809 so its only last few weeks max. I have used VMware for yrs I think this only happened once and all that was is a reboot fixed it.
      My ComputerSystem Spec

  4. jimbo45's Avatar
    Posts : 7,256
    Windows / Linux : Centos, Ubuntu, OpenSuse
       #4

    EdKiefer said: View Post
    Hi, thanks for the reply, I am using win10 pro-1903 for host and win10 home 1903 for guests. I am not using any programs to copy/paste, just system to system (tried copy/paste from right-click context menu, also tried to drag an drop).
    It copy/paste the field is grayed out on the guest VM and drag an drop shows a gray circle with a cross.

    Also forgot to mention flash drive doesn't show up in MV guest but honestly I am not 100% this worked before.
    I am using the free version of VMware player, latest version 12.1.0.46741.

    I am just trying to move files from host to VM guest desktop, well any folder.

    PS: I am a windows guy, I don't know Linux or any non windows OS

    I do use O$O shutup win10 privacy app but I don't see anything that would hinder, or any windows services. I was working fine back in 1809 so its only last few weeks max. I have used VMware for yrs I think this only happened once and all that was is a reboot fixed it.
    Hi there

    @EdKiefer

    why not simply use basic Windows file sharing then the VM is simply another machine and you can suse things like file explorer to copy files between the machines -- ensure the Windows VM is "Network visible" -- Bridged Networking" in the VMWare settings rather than NAT and ensure all relevant HDD's / directories are shareable on all the windows systems.

    On the VM windows machine though ensure SMB1 is enabled via Windows features --in the Windows control panel -- and it's also better to have SMB1 enabled in the HOST as well (again via control panel -->turn windows features on or off).

    After 1809 SMB1 is disabled by default. This often causes problems on home networks.


    Cheers
    jimbo
      My ComputerSystem Spec

  5.    #5

    jimbo45 said: View Post
    Hi there

    @EdKiefer

    why not simply use basic Windows file sharing then the VM is simply another machine and you can suse things like file explorer to copy files between the machines -- ensure the Windows VM is "Network visible" -- Bridged Networking" in the VMWare settings rather than NAT and ensure all relevant HDD's / directories are shareable on all the windows systems.

    On the VM windows machine though ensure SMB1 is enabled via Windows features --in the Windows control panel -- and it's also better to have SMB1 enabled in the HOST as well (again via control panel -->turn windows features on or off).

    After 1809 SMB1 is disabled by default. This often causes problems on home networks.


    Cheers
    jimbo
    Thank you, all I had to do was change the VM setting from NAT to Bridged Networking and my shared DL folder was available under networking in quick view. I didn't have to mess with SMB1 (I know I have it disabled on host, not sure on VM).
    Edit: VM had all SMB1 options enabled, so that's fine with me, all works and this is actually a better way.
      My ComputerSystem Spec

  6.    #6

    I understand that you have the share working, but as for the copy / paste, could you just verify one more setting?

    Open settings (in VMware, not Windows) for the Virtual machine in question. Select the Options Tab, then Guest Isolation. Turn on both "Enable drag and drop" as well as "Enable copy and paste".
      My ComputerSystem Spec


  7.    #7

    hsehestedt said: View Post
    I understand that you have the share working, but as for the copy / paste, could you just verify one more setting?

    Open settings (in VMware, not Windows) for the Virtual machine in question. Select the Options Tab, then Guest Isolation. Turn on both "Enable drag and drop" as well as "Enable copy and paste".
    VMware free player version doesn't have that setting or at least I could never find it. I think that is only for the workstation version.
    Click image for larger version. 

Name:	VMware options.jpg 
Views:	10 
Size:	47.2 KB 
ID:	237147
      My ComputerSystem Spec

  8.    #8

    Sorry about that. You are correct - I was looking at Workstation and just assumed that setting would be available in Player as well.
      My ComputerSystem Spec

  9.    #9

    I found another person having the same difficulty and in response someone noted that setting the previously mentioned options in Workstation makes the following entries to the .VMX file for a VM. They suggested trying these settings to see if they affect Player. The person with the issue stated that these settings resolved the issue.

    In your case, adding these lines, if not already present, to your VMX file. You want to set them all to "FALSE".

    These options disable drag and drop:

    isolation.tools.copy.disable = "TRUE"
    isolation.tools.dnd.disable = "TRUE"
    isolation.tools.paste.disable = "TRUE"

    These enable it:

    isolation.tools.copy.disable = "FALSE"
    isolation.tools.dnd.disable = "FALSE"
    isolation.tools.paste.disable = "FALSE"
      My ComputerSystem Spec

  10.    #10

    hsehestedt said: View Post
    I found another person having the same difficulty and in response someone noted that setting the previously mentioned options in Workstation makes the following entries to the .VMX file for a VM. They suggested trying these settings to see if they affect Player. The person with the issue stated that these settings resolved the issue.

    In your case, adding these lines, if not already present, to your VMX file. You want to set them all to "FALSE".

    These options disable drag and drop:

    isolation.tools.copy.disable = "TRUE"
    isolation.tools.dnd.disable = "TRUE"
    isolation.tools.paste.disable = "TRUE"

    These enable it:

    isolation.tools.copy.disable = "FALSE"
    isolation.tools.dnd.disable = "FALSE"
    isolation.tools.paste.disable = "FALSE"
    Thanks ,This is how those lines look in my file now.

    isolation.tools.copy.disable = "FALSE"
    isolation.tools.dnd.disable = "FALSE"
    isolation.tools.paste.disable = "FALSE"
    isolation.tools.hgfs.disable = "FALSE" (had this one already).

    Anyway, it didn't help.
    thanks anyway.
      My ComputerSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
Solved trouble with copy and paste in General Support
Hi all, I have copied a calendar jpg using the snipping tool and have previously used edit - draw board and inserted an ellipse or circle to signify special dates. Today it won't work. C&P works everywhere else but no more on that jpg nor any other...
I normally use the built-in file copying program into Windows when I backup my data disks. Then I started to use TeraCopy which was great but then I wanted to take things to the next level. Why? Because who doesn't like to complicate things? I...
cut copy paste in General Support
Before update 14383 I used my mouse for cut. copy, paste. After this update that disappeared. Why
Copy & Paste in General Support
Something just recently changed in Windows 10. I can no longer use the PASTE shortcut CRTL+V. To paste anything, I must use the right click and then click on PASTE. I generally use COPY (CRTL_C) then CRTL+V and it is done. Does anyone know how to...
Solved Cut or Copy and Paste in General Support
How do you copy or paste from one document to another in Windows 10? Thanks.
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 01:50.
Find Us