Virtual Switch Manger Unable to Create Default Switch in v1809

Page 2 of 3 FirstFirst 123 LastLast

  1. Posts : 16
    Windows 10 x64 v1809
    Thread Starter
       #11

    Hmmm, Get is not recognized as the name of a cmdlet, Function, … etc. error when I try this command:

    Get -VMSwitchExtension -VMSwitchName ('Default Switch')
      My ComputerSystem Spec

  2. Kari's Avatar
    Posts : 16,166
    Windows 10 Pro
       #12

    jareinertson said: View Post
    Hmmm, Get is not recognized as the name of a cmdlet, Function, … etc. error when I try this command:

    Get -VMSwitchExtension -VMSwitchName ('Default Switch')
    You have a typo there. There should be no spaces between Get and hyphen, but you have a space there. All PowerShell cmdlets have same syntax, Verb-Noun, with no spaces.

    Kari
      My ComputerSystem Spec


  3. Posts : 16
    Windows 10 x64 v1809
    Thread Starter
       #13

    I believe I tried with and without space after Get.
    I moved ahead with the rest of the process you recommended. I was also on the same wavelength and anticipating a repair installation. Great Minds !

    Anyway it is in process and I will update with results hopefully before I retire for the day. Currently at 75%!
      My ComputerSystem Spec


  4. Posts : 16
    Windows 10 x64 v1809
    Thread Starter
       #14

    Sadly... the repair installation did not resolve the issue. Same issue and symptoms remain. The Virtual Switch Manager just is unable to get the Default Switch created. I can see it trying but it only exists for a few seconds then vanishes.
      My ComputerSystem Spec

  5. Kari's Avatar
    Posts : 16,166
    Windows 10 Pro
       #15

    jareinertson said: View Post
    The Virtual Switch Manager just is unable to get the Default Switch created.
    That comment makes me a bit confused. Default Switch cannot be created in Virtual Switch Manager. It is created automatically, and now in your case it has disappeared. The only way to get it back is to let system "to start from scratch", to recreate it.

    Next thing you could try is to first delete all existing virtual switches in Virtual Switch Manager. When done, restart. After restart, open Device Manager and one by one uninstall all Hyper-V network adapters:

    Click image for larger version. 

Name:	image.png 
Views:	1 
Size:	295.8 KB 
ID:	228016

    Now disable Hyper-V in Optional Features and restart. After restart, enable Hyper-V and check if the Default Switch has been recreated.

    Kari
      My ComputerSystem Spec


  6. Posts : 16
    Windows 10 x64 v1809
    Thread Starter
       #16

    I'll give this process a try and post results.
      My ComputerSystem Spec


  7. Kari's Avatar
    Posts : 16,166
    Windows 10 Pro
       #17

    jareinertson said: View Post
    I'll give this process a try and post results.
    In the mean time, I am asking help from the best Hyper-V expert I know. Although she's now working for Microsoft HoloLens team, she used to be a team lead in Hyper-V team.

    Click image for larger version. 

Name:	image.png 
Views:	2 
Size:	367.5 KB 
ID:	228059
    The tweet shown in screenshot on Twitter

    Kari
    Last edited by Kari; 20 Mar 2019 at 21:35. Reason: Typo fixed
      My ComputerSystem Spec


  8. Posts : 16
    Windows 10 x64 v1809
    Thread Starter
       #18

    Roger that. Thanks.

    FYI re the Virtual Swithch Manager comment... what I am seeing is if I am viewing Network Connections when I have the Hyper-V Manger open and select the Virtual Switch Manager, I see the Default Switch appear for a few seconds, typically multiple times.

    FYI, I may not have anytime to spend on this until Friday afternoon.
      My ComputerSystem Spec

  9. slicendice's Avatar
    Posts : 4,263
    Windows 10 Pro x64 v1903 Build 18362.264 (Branch: Release Preview)
       #19

    I believe this is a bug with the Default Internet Switch. I have had a lot of different issues with it including the one you describe. I haven't been able to solve this without a Windows clean install.

    On one of my computers, I've simply ignored and disabled the Default switch and created a new one that works flawlessly.

    This is a big and long time issue and this Switch creation spaghetti mess should have been solved by MS a long time ago but nothing has changed.
      My ComputersSystem Spec

  10. Kari's Avatar
    Posts : 16,166
    Windows 10 Pro
       #20

    slicendice said: View Post
    On one of my computers, I've simply ignored and disabled the Default switch and created a new one that works flawlessly.
    If Default Switch is not working, or missing like in OP's case, and NAT is required, the easy workaround is of course to create an internal switch, then share LAN / WLAN connection with internal switch. Now VMs using internal switch will get a NAT connection.


    slicendice said: View Post
    This is a big and long time issue and this Switch creation spaghetti mess should have been solved by MS a long time ago but nothing has changed.
    I have had no issues with switches, not in 1809, not in Fast ring and Skip Ahead ring Insider previews.

    Kari
      My ComputerSystem Spec


 
Page 2 of 3 FirstFirst 123 LastLast

Related Threads
I get the error "bind failed: General access denied error" when I try to create an external virtual switch. 67920 I tried running Hyper-V with as admin without success. Kevin
I created my first VM the other day and frankly I did not quite understand what the virtual switch was all about and did not create one. After the VM was successfully created I quickly shut it down for fear of wrecking it : ) It would seem however...
Hi I am new to Hyper-V so please bear with me. After about 5 hours I managed to get the Hyper-V Manager working then tried to set up a Virtual Switch following the tutorial. What I keep getting is "Error applying Virtual Switch Properties changes"...
creation of virtual switch seems to be proceeding but stops and I get a message similar to this: "Error applying virtual switch properties changes" Failed while adding virtual switch connections External ethernet adapter "'realtek pcie gbe'...
Virtual desktop switch in Virtualization
win+tab opens virtual desktop switch ... but by repeated press it again disappears instead of continuing to next desktop :/ do you know how to advance to next desktop ? by keyboard not by pointing cursor over 2nd desktop ??? (win+tab+1 .... did...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 22:39.
Find Us