VMware Workstation 15.0.2 is slowing my internet speeds.

  1. Compumind's Avatar
    Posts : 735
    Windows 10 Pro x64, Various Linux Builds, Internet Security Specialty.
       #1

    VMware Workstation 15.0.2 is slowing my internet speeds.


    Hey everyone...

    VMware Workstation 15.0.2 Build 10952284 is slowing my internet speeds by 40 Mbps (minimum).

    Anyone else?

    I had to perform the following to restore my speeds:

    At the Command prompt, right-clicked Command Prompt, and then selected Run as administrator.
    Also at the command prompt, ran the following commands in the order listed below:

    ipconfig /flushdns
    ipconfig /renew
    netsh int ip reset
    netsh winsock reset


    Restarted the system.

    It worked. Any insight as to why and how I can correct this going forward?

    TIA, as usual.

    Last edited by Compumind; 1 Week Ago at 09:25.
      My ComputerSystem Spec

  2. jimbo45's Avatar
    Posts : 6,740
    Windows / Linux : Centos, Ubuntu, OpenSuse
       #2

    Hi there
    Is this when accessing the Internet from within a VM or when doing file transfer between machines on LAN. You might like to look at the properties of the Virtual network adapter that's being used and check for things like full duplex etc.

    Even if your HOST is using a wifi connection the network adapter in VMWare should be set to use a Virtual Ethernet adapter and its speed should be 1 Gb/s between VM and its HOST whilst between VM and rest of network should be at your Wifi LAN speed.
    Try also switching between Bridged and NAT networking in the VM. There's a few parameters you can also tweak in the .vmx configuration file but not being a Network Guru you'll have to google for those settings.

    There's no way installing VMware should make any difference whatsoever to the HOST's Internet speed.

    Cheers
    jimbo
      My ComputerSystem Spec

  3. Compumind's Avatar
    Posts : 735
    Windows 10 Pro x64, Various Linux Builds, Internet Security Specialty.
    Thread Starter
       #3

    @jimbo45 -

    Hi.

    When i installed VMware with default settings the connection speed dropped as above.
    So I ran the above network stack commands and the problem was resolved.

    I cleanly uninstalled VMware in conjunction with their cleanup tool and will reinstall with your recommendations.

    Something with those virtual adapters, I think.

    Do I need to install the Virtual Keyboard with the reinstall?

    Thanks.

      My ComputerSystem Spec

  4. jimbo45's Avatar
    Posts : 6,740
    Windows / Linux : Centos, Ubuntu, OpenSuse
       #4

    Hi there @Compumind
    No idea about Virtual keyboard -- never installed it (at least knowingly !!) When using VMware tools I just take the default options.

    Cheers
    jimbo
      My ComputerSystem Spec

  5. Compumind's Avatar
    Posts : 735
    Windows 10 Pro x64, Various Linux Builds, Internet Security Specialty.
    Thread Starter
       #5

    Reinstalled VMware.

    Same problem - internet speeds down, as above.
    Even checked that 'nic" adapter power does not go to sleep.

    Will call VMware. Very strange, indeed!

      My ComputerSystem Spec

  6. jimbo45's Avatar
    Posts : 6,740
    Windows / Linux : Centos, Ubuntu, OpenSuse
       #6

    Hi there
    Afraid I've run out of ideas -- I don't have any network issues caused by VMware -- it is strange !!.

    Cheers
    jimbo
      My ComputerSystem Spec


 

Related Threads
Hi there vmware rel 14 out ( I guess they skipped V13 !!!) has a load of new features including Unity support for W10 , New CPU support, new guest OS support for various OS'es, support for latest V4 Linux kernels (both HOST and GUEST OS'es) etc....
vmware workstation 12.5.2 in Virtualization
Hi folks If you are running Linux Hosts this version of VMWARE workstation (and similar release of vmplayer) seems to have fixed problems of "wobbly mouse" etc -- also when scrolling inside the GUEST in windowed mode --I.E Windowed mode WITHIN...
Hi, I've done a clean install of windows 10 Pro but am now unable to get internet on a guest VM on Windows 7, Windows 8.1 and Windows 10 . I just get a yellow ? Ethernet controller in device manager. I tried my legal copies of Windows Me and...
VMWare Workstation 10.4 in Virtualization
VMWare Workstation 10.4 is on the street. Up and running, and at the moment haven't had any problems running any OS.
Hi there Problem with installing VMWARE tools with Windows 10 x-64 using Windows host. Works fine on LINUX host !!!! (VMware workstation rel 10.0.3 build-1895310) Cheers jimbo
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 14:12.
Find Us