VMvare Tools install fail on some VM's

  1.    #1

    VMvare Tools install fail on some VM's


    I've been messing around with virtual machines for a couple of months. Lots of fun!
    Started from scratch without knowing or understanding anything and I got to the stage where I thought I knew everything and then all the way to realizing i understand very little, and still don't know anything...

    So, Time to ask someone for help.
    I currently run several different VM's in VMware Workstation 12 after running in to loads of problems with Hyper-V and VirtualBox. I do it mostly for fun and to learn about it. Bought an older workstation just to be able to tinker with different OS and get my dusty computer skills up to date after a couple of years hiatus...

    After setting up a couple of different GNU/Linux distros and trying them out, I made a macOS and then a Win10 VM to use as a sandbox.
    All working fine with no problems installing the OS or the VMware tools. Full screen and responsive(-ish) mouse and keyboard input.
    MacOS, Mint, openSUSE and Ubuntu works fine. Win10 and macOS are a bit slow, but I think that's my own fault for setting them up a bit stupid. More on that later...

    But then I ran into some problems when it came to installing VMware tools on some of the subsequent OS's I tried out.
    I could not get it running on System 76's pop OS and I've only been able to install VMware tools on one VM running macOS Mojave.
    The error I get is:
    "Could not find component on update server. Contact VMware Support or your system administrator."

    I have no idea how i managed to get the tools installed on the one macOS VM that workes 100% and not on the others. I think I just clicked the "install Tools" in the yellow bar at the bottom of the VM screen and it worked that time. Next time I went to do it on a different macOS VM, the "Could not find..."-error popped up and I haven't been able to get it working since. Other OS's are fine and can get Tools installed the "natural" way without any manual downloads.

    I've tried to install VMware tools manually by downloading and installing. I can install it, but it doesn't work.
    The forum posts I've read says installing manually, uninstalling and installing again works. For me it doesn't.
    One fix seems to be to install a patch to allow the user to set the screen resolution manually with a sudo command in the terminal. Haven't been able to get that to work either. It takes my commands, processes them, says everything os OK and then does nothing... I've created root-accounts to run it, downloaded patches, fixes and different versions of the VMware tools. I've tried different versions of macOS and tried installing the tools both directly after install and after updating macOS. Tried all the way from Mountain Lion up to Mojave. Nothing works. If I hadn't been able to get it working before it wouldn't be as much of a thorn in my balls. But now?! Well, it keeps me up at night.

    So why do I need more than one macOS VM? I don't, really. But I managed to mess up when I setup the fully working macOS VM, and now it's different components are scattered between multiple folders in different directories which makes it quite slow and a pain in the ass to manage...
    Virtual drive split into different pieces, wrong file name, wrong folders, wrong drive... The only thing that's right about it is that it's somehow working.
    I honestly don't know which files belong to the working macOS VM and which doesn't anymore after messing around with this issue for a couple of weeks.
    I want a do-over on my macOS VM install but I'm unable to recreate what I once did and I can't figure out what's different now. I dare not remove the working one until I manage to recreate it...

    Any thoughts on this problem?

    Hiatus
      My ComputerSystem Spec

  2.    #2

    Update!
    After pretty much 6 hours of non-stop trying different methods and darwin files (containing the tools), on the 13th attempt of the day, I actually managed to get VMware tools installed on a second VM running macOS Mojave 10.14.2.

    Here's what I did different in the end.
    Instead of downloading the darwin.iso directly to the VM, I downloaded it to the host and mounted the iso as a drive on the VM and then went through the install-uninstall-install routine.
    At the second install, I got prompted to select which users should be effected by the tools install. That one was new. After installing a second time and rebooting the VM, I finally got some result. I got mouse and keyboard to respond well, but the resolution was still messed up. Full screen but wrong res.

    After messing around with vmware-resolutionset for a while without any real success, I finally fixed the resolution by running this command:
    sudo /Library/Preferences/com.apple.windowserver DisplayResolutionEnabled -bool NO

    This got the resolution right and now everything seems to be working fine!
    Now to see if I can replicate the result. I don't like the double installation part of it (since i don't understand why) and even if i like sudo commands as much as the next guy, I have to say that it troubles me a bit that it was needed to get it working...

    Hiatus
      My ComputerSystem Spec

  3. jimbo45's Avatar
    Posts : 6,740
    Windows / Linux : Centos, Ubuntu, OpenSuse
       #3

    Hi there.

    On Linux VM's with VMWARE tools you don't need to install VMWare tools --- just ensure the Guest has package openvm-tools. Install via the package manager for the linux distro you are using.

    For MAC type OS'es --don't know as I've never installed any of those.

    Cheers
    jimbo
      My ComputerSystem Spec

  4.    #4

    Hello jimbo!
    That's good information. Saves me lots of time and effort to just get the tools from the package manager. I'll try that on the next one!

    I did manage to recreate my results last night, and I have now installed VMware tools on three different macOS VM's without any major problems.
    In the last one I had to un-check a new box in the Display settings for the VM while it was running. It had to do with auto scaling. Never seen it before and it does not appear in any of the other VM's. The same check box does not appear if I close down the VM and try to edit the preferences for it when turned off...
    It has to be done from the "manage virtual machine" it seems. Not sure what's different about that VM, but it's obviously something...

    Hiatus
      My ComputerSystem Spec


 

Related Threads
KB4022725 install fail in Windows Updates and Activation
KB4022725 update is failing to install on my Windows 10 creator's edition. Ran the included windows update troubleshooter multiple times, it always finds and "fixes" the same things but the update still doesn't install. I stopped trying to install...
WICD Builds fail to install in Installation and Upgrade
Hope I have the right location for this. Been using WICD to build my new images for the school system I work with. Was working great then suddenly every image I build fails to install windows 10. Ive stripped everything down besides a few...
windows updates fail to install in Windows Updates and Activation
hello all :) i am using windows 10 Pro 64 i had some updates go in yesterday but then had a error message come up that i did not get a chance to write it down and seach it. now i am getting updates failing to install. i am constantly clicking the...
How to Install and Uninstall Graphics Tools in Windows 10 With Windows 10, the graphics diagnostic tools are now available from within Windows as an optional feature. To use the graphics diagnostic features provided in the runtime and Visual...
Install on HP 23-N010 fail! :( in Installation and Upgrade
So after making an image, I decided to make W10 TP the operating system. Got the 64-bit ISO and proceeded to do the install keeping all programs and data, iow an upgrade. All proceeded with no errors until the final boot. Then all I get is a...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 14:18.
Find Us