Windows 10: Removing old virtual switches

Page 2 of 3 FirstFirst 123 LastLast
  1. Kari's Avatar
    Posts : 15,054
    Windows 10 Pro
       24 Apr 2018 #11

    Really strange guys. I have the same speed with an external switch than without. In fact, I have noticed that my DL speed will often exceed the 100 Mbps I am paying for when using external switch (goes up to 110 - 115).
      My ComputerSystem Spec

  2. slicendice's Avatar
    Posts : 3,560
    Windows 10 Pro x64 v1809 Build 17763.104 (Branch: RS5 Release Preview)
       24 Apr 2018 #12

    This is so odd.

    Now I tested my network speeds on 2 computers and one VM, using a different tool. They all reported pretty much the same speeds after multiple tests. Variance was less than 0.6% (2Mbit variance on 30 tests total, 10 each using WiFi, LAN and Hyper-V-Switch over WAN 350Mbit).


    Why do I get these numbers now? LOL!
      My ComputersSystem Spec

  3.    24 Apr 2018 #13

    slicendice said: View Post
    This is so odd.

    Now I tested my network speeds on 2 computers and one VM, using a different tool. They all reported pretty much the same speeds after multiple tests. Variance was less than 0.6% (2Mbit variance on 30 tests total, 10 each using WiFi, LAN and Hyper-V-Switch over WAN 350Mbit).


    Why do I get these numbers now? LOL!
    How odd. My brain hurts now.
      My ComputerSystem Spec

  4. slicendice's Avatar
    Posts : 3,560
    Windows 10 Pro x64 v1809 Build 17763.104 (Branch: RS5 Release Preview)
       24 Apr 2018 #14

    cereberus said: View Post
    How odd. My brain hurts now.
    HAHAH! And now when I touched the network configurations, I can't remote manage my VMs from another Hyper-V Manager anymore. Can't get it to work again....
      My ComputersSystem Spec

  5.    25 Apr 2018 #15

    slicendice said: View Post
    HAHAH! And now when I touched the network configurations, I can't remote manage my VMs from another Hyper-V Manager anymore. Can't get it to work again....
    Somehow my Hyper-V got all tangled up and the default switch would not work anymore. I even installed a new vm, chose default switch - nope would not connect.

    In the end, partly out of mild desperation as I did not want to restore a Macrium image and all my vms (separate), so I uninstalled Hyper-V, reinstalled it and then it came up with error message saying config error with switch. I added the default switch back to the VM, and it now worked. I guess it was Hyper-V that got corrupted in some way, as all my vms work now.
      My ComputerSystem Spec

  6.    25 Apr 2018 #16

    jimbo45 said: View Post
    Hi there

    Open port 3389 on the VM ensure firewalls OK

    say NAT addr is 10.0.0.1

    then in your RDP this should work 10.0.0.1:3389

    Cheers
    jimbo
    As I can only use the default switch, I tried this and it worked fine. Do you know if the IP is dynamic or static?
      My ComputerSystem Spec

  7. slicendice's Avatar
    Posts : 3,560
    Windows 10 Pro x64 v1809 Build 17763.104 (Branch: RS5 Release Preview)
       25 Apr 2018 #17

    LOL, my Default Switch, isn't connected to anything. Has been like this since two Windows upgrades ago.

    I use a switch I have created myself, and it works like a charm. Only issue is that if I delete it and re-create it, the MAC address and device ID change, so all security settings gets reset and my VM can't be recognized as the same machine as before.

    But at least I can decide, which physical adapter on the host it uses, if at all.

    For advanced routing purposes, one can create a small Linux VM, with routing software (OpenWRT...etc.) and connect that to at least 2 switches, where the first one is connected to internet using preferred physical NIC and the other one is as a stand alone switch. Then Just configure your router VM to use the internet connected switch/NIC as a WAN port and the other switch/NIC as LAN/NIC. All other VMs then connect to Switch 2 and the Linux VM handles the NAT and routing. It is even possible to simulate a real router by adding more non internet connected switches to the router VM. :)
      My ComputersSystem Spec

  8.    25 Apr 2018 #18

    cereberus said: View Post
    As I can only use the default switch, I tried this and it worked fine. Do you know if the IP is dynamic or static?
    I cannot rdp from my phone to vm.

    I can from host on pc containing the vms.

    The phone is on same subnet as the host pc.

    Any ideas why not?
      My ComputerSystem Spec

  9.    25 Apr 2018 #19

    Hi there

    might be a silly answer but did you check if the phone was on your Internet or were you on the phone's 4G system. If not on your home (local) internet and LAN then it won't work from the phone's 4G address.

    I know you are experienced in this sort of stuff but even the most experienced people make mistakes with this type of stuff !! I've made really silly mistakes loads of times too !!!.

    Cheers
    jimbo
      My ComputerSystem Spec

  10.    25 Apr 2018 #20

    jimbo45 said: View Post
    Hi there

    might be a silly answer but did you check if the phone was on your Internet or were you on the phone's 4G system. If not on your home (local) internet and LAN then it won't work from the phone's 4G address.

    I know you are experienced in this sort of stuff but even the most experienced people make mistakes with this type of stuff !! I've made really silly mistakes loads of times too !!!.

    Cheers
    jimbo
    Yeah I have done that before - phone is on wifi. I can rdp to host but not the vm. I cannot see any obvious reason.
      My ComputerSystem Spec


 
Page 2 of 3 FirstFirst 123 LastLast

Related Threads
Main display switches in Graphic Cards
Hello - this might possibly be a bit outside of the Windows discussion since I run Windows 7 on a RH Linux laptop (it's a work requirement), but I'll ask since I have not been able to figure this out or find a solution anywhere. I use 3 monitors...
key switches don't work in Drivers and Hardware
On this Toshiba Satellite M645, key switches don't work, brightness control, mouse and pointer on/off, and wireless on/off. Any suggestions?
I'm using an RCA 55" LED Smart TV on my rig to play games. This was not an issue in windows 7. Going fullscreen on some games causes my display to switch from 1080p to 1080i. It's very annoying. I have been using autohotkey with a force full...
I've made 3 virtual machines at hyper-v on windows 10 x64 professional, also I made 3 virtual switches, but the networking including host does not work. 1. 1 external and 2 internal switches 48474 The last photo is windows 7 vm. I...
In win7 and win8.1, i could set the screen of my tablet (Lenovo Miix3) to switch off after 3 min (not sleep, just switch off the screen). Tapping the touchscreen would bring it immediately to life again. With win10, this does not happen. I need...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 23:39.
Find Us