Error 0x80070002 when starting Microsoft Passport Container Service

  1. Posts : 1
    Windows 10

    Error 0x80070002 when starting Microsoft Passport Container Service

    Some backstory for this problem: For the past year or so, I've had 2 major problems with my Windows 10 PC. The first problem (which i solved by turning off fast startup) was that the password box and my profile picture on the login screen didn't appear when I shut down and then started the computer up. The screen would work fine if i restarted the computer. The second problem is that the user account control prompt does not pop up at all, no matter what I do. The prompts are able to pop up for about 10-30 minutes after I start the computer, but after that, they either never show up, or take hours to show up. Because the prompt doesn't appear, the entire window that the prompt was opened from freezes (for example, opening a browser that requires admin permission on the desktop causes explorer.exe to freeze). Sometimes the UAC prompt appears in the taskbar, but, when I hover over it, it shows a white screen with the prompt on it. The prompt has no "yes" button and no password box.

    After the UAC prompt failed to pop up, I noticed that there was an error in the Event Viewer: "The Microsoft Passport Container service (which is NgcCtnrSvc in the service's properties) terminated with the following error: The system cannot find the file specified." I looked up this error message, and I cannot find anyone who has gotten the same error message as me. The closest to my error message that I could find was a general access denied error. After seeing the error, I restarted the computer, and the Passport Container service was enabled. UAC worked. When I disabled the service, UAC no longer worked. I tried to re-enable the service, only to get an error message saying:

    "Windows could not start the Microsoft Passport Container service on Local Computer.

    Error 0x80070002: The system cannot find the file specified."

    So it's impossible for me to enable the NgcCtnrSvc service after it has been (somehow) disabled. Does anyone have an idea of how to get rid of this error message and problem in general?

    Thank you,

      My Computer

  2. Posts : 1
    Windows 10


    I realise this is an old thread but it;s the first result on Google for this issue.

    My fix was to logon to another Windows 10 computer and export the entire HKLM\System\CurrentControlSet\Services\NgcCtnSvc key and then import onto the machine with this problem. The Microsoft Passport container service could then start and all apps behaved as normal again.

    I hope this helps someone else.
      My Computer


  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 18:00.
Find Us

Windows 10 Forums