Security Tab in Folder Properties: SID Shows Instead of User Name

  1. Maidvelia's Avatar
    Posts : 12
    Microsoft Windows 10 Home (v21H1)
       #1

    Security Tab in Folder Properties: SID Shows Instead of User Name


    Whenever I click the security tab in properties for my personal folders, my user name does not appear, only the security identifier does (S-1-5-XX-XXXXXXXXXX-XXXXXXXXXX-XXXXXXXXXX-XXXX). Is there a way to fix this without creating a new user account? It is not that big of a deal if I have to make a new account, I was just curious if there was another workaround.

    I renamed my user folder by changing the ProfileImagePath in RegEdit and then renaming the folder in the Windows Recovery Environment command prompt (via file explorer, accessed through "Save As..." in notepad.exe). I feel like I messed up here and that security can no longer resolve my username due to it.

    EDIT: I also have been having HomeGroup issues, and I feel like not being able to resolve my user name is part of what is causing those issues.
    Last edited by Maidvelia; 21 Aug 2017 at 20:39.
      My Computer

  2. Spectrum's Avatar
    Posts : 546
    seL4
       #2

    The SID being shown means the username cannot be resolved. In an Active Directory environment this is normally caused by networking issues (primarily DNS).

    I do not have much experience with homegroups but it sounds like there is some issue with communication between the computers in this group. Are all computers working, and can you resolve all of their hostnames? Have you tried rebooting all computers in the homegroup? Leaving/rejoining the homegroup, or creating a new homegroup?
      My Computer

  3. Samuria's Avatar
    Posts : 6,190
    windows 10
       #3

    It normally when a user is deleted
      My Computer

  4. Maidvelia's Avatar
    Posts : 12
    Microsoft Windows 10 Home (v21H1)
    Thread Starter
       #4

    Spectrum said:
    The SID being shown means the username cannot be resolved. In an Active Directory environment this is normally caused by networking issues (primarily DNS).

    I do not have much experience with homegroups but it sounds like there is some issue with communication between the computers in this group. Are all computers working, and can you resolve all of their hostnames? Have you tried rebooting all computers in the homegroup? Leaving/rejoining the homegroup, or creating a new homegroup?
    All of the computer names show up under Network. I have also tried leaving, rejoining, creating a new HomeGroup, and resetting HomeGroup via deleting the contents of PeerNetworking.

    The user name issue has resolved itself though. I made a new user account (as well as deleted the old one) and the issue I had still persisted, but it only persisted when I signed into my Microsoft account. My formal name would disappear and my email address would take its place, and user entries under the Security tab would only show the SID.

    I fixed it by simply switching to a Local Account for awhile (and the Security tab looked just fine during then). I then did a reboot and signed back into my Microsoft account. No more disappearing user names.
      My Computer

  5. Maidvelia's Avatar
    Posts : 12
    Microsoft Windows 10 Home (v21H1)
    Thread Starter
       #5

    Never mind it just happened again. Looks like I'm sticking to a Local Account.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 23:07.
Find Us




Windows 10 Forums