Windows 10: Rename Users\Username? Solved

  1.    06 Aug 2017 #1

    Rename Users\Username?


    When I installed Win10 Home and was prompted for a name at one point I got as far as 'conni' and before I could type the 'e' the word was accepted.

    This is not the name that shows up on the Network for the machine-which is correct as to what I changed in System.

    This is not the name that appears in Local Users/Groups, User Accounts--which is correct as her full name.

    This is the name that appears under Users along with Public, etc.

    Per Brink's tutorial, I've right clicked on 'conni' under Users but there is no Rename option.

    I've right clicked conni, clicked Properties but the name is grayed out.

    ?

    Mark
      My ComputerSystem Spec


  2. Posts : 25,243
    64-bit Windows 10 Pro build 17040
       06 Aug 2017 #2

    Hello Mark,

    If you are currently signed in to the "conni" account, you won't have the "Rename" option available in the context menu.

    You'll need to be signed in to a different administrator account to be able to rename the user profile folder for the "conni" account.

    Change Name of User Profile Folder in Windows 10 Windows 10 User Accounts Tutorials
      My ComputersSystem Spec

  3.    06 Aug 2017 #3

    Thanks--

    I had skipped your entry comments and went directly to steps. That won't happen again.

    Mark
      My ComputerSystem Spec


  4. Posts : 25,243
    64-bit Windows 10 Pro build 17040
       06 Aug 2017 #4

      My ComputersSystem Spec

  5.    06 Aug 2017 #5

    Big time problems


    On the login screen, bottom left, options Connie, Administrator, and something else. I clicked Administrator.

    I wasn't asked for a password, Windows said to wait while it set things up and then opened to a desktop that was a mixture of initial setup and her desktop.

    I right clicked on conni, renamed to Connie, clicked open space and got the attached error.Click image for larger version. 

Name:	Folder in use.png 
Views:	13 
Size:	11.0 KB 
ID:	147517

    Then the fun started.

    I restarted, clicked on Connie this time instead of Admin, entered password and got a blue rectangular screen something like Windows couldn't logout dismiss and use temporarily or give up I think.

    I shutdown and restarted a few times, same problem--machine would not take her login per couldn't logout.

    I then reverted to yesterday's restore point successfully (using run for control panel, etc). But not really. The restore point start button does not work on left click, just right. I booted a few times--same problem with the button--can't get to programs.

    I then used run to start Reflect from its .exe file. When I loaded last night's image something didn't seem right with the drive letters it was going to use for restored partitions.

    I figured best come back here and see if we can get the start button to work?

    I've got a headache ;-)!

    Mark
      My ComputerSystem Spec


  6. Posts : 25,243
    64-bit Windows 10 Pro build 17040
       06 Aug 2017 #6

    This has happened if you restarted the computer without renaming the profile folder to match the path specified for the ProfileImagePath value in the registry.

    You can fix this by renaming the ProfileImagePath data value path to what the folder is currently named.

    To be able to rename the profile folder of an account, that account must be signed out.
      My ComputersSystem Spec

  7.    06 Aug 2017 #7

    No, not what happened.

    I restarted to get to the login screen and logged in as Administrator. With those rights per your earlier message, Rename would appear when rightclicking User conni. Rename did appear, I typed Connie BUT the OS did not accept the name change per the screenshot and per the same conni appearing as the User when I cleared the 'folder in use error' message.

    So nothing changed at this point other than being logged in as Administrator. Hence, I restarted to log Admin out, get to the login screen and click on her account vs. Admin. After I entered her password I then got the Windows error that the previous had not logged out and in smaller print something to the effect that Windows sometimes needs to restart to logout the previous. I did so 2 more times including a cold boot. All times her name login/password resulted in the same message.

    At that point I dismissed the warning, got to her desktop and there was a reminder that anything I did would be deleted on restart.

    That's when I figured if I can't get Admin to unlock/logout by a soft or cold boot, the next best was to go back to an earlier system restore point--yesterday. I did that. OS reported done successfully. Wrong. The start button is nonfunctional. I booted again, the start button not functional.

    The current status: restore point of yesterday, the same User conni remains in place and the start button is not functional. I'm not sure but it seems that the OS is not quite stable but I wasn't hanging around long enough to really know.

    ?
      My ComputerSystem Spec


  8. Posts : 25,243
    64-bit Windows 10 Pro build 17040
       06 Aug 2017 #8

    Odd. It seems to behave like the "conni" account was still signed in with a "in use" error.

    If you're still getting a temp profile error when trying to sign in to "conni", you might check using the tutorial below to see if it may help to sort this error to hopefully continue with the main issue afterwards.

    Fix You've been signed in with a temporary profile in Windows 10 Windows 10 User Accounts Tutorials
      My ComputersSystem Spec

  9.    07 Aug 2017 #9

    If the ‘conni’ account were still signed in I would have gotten the error signing in as Admin, which I didn’t. I got the error after Admin didn’t work Renaming conni, and I restarted and attempted to sign in as Connie G….


    The reason your temp profile tutorial is not necessary now—


    I dismissed the temp profile warning and fell back to the last restore point. The OS said it worked but it didn’t. The login problem was cleared but the start button was shot. No left click., no program launch other than directly from an .exe with explorer.


    I then decided to do a Reflect image restore. The target partition drive letters on the restore screen didn’t seem correct—possibly due to starting up Reflect (don’t remember now, either from the .exe or double clicking an image) not from programs.


    I will post the condition in the proper forum after another cup of coffee and a shower 😉!

    Mark
      My ComputerSystem Spec


 

Related Threads
Solved How to rename a user's folder in c:\users? in User Accounts and Family Safety
While my request in the thread Is it advisable/useful to have a second (full) Administrator account? was successfully handled, I now have this situation which I consider appropriate to mention in a new thread. Basically, I would like to rename the...
I don't remember when, but I availed myself of the free Windows 10 upgrade sometime back. I was using 8.1 and I had, at some point, moved C:\Users and all its associated folders to E:. Everything has worked fine and Win10 didn't have a problem. I...
Every time I get one of these involuntary updates from Microsoft, my PHOTOGRAPHS folder is renamed MUSIC. The folder icon changes also. Up to now it has merely been a nuisance. But after the most recent update, the RENAME option disappeared from...
Hi I have Windows 10 v1511 Enterprise 64 bit. From the Command Prompt, run as administrator, how should I do to remove any TrustedInstaller or Authenticated Users or System users from the ACLs of an entire directory structure also contains...
Solved How to rename C:\ users in User Accounts and Family Safety
I bought a new Toshiba laptop running Windows 8.1.Recently, I upgraded to windows 10. :D But now I noticed that my user folder is named as it world. And the path is C:\Users\it world . :mad: please help me to change it to...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 21:07.
Find Us