1.    05 Apr 2017 #1
    Join Date : Apr 2017
    Posts : 18
    Windows 10

    Need Help With Windows Permissions Control Issues


    Okay, so long story short my dad worked for a company and had a company laptop. He is now retired from said company.

    He had personal files on that computer which he backed-up to an external hard drive.

    Now when you access the external hard drive from his new computer, you cannot open those files because of permission control issues. Says he's not the "owner" and cannot do anything with the files. Even though these are personal photos and what-not.

    Probably because it was a company laptop and it had it's files locked-down I'm guessing. Unfortunately that laptop has already been turned-in to his company and by now I'd imagine they've formatted it and given it to someone else. Point being that if there's anything we could've done from the old machine it's too late for that now.

    I read that the permissions control has to do with Windows and with NTFS. I thought maybe if I copied them over to a FAT32 drive maybe it'd get rid of it but it also doesn't let me move or copy the files or anything. I'm not sure if I can even delete them without formatting the entire disk. No idea how to undo permissions control, I really don't mess with that part of Windows much.

    Any ideas? My only other idea was to attempt using a totally different OS like a Linux distro to mess with them as I'm not sure if other non-Windows OSes are built to acknowledge Windows permissions controls.

    If you're not willing to talk about it in a public forum then please at least PM me. I'd rather not have to tell him "Welp, looks like they're lost forever, sorry".

    Thanks in advance.
      My ComputerSystem Spec
  2.    05 Apr 2017 #2
    Join Date : Jul 2016
    Crewe Cheshire
    Posts : 1,451
    windows 10

    Welcome to the forum. You should just need to take ownership of the folders see our tutor which has a tool to do it for you Add Take Ownership to Context Menu in Windows 10 - Windows 10 Customization Tutorials
      My ComputerSystem Spec
  3.    05 Apr 2017 #3
    Join Date : Apr 2017
    Posts : 18
    Windows 10
    Thread Starter

    Okay thanks, I'll report back if there's any issues or if it succeeds.
      My ComputerSystem Spec
  4.    06 Apr 2017 #4
    Join Date : Apr 2017
    Posts : 18
    Windows 10
    Thread Starter

    Hmm, it seems that it's not quite that simple in this case. The "Take Ownership" tool didn't do anything that fixed the issue. I still get the error "User does not have access privileges".

    Let me be a bit more descriptive - the files I'm trying to access have a little yellow padlock icon on them. Not sure if that helps any.

    I mean, I've worked with permissions control at least enough to where I know how to change that setting. But in this case it's just not that simple - doing that seems to have no effect. I think these files are actually encrypted or something, which I'm not sure if there's anything to be done about.

    I've already told him that, most likely there's nothing anyone can do and he'll probably need to get in touch with his company to have any chance of fixing this. Upon further research I think these files are encrypted with EFS and that he needs the key.

    That being said he's retired and he said you're not supposed to save personal files to those directories anyway, so he might be boned I guess.

    So it's playing out like I thought it would. When I first took a look at the laptop I said "If this were really just permissions control then I'd already be done, but this looks a bit different.. I'll do what I can, but I don't think they'd bother with it if it was that easy to undo. This is one of the world's biggest companies we're dealing with here, I highly doubt they'd secure their files in a way that a kid like me and some online forums can figure out."

    ...Well, unless you're Yahoo and storing people's passwords as unsalted MD5 hashes. Ha.

    Thanks.
    Last edited by AlexanderM13; 06 Apr 2017 at 06:43.
      My ComputerSystem Spec
  5.    06 Apr 2017 #5
    Join Date : Apr 2017
    Posts : 18
    Windows 10
    Thread Starter

    Upon talking with him more about it, he says he doesn't think they're encrypted because when he copied the files over to the external hard drive, something prompted him. Either he selected "don't encrypt" or the system was just telling him that the files wouldn't be encrypted.

    However, the padlock icons are still on the files and even with that "Take Ownership" option it doesn't fix it. Upon attempting to open them you just get the "You don't have privileges" error.

    Far as getting an encryption key goes, seems he's pretty resigned to just accepting it if that's really the case. Doubtful they'd help him and I don't think he even wants to ask. I figure these kinds of questions just make a guy sound fishy and he wasn't supposed to have personal files on it anyway so it's probably not a good idea to even ask.

    If there's anything anyone can do I really appreciate it. Thanks.

    Windows telling me to check my privilege. Ffs.
    Last edited by AlexanderM13; 06 Apr 2017 at 07:26.
      My ComputerSystem Spec
  6.    06 Apr 2017 #6
    Join Date : Jan 2015
    UK, Midlands
    Posts : 10,980
    Win 10 Pro (1703)
      My ComputerSystem Spec
  7.    06 Apr 2017 #7
    Join Date : Apr 2017
    Posts : 18
    Windows 10
    Thread Starter

    But that's just for fixing a cosmetic nuisance. In this case the files are still actually inaccessible.
      My ComputerSystem Spec
  8.    06 Apr 2017 #8
    Join Date : Jan 2015
    UK, Midlands
    Posts : 10,980
    Win 10 Pro (1703)

    Is it this one then?
    Change or Remove Lock Icon on Encrypted Files in Windows 10 - Windows 10 Customization Tutorials
    I don't know what version of padlock etc you're seeing.
      My ComputerSystem Spec
  9.    06 Apr 2017 #9
    Join Date : Aug 2016
    S/E England
    Posts : 4,490
    10 Home x64 (1709) (10 Pro on 2nd pc)

    Quote Originally Posted by AlexanderM13 View Post
    Hmm, it seems that it's not quite that simple in this case. The "Take Ownership" tool didn't do anything that fixed the issue. I still get the error "User does not have access privileges".
    Taking ownership can sometimes just be the first step. You may then need to add your account to the list of those that have permissions and grant yourself full control. On the Security tab, to change permissions, click 'Edit', then click 'Add' to add your account.
      My ComputersSystem Spec
  10.    06 Apr 2017 #10
    Join Date : Jul 2016
    Crewe Cheshire
    Posts : 1,451
    windows 10

    Can we get a screenshot of the folder showing file names and lock. Takeownership need to be run on the folders not the files starting with top folder
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Bash Global NPM Installs Permissions Issues
I've been playing happily with the new Bash features and I'm bumping into a couple of small issues that I'm having a tough time fixing. I think fixing this one will solve the others as well. Having installed NodeJS as described here, running...
Windows Insider
Lost all permissions and control of files/folders
Hi all, earlier I plugged in the hard drive from my wife's PC into my own PC (both windows 10) so I could try to recover some files from it (as it's currently not booting into windows). As soon as I booted my PC back up I could see the second...
General Support
Permissions Issues - You do not currently have permission to ...
Installed windows 10 pro yesterday as an in place upgrade to my 8.1 pro. There is a few issues so far, but the one that is annoying me at the moment is my pictures/documents/music folders. On a fresh reboot of my computer, the first time I try and...
User Accounts and Family Safety
Display Resolution and Windows Control Issues
Installed Windows 10 with a standard LG HDMI 1920 x 1080 monitor. Worked fine for awhile, then I started getting notification pop ups saying I should increase resolution beyond 1920 to something like 2300 pixels. Settings do not include this. Then...
Graphic Cards
Windows 10 Permissions Issues
I've noticed two issues issues related to permissions after the upgrade to Windows 10. I used the upgrade process using a fresh install of Windows 8 Pro, telling Windows 10 to keep nothing. It would appear to be the same file system, as...
General Support
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 06:56.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums