1.    27 Jan 2017 #1
    Join Date : Jan 2017
    Posts : 3
    Windows 10 Anniversary Update

    CopyProfile in Build 1607 not fully working?


    I've encountered a strange behavior of the CopyProfile feature in Windows 10 Anniversary Update. We typically create our images in Audit Mode on a VM and use CopyProfile in the Answer File to make sure all users have the same visual experience. This includes not only the Start Tile layout, but also general settings like: always show all icons in Notification Area; File Explorer opens to This PC instead of Quick Access; and most Startup items being set to "Disabled" in the Task Manager's Startup pane.

    Until recently this has always worked without any problems (since they fixed it with Build 1511 of course), but in the last two weeks every time I pull a new copy of my image the Start Tiles are fine, but NONE of those other options I mentioned get carried over into the new Default profile! I know the CopyProfile switch is being processed because the layout of our Start menu is as I expect it to be (no tiles at all, only the All Apps menu), but that appears to be the only aspect of the profile being carried over. I pride myself on the appearance of my image, and I'm admittedly fanatical about my notification area and especially File Explorer opening onto This PC.

    Has anyone else had this same experience? I don't know of anywhere in the image offhand that I could have accidentally chosen this behavior...

    Any advice would be greatly appreciated!
      My ComputerSystem Spec
  2.    27 Jan 2017 #2
    Join Date : Oct 2013
    A Finnish expat in Germany
    Posts : 12,979
    Windows 10 Pro

    Start modifications (add / remove tiles) do not need CopyProfile set to TRUE. When adding tiles they might be in slightly different order than set before Sysprep, but mostly that works even when CopyProfile is not used.

    Based on that, the fact that Start does not show tiles you removed before sysprepping is not a 100% sure way to know that all modifications were copied to default profile.

    I have currently only Creators Update / Insider preview installed on my physical and virtual machines, testing this with build 15014 will not tell how it works in build 14393, version 1607. I will install 1607 this weekend on a reference machine and test various settings you mentioned using CopyProfile = TRUE, will post what I will find out in case it might help you to find reason for this behaviour.

    Kari
      My ComputerSystem Spec
  3.    30 Jan 2017 #3
    Join Date : Jan 2017
    Posts : 3
    Windows 10 Anniversary Update
    Thread Starter

    Between Friday night and early this morning we've rolled back our VM through several checkpoints and tried again. The CopyProfile switch seems to work as intended in Build 1607, as far as I can tell. There are several of us working on this iteration of our image, and I'll confirm with my staff if anyone tried to "clean" the Default user profile before I pulled the test copy Friday morning. In all likelihood the handful of settings that didn't get copied were probably kept in some kind of database file under the hidden AppData user folder, which we sometimes try to shrink down to decrease login times. Thank you for your offer of help, Kari!
      My ComputerSystem Spec
  4.    30 Jan 2017 #4
    Join Date : Oct 2013
    A Finnish expat in Germany
    Posts : 12,979
    Windows 10 Pro

    I've not had time to run tests yet. Thanks for reminding me, I'll try to do this today.
      My ComputerSystem Spec
  5.    31 Jan 2017 #5
    Join Date : Jan 2017
    Posts : 3
    Windows 10 Anniversary Update
    Thread Starter

    I've confirmed it - one of our technicians did a "clean up" of the admin profile before we pulled the image that experienced these problems. It appears that one of the deleted folders caused these settings to be erased; subsequent testing confirmed the CopyProfile feature to be working normally. :-)

    In other news, we've started playing with the LTSB Windows 10 v1607, which comes with none of the system apps. Initial login times are back under one minute, but it we've run into trouble with Taskbar icons not coming through with CopyProfile. It doesn't matter at the moment, as we've worked around that by adding File Explorer to the Start Menu for now. We have technicians working on this new issue and searching other threads/forums for more info. Thanks for reading!
      My ComputerSystem Spec
  6.    31 Jan 2017 #6
    Join Date : Oct 2013
    A Finnish expat in Germany
    Posts : 12,979
    Windows 10 Pro

    Good to hear you found the culprit. I've been testing most of yesterday evening and today, I couldn't replicate your issue.

    Just a heads up: Sysprep and customizing in Audit Mode will work just as fine with next major update, Windows 10 Creators Update (depending on if they release it in Mars or April that will be version 1703 or 1704). Since late last week when pre-release build 15019 was released I've already done at least 25 - 30 Sysprep runs with it testing various scenarios. Looking good!

    Kari
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Build 1607 Not Installing
Hello, My little netbook is having trouble installing Build 1607. Currently I have Win10 Pro 32-bit, Build 10240. There was a recent update to that build, it installed fine, and now the only update that keeps coming up is Build 1607. Each time,...
Windows Updates and Activation
touchpad stopped working after 1607 update
I have an Acer Aspire ES1-711-P14W, When I initially reinstalled my touchpad wasn't working so I installed these drivers from Acer it worked fine until I updated to Version 1607 Build 14393.10: Chipset Intel Chipset Driver 10.1.1.7 IO...
Drivers and Hardware
Solved Who Wants a Fully Working Recycle Bin Icon in the Windows 10 Taskbar?
Who Wants a Fully Working Recycle Bin Icon in the Windows 10 Taskbar? I read garbage like this and wonder "How much do people really know how to use Windows?" I have been placing my Recycle Bin on my taskbar since Windows 7. All you have...
Customization
CopyProfile XML for Start layout
Has anyone managed to get customize the start menu and then copying that customization in the default user by using the CopyProfile method? Link: Start layout for Windows 10 desktop editions - Windows 10 hardware dev Moreover, has anyone...
Customization
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 04:11.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums