1.    14 Dec 2016 #1
    Join Date : Jul 2015
    Posts : 21
    windows 10

    administrator errors


    i get
    please log on with administrator privileges and try again,when trying to load a game which i have played for 8 years and re installed on w10.
    i have tried run as administrator,take control,looked at the security properties and have them set to allow full control,but still get above error?
    Windows 10 is really annoying when it comes to administrator issues.any help appreciated.
      My ComputerSystem Spec
  2.    14 Dec 2016 #2
    Join Date : Oct 2014
    Trnava
    Posts : 2,866
    Windows 10.4 Home 1709 x64

    It is generally better not to install games on system drive (C) or at least not to system folders like ProgramFiles.

    Try to install it on other partition or to your user folder (C:\Users\YourUSerName) - %USERPROFILE%
      My ComputerSystem Spec
  3.    15 Dec 2016 #3
    Join Date : Jul 2015
    Posts : 21
    windows 10
    Thread Starter

    Quote Originally Posted by TairikuOkami View Post
    It is generally better not to install games on system drive (C) or at least not to system folders like ProgramFiles.

    Try to install it on other partition or to your user folder (C:\Users\YourUSerName) - %USERPROFILE%
    The game is installed on a different drive E drive,its not on the C drive.
      My ComputerSystem Spec
  4.    15 Dec 2016 #4
    Join Date : Jul 2015
    Posts : 21
    windows 10
    Thread Starter
      My ComputerSystem Spec
  5.    15 Dec 2016 #5
    Join Date : Jul 2015
    Posts : 21
    windows 10
    Thread Starter

    further "
    If you see that message in Windows 10 then you are out of luck and the game will not run on Windows 10 There are no known legitimate or safe methods to install or run these older games on Windows 10"
    So Rome Total war which i bought about 8/9 years ago now wont play on W10 because they have decided....
    Nor will Total war barbarian invasion again bought 6/7 years ago.
      My ComputerSystem Spec
  6.    15 Dec 2016 #6
    Join Date : Jul 2015
    Posts : 21
    windows 10
    Thread Starter

    Anybody know how to remove above update on w10. W7 it was easy enough?
      My ComputerSystem Spec
  7.    15 Dec 2016 #7
    Join Date : Jul 2015
    Posts : 21
    windows 10
    Thread Starter

    even tried compatibility mode W7 and get incompatible device...
      My ComputerSystem Spec
  8.    15 Dec 2016 #8
    Join Date : Jul 2015
    Posts : 21
    windows 10
    Thread Starter

    This from another thread best describes the issue if you want to play games or rather not on windows 10.
    Perhaps there should be a specific thread from the forum admins explaining this and there wont be as many post asking the same questions?

    his explains why Rome Total War will not run if your trying to use the original CD version of the game!! The manufacturer of the game cannot make a fix to this issue. They have fixed preference issues, but can not get around the SafeDisc issue. This of course is for hard copies of the game (CDs).
    I am also experiencing the same problem. This game used to work on windows 7, but after I did the upgrade to windows 10, it no longer worked. I've tried everything to fix the issue, but have not had any luck. Originally, the files on it were corrupted after the upgrade and somehow did not exist on my computer anymore.. After a fresh reinstall, the desktop short cut no longer worked. I was able to get the start up window for the game started when I went into "my computer" and launched it from there. But after I hit "play game" it popped up a small window saying it was "designed with demo shield" and then did nothing. The game ceased to start up or do anything after that. I assume it's because of the SafeDisc issue. I also got the same issues of "not valid permissions even though I am the administrator. I also tried messing with the settings and nothing worked. (Basically I experienced what the guy listed below.)

    I copied this from a member on the total war help forum who posted it on this Microsoft community help page. The guy said it best, and if a member of Microsoft see's it, they can hopefully take it up the latter and get this issue fixed!

    "Hello,

    I have discovered an unfortunate problem with Windows 10.

    Many games from the early-mid 2000's used Macrovision's SafeDisc (version 2) as a means of copy protection. At game startup, Windows loaded SECDRV.SYS to verify an original game disc was in the drive, after which the game would start.

    When you try to run ANY game which uses this SafeDisc form of copy protection in Windows 10, the following happens:

    - You get an error window that tells you to log in with Administrator Privileges and to try again. This happens on any account, even those with Administrator access. The game fails to start.

    - If you then set "Run as Admin" compatibility mode on the game's startup file, the message disappears, but the game doesn't start.

    - Keeping a window open for C:\WINDOWS\SYSWOW64\DRIVERS shows SECDRV.SYS appearing at the moment you try to start the game. Based on its size, it appears to be the file that is present on the game disc (tested across several games), even though I see no disc activity and cannot find the file elsewhere on my system.

    - The Windows event log shows that SECDRV.SYS failed to load.

    - This happens both with an upgraded install (Windows 8.1 > Windows 10) and with a fresh Windows 10 install, with one of the games being installed immediately upon the fresh install completing.

    - On my Windows 64-bit 8.1 system, C:\WINDOWS\WINSXS has a folder called amd64_macrovision-protection-safedisc_31bf3856ad364e35_6.3.9600.16384_none_4e6b3758913c9240 with a SECDRV.SYS in it, presumably the one that ships with Windows. Windows 10 had such a folder in early builds, but it is missing from the release build. It appears SafeDisc support is missing entirely.

    OTHER TESTING I HAVE DONE:

    - I updated one of the games to a version that no longer required the CD check, and it started immediately and ran perfectly once the check was removed. However, this is possible only with a very limited number of games, or resorting to fixes that violate the game's EULA or put the user's system security at risk.

    - I tried disabling driver signature verification and installing one of the games again; same problem.

    - Multiple compatibility modes; same problem. XP (Service Pack 3) mode and / or Run as Administrator mode make the error message go away, but the games still fail to launch.

    SIGNIFICANCE:

    Unless this is fixed in Windows 10, a massive catalog of older games will cease to function in Windows 10 for the simple reason that they cannot pass the SafeDisc copy protection check. I am accustomed to some games breaking with every new version of Windows as technology progresses (for example, the loss of the ability to run 16-bit programs in 64-bit Windows), but this seems to be an unnecessarily harsh change."


    Again, I copied that, I did not write it.. but it explains why the game does not run. Microsoft needs to put SafeDisc back in. However, this game will work if you run it off of Steam. Currently that is the only safe way to play it, but you need to of course have Steam.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Solved User is Administrator equivalent but getting permissiosn errors
I have a user whose PC is having permissions problems. It was recently migrated to WIndows 10. Some (but not all) of the files have problems when you attempt to open them. I'm using a user ID that is an Administrators equivalent, but when...
User Accounts and Family Safety
Blue screen errors while gaming - random errors
Hi Recently I am facing blue screen errors while gaming and recording with Nvidia ShadowPlay There is not single error which I can name, as crashes produced many BOSD errors Recent error was " Driver Expool Corrupted" while I was gaming...
BSOD Crashes and Debugging
Windows 10: Constant BSOD errors, different errors each time. HELP!!!!
Hi my name is Peter I am new to this so please excuse any mistakes in posting this I might make. I have very recently built myself a new pc to game on. Once I put the system together and installed windows 10 almost immediately I got BSOD with a...
BSOD Crashes and Debugging
Service control manager errors never goes away Persisting errors zeez
You are about too read a bad english. and i am really sorry about it i am not native english speaker Just installed window 10 th2 and few other software didn't upgrade it just did a clean install of it but service control manger errors never...
General Support
Administrator Errors
When I try to save photos or click certain links, I am told to get Administrator Permission. Checked the settings, I am listed as Administrator. I also got this message when trying to save the upgrade drivers for my printer. I have never had this...
User Accounts and Family Safety
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 10:00.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums