This appears to have been caused by the Anniversary Update that Windows installed last night. Ever since then, my data drive D: has become read-only! Oddly enough, I can still make copies of folders but the copies don't contain any files. When I try to delete the folder, I get told I need to provide administrator access (click for screenshot), and then permission from the owner. Of course, I am the owner, and also an administrator. So why can't I delete this??

This screenshot shows the advanced security settings for the folder in question. As you can see, both Administrators and me have Full Control. When I click on the "effective access" tab, it confirms that I have all permissions for this folder, as you can see here.

I've tried logging off and on again, I've tried manually re-setting my account to an administrator. whoami /groups confirms this (screenshot). I even tried using Elias Bachaalany's "Reset Files Permission" tool, all to no avail.

I'm starting to run out of ideas... can anybody help? The owner of the root directory D:\ is SYSTEM, but that doesn't seem wrong. Would really appreciate a tip, in my years of Windows joy and suffering I have never seen anything like this. Thank you!