1.    21 May 2016 #1
    Join Date : Jul 2015
    Pacific Northwest, USA
    Posts : 386
    Win10 x64 Pro -2 desktops, 1 laptop

    Can't log out of local account


    For a couple months I've had a single account without password protection - never had to purposefully log out - just shut down. I added another account a couple days ago. Now the PC hangs up with a blank screen for about 5 minutes when I try to log out. Eventually the PC wakes up, but the logout has failed.

    The only thing I see in the event log are a lot of the ubiquitous DistributedCOM 10016 errors, many with the userid of the user I'm trying to log out. Is there likely to be a connection? I've never noticed any external problem associated with the 10016 errors so I've never tried the rather long an (for me) complicated fixes. Should I try to fix this error, or would that be wasted effort?

    Is there anything else I should do to debug this problem?

    I think I'll try shutting down, but I'm not sure I'll be able to start back up.
      My ComputerSystem Spec
  2.    21 May 2016 #2
    Join Date : Oct 2014
    Trnava
    Posts : 2,954
    10.4 Home 1709 x64

    The error is usually related to missing permissions, do you have admin or standard account?
    My guess, it can not end some running software, try to run this as admin in CMD, in that account:

    reg add "HKCU\Control Panel\Desktop" /v "AutoEndTasks" /t REG_SZ /d "1" /f
    reg add "HKCU\Control Panel\Desktop" /v "HungAppTimeout" /t REG_SZ /d "10000" /f
    reg add "HKCU\Control Panel\Desktop" /v "WaitToKillAppTimeout" /t REG_SZ /d "20000" /f
    reg add "HKLM\System\CurrentControlSet\Control" /v "WaitToKillServiceTimeout" /t REG_SZ /d "20000" /f
      My ComputerSystem Spec
  3.    21 May 2016 #3
    Join Date : Jul 2015
    Pacific Northwest, USA
    Posts : 386
    Win10 x64 Pro -2 desktops, 1 laptop
    Thread Starter

    Both accounts have admin authority. You could be right about not being able to end some running software, but that in itself is worrisome. I think I an going to restore my PC back to before I defined the troublesome account. I had some problems defining the account and may have messed things up.
      My ComputerSystem Spec
  4.    21 May 2016 #4
    Join Date : Jul 2015
    Pacific Northwest, USA
    Posts : 386
    Win10 x64 Pro -2 desktops, 1 laptop
    Thread Starter

    It took me a while, but I did a recovery using a week-old backup, defined the new account, and all is well.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Side effects/questions converting an MS account to a local account?
I have had some annoying MS account related issues on our new laptop (whilst our desktop works fine with our family accounts). See https://www.tenforums.com/user-accounts-family-safety/45165-user-account-family-issues.html. It's made me consider on...
User Accounts and Family Safety
Local account login changed to Microsoft Account so unable to log in
I would like help solving a mystery. I set up a new Dell Optiplex 3020 which shipped with Windows 10 Pro. I bypassed the option to set up the user with a Microsoft Account (The owner does not have a microsoft account and I did not create one at...
User Accounts and Family Safety
How do I set shares using Ms Account - Works fine when LOCAL account
Hi there Using a LOCAL account I have no problem with Shares -- how do I set these now using an Ms account. Samba just times out trying to access Windows machine where I'm logged on with an Ms account. Also I can't access other Windows...
Network and Sharing
Solved Local account changed to MS account, act as separate accounts at login
So I originally started with a local account but then signed into the store with a MS account. I changed the setting where users are required to enter a password through netplwiz (like this) and making a password not required after waking from...
User Accounts and Family Safety
IE11 crashes and restarts on MS account --OK on Local account
Hi there IE11 re-starts itself every so often after a few web pages -- only happens on MS account. It's FINE on a LOCAL account !!!!. You also see this Forum error sometimes (I've posted in the Forum bugs too). Cheers jimbo
Browsers and Email
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 01:21.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums