Windows 10: So is C: root unavailable per default? Solved

Page 1 of 2 12 LastLast
  1.    17 Jan 2016 #1

    So is C: root unavailable per default?


    I just came across an error regarding use rights in the root of C:, I can not place files there. I can create a folder and place files inside the folder, but not in root.

    Is this to be expected?

    I got error 0x80070522 when trying and found this older thread about it: Unable to change Admin Settings - Windows 10 Forums

    The post is answered by referring to the tutorial of Take Ownership, but I do not think that is relevant to this case.
      My ComputerSystem Spec

  2.    22 Jan 2016 #2

    Can anyone verify this?
      My ComputerSystem Spec

  3.    22 Jan 2016 #3

    That is completely normal. The GUI will let you make a folder but not a file. Any program you run as a normal user (even if that user is part of the administrators group) will not let you save there.

    However if you open an administrator command prompt and type
    Code:
    echo "whatever" > C:\test.txt
    you will find it has created a file test.txt at root of C containing the word "whatever".

    Similarly if you open notepad or many other programs as Administrator (right click on the program, run as administrator) it will let you save in root of C.

    What are you trying to do exactly? You can run a program as administrator to do it but otherwise I can't give a sensible suggestion unless you say what the objective is. There are also other issues with running things as administrator so don't take that as a default answer.

    Definitely don't take ownership of the whole of the C drive whatever you do though. That would cause no-end of problems.
      My ComputerSystem Spec

  4.    22 Jan 2016 #4

    What files where you trying to place there?
      My ComputersSystem Spec

  5.    22 Jan 2016 #5

    It is my own desktop and on my 7 machine I had a couple of cmd scripts there that ran a robocopy every system start... Just putting them back to the same location according to my own system setup documentation.
    It is not a corp comp.

    Thanks for the clarification.
      My ComputerSystem Spec

  6.    22 Jan 2016 #6

    I'd recommend you run any robocopy job as admin anyway (whether you want to copy to root of C is up to you).

    Just tick the "Run with highest privileges" box on task scheduler (assuming you are starting it it like that).
      My ComputerSystem Spec

  7.    22 Jan 2016 #7

    No, not starting like that. Shortcut to Programs/Startup folder..

    Running CMD batch's via Task Scheduler has in my experience not always worked very well, often error with exit messages, perhaps it works better in 10, but have not tried it.
      My ComputerSystem Spec

  8.    22 Jan 2016 #8

    Best practice with hard drives has always been to put files within folders and not directly in the root of the drive. The only files that should be in the root of the drive are system files that must be there. You need a compelling reason to depart from this principle and I don't see it.
      My ComputerSystem Spec

  9.    22 Jan 2016 #9

    Compelling reason? On my own local desktop?

    Just because I want it that way, I consider it tidy, in my opinion. I do not apply "best practice" on my own desktop.
      My ComputerSystem Spec

  10.    22 Jan 2016 #10

    Coram Daes said: View Post
    Running CMD batch's via Task Scheduler has in my experience not always worked very well, often error with exit messages, perhaps it works better in 10, but have not tried it.
    I can't say as I've always used task scheduler since 7.

    In any case without changing permissions you'll need to get the thing to run as Admin. I don't think you can do that easily any more using Startup folder (but you could try this).

    Coram Daes said: View Post
    I do not apply "best practice" on my own desktop.
    You could take ownership of the whole C drive but it would most likely cause problems. This isn't a moral objection (you can do what you want) only that some permissions are inherited and some explicit and if you change the root to have explicit permissions you'll overwrite what was there before (as explicit permissions always override inherited) and you'll end up with your permissions being wrong and no way to reset them as MS doesn't say what they should be in the first place anyway.

    You could do it but it might cause you issues later on to the extent you have to re-install.
      My ComputerSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
Windows 10 November Update Unavailable? in Windows Updates and Activation
Hello, I recently tried to update the newly released Windows 10 update However, after installation it said that the update has failed. I clicked on "Retry" but nothing happened. Re-checked for new updates but says device is up to date. I restarted...
I just installed Speccy and Unchecky; in August, I install OmniPage with PDF Creator. When I go try to make PDF Creator my default program, it's not there in Settings>Default Apps. So, I go to Apps and Features and find it's installed but marked...
I see a long list of my windows 7 apps. Some have a size and date and other have the date and the words "unavailable". What does this mean and if it means I can't run the app, what can I do about it? Do I have to find a Win 10 compatible...
No BSOD. Services unavailable and more in AntiVirus, Firewalls and System Security
Hi! First of all sorry if this post is not mean be here. Since I didn't find a Troubleshooting section I thought this was the most appropiate forum to post this. Just upgraded to Win10 Pro x64 a couple of days ago from Win 7 x64 (I think...
Hi there Is sourceforge changing possibly into a "Pay" site or something --it's been unavailable for a few days. Used to be fine for all sorts of Open source software. It's sometimes difficult to find alternate mirrors for some decent open...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 03:57.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums