I normally log on to Windows 10 Home (a clean install) with my User Account. Let's call my User Account "Jerry".
When I need to run something as admin, I enter my administrative account password in the UAC screen. Let's call my admin account "Tom".
"Tom" and "Jerry" are linked to two Microsoft accounts of mine.
So far, so good.

What's weird, though, UAC lists "Tom" twice. Both entries share exactly the same name (my Microsoft account name, not the local name) and same email address.
Only difference is, one entry shows my icon pic, the other is blank.
Both of them accept the same password (Microsoft account password) and both of them do unblock UAC successfully.
Question #1: Should I do something about it and remove the duplicate entry (how?), or just ignore this "Windows oddity"?

In case it helps, my admin account is with the following groups: Administrators, Users and Home Users.

Besides, I have to tell you I changed the computer name after install, then I also did something in User Accounts like adding a description to "Jerry" into the description field.
I am not 100% sure whether there's cause and effect, but after a while I noticed something weird had happened: "Tom" the admin was not an admin any longer, just a limited user (I had to add it to Administrators again, now it works fine), and "Jerry" the user was not in any groups any longer, it wasn't even showing on the Windows logon screen. I had to add it to the Users and Home Users group again and now it works fine too.
On the same Windows, I have a third account too, a local administrative account. It was not affected by any oddities. I use it as emergency logon only, though. I used that to add "Tom" to admins again.

Question #2: Would you recommend that I go back to a pre-computer-name-change Windows state, using a Restore Point?
Question #3: Would you recommend that I unlink Tom the admin from the Microsoft account?
Or I shouldn't worry about all that? After all, apart from the duplicate entry in UAC and apart from those other "oddities" I already fixed, everything seems to be working fine now.

Thanks in advance for any suggestions!