Windows 10: UAC is off; still getting permission prompts for mundane tasks.

  1.    13 Sep 2015 #1

    UAC is off; still getting permission prompts for mundane tasks.

    Hello. I'm having an issue after upgrading to windows 10 from 7. I've been getting a lot of strange administrator permission prompts, despite being on the admin account and having UAC completely off. This occurs on very mundane operations, such as deleting a photo or even creating/renaming a new folder. The thing is that it only occurs in the C: drive (not in my D: storage drive), presumably because this is the OS drive and it was somehow changed after the upgrade.

    I noticed this because none of the games in my steam library that are installed to C: are working. They won't launch (can't find the exe) and they won't update (disk write error). I assume this is part of the same problem, and they don't have proper permission. The games will finish downloading and will update if I run steam as admin, but I shouldn't have to do this because I'm on the admin account and UAC is off. Does anyone have ideas on how I can fix this, take ownership of the whole C: drive, enable the build-in admin on my main account, or any other fixes? This is on a self-built computer (Gigabyte z87-ud3h, i5-4670K, 780ti, etc) and I am the only user. Thank you.
      My ComputerSystem Spec

  2.    13 Sep 2015 #2

    To add to this, the problem may be related to the access level of various folders and files in my C: drive. Under the security tab in properties, a number of folders (like program files, program files (x86)) don't have full control for administrators and users, and I the option to give them full control is grayed out. For certain other folders, like steam, admins have full control but 'users' do not. My account is an administrator but I'm still prompted to create a new folder, for example. When I give 'users' full control, this prompt goes away.

    Does this mean that my account is not properly given admin permissions, despite the fact that it says I'm an admin under local users and groups and elsewhere? Did something get screwed up when I initially logged into my microsoft account from my local account?
      My ComputerSystem Spec

  3.    23 Sep 2015 #3

    I have similar problems...I see nobody has answered you and I'm wondering also how to get around always clicking on "Run as Administrator" when the UAC is disabled. Maybe somebody that knows will answer us here.

    I am using a Dell and Skype, Chrome, Microsoft Word all need the extra clicks to open with the UAC turned off. I don't know what I'm doing wrong. On another Dell laptop everything is working fine, but this problem is on a Dell Latitude laptop with the same UAC level on the settings screen. It shouldn't be doing that should it? It is likely some easy setting somewhere that I don't know about. I am not used to Win 10 yet and didn't use Win 8 so there is a little learning curve.
      My ComputerSystem Spec


Related Threads
Solved Google Tasks Unnecessary? in Performance & Maintenance
When I examined the startup programs under Task Manager right after I did a cold boot, I noticed several instances of Google Chrome and Google Installer already running. 36540 Is that supposed to happen? Are those all necessary?
Solved God Mode / All Tasks in General Support
I did a search and nothing came up on it, I didn't find it in the tutorials section, I copied my god mone from Win7 to a flash drive dragged and dropped on my W10 desktop and it works as it always has,,, not sure if someone wants to add it, I find...
User account does not have permission to modify tasks in User Accounts and Family Safety
Since upgrading to Windows 10 only one of my scheduled tasks seems to work. I cannot edit a current task or create a new one as I get the following error message: "Task scheduler cannot apply your changes. The user account is unknown, the...
Source: Location consent prompts and settings improvements in Windows 10 Mobile | Building Apps for Windows
I have no tasks in my GWX taskscheduler folder..any suggestions on how to get the icon to show up? thanks!
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 22:39.
Find Us