User permissions incorrect (corrupted?) for admin account?

  1.    2 Weeks Ago #1

    User permissions incorrect (corrupted?) for admin account?


    I have a machine I have had for a few years and has been working fine. Suddenly a couple days ago Dropbox gave me an error that it couldn't start and said the error was 'usually because of a permissions error'. Since then, Photoshop will not start, saying it doesn't have access to some files it needs, and I have several other programs that are not working correctly with similar messages. My main account that I use is an admin account, but it is still giving these messages. I did figure out that if I start Dropbox or Photoshop in admin mode they start ok. Other programs also start as administrator and work better but some still seem to have issues.

    One program mentions the a folder under the local app data temp folder (C:\Users\*username*\AppData\Local\Temp) so I went there to see what I can see for permissions. My account is listed with full permissions to that folder. I do notice that there is an odd security item named 'LogonSessionId_0_1568081 (NT AUTHORITY)" that I don't remember seeing, but it's not listed as having any permissions at all except for 'special permissions' which is grayed out... If I go to 'Advanced' and 'Edit' for that account it shows basic permissions of 'Read & Execute, List folder contents, and Read'.

    I also found in a subfolder of the above named 'UnionWinmdWorkingFolder'. When I go to permissions here it tells me 'You do not have permission to view this objects security properties, even as an administrative user.'

    Lastly, along side that temp folder, There are 53 folders named something like 'Tempzxpsign0ce74a38c9836c50' (All start with 'Tempzxpsign' and then have a bunch of letters and numbers after them). All appear to be empty from what I can see.

    The only things I can think of that I have installed recently are the Angular CLI and one or two node.js packages but those were well before the issue started...

    Anyone else seen this or had this issue? Is this some type of virus? BitDefender doesn't detect anything...
      My ComputerSystem Spec

  2.    2 Weeks Ago #2

    I also forgot to mention that I tried to create another admin local account on the machine. That worked and that account can start Photoshop and others without running as admin. However on that account whenever I try to go to a webpage it says could not load with a 'connection timed out' error... It shows I'm connected to the wifi and have internet access but both chrome and edge won't load a page... Not sure if that's related or not...
      My ComputerSystem Spec

  3.    2 Weeks Ago #3

    Welcome to the forum. Just because your admin doesnt give you full rights many folders are owned by system which is above admin these are set for system critical folders so you can knacker windows. A lot of users folders are owned by the user and often admin has no rights on them as well.
    When you install some software it asks if you want everyone to use it or just you depending on the answer it put needed files were everyone can load them or in private folder for the user.

    The tmp files folder may be in use and will be owned by the software disk clean will remove them as it runs as system.
      My ComputerSystem Spec

  4.    2 Weeks Ago #4

    ok that makes some sense as far as the system permissions. However, why would a bunch of programs suddenly not have access to the necessary folders for them to run when all were running fine recently? I also tried the grant via cmd prompt as described at Dropbox is stuck syncing, won't open, or shows an error – Dropbox Help (see 'Windows' section under 'Permissions Error'). That is specific to Dropbox but Dropbox still had the same error after doing that.
      My ComputerSystem Spec


 

Related Threads
Corrupted Admin Account (Mine) in User Accounts and Family Safety
A strange thing started happening a month ago. When I logged into my Admin account, it went through the normal log in process and when it finished my screen went completely dark. The same thing happened to another password protected account, but...
Admin Account But No Permissions To Access Files. Why? in User Accounts and Family Safety
I am logged onto win10 with an administrator account yet I keep getting 'no permission' messages. Not generally but this morning for instance in IIS. I couldn't read the log files in IIS. So I simply went to Explorer and found the log file...
Hello everybody, I have realized that all the laptops I installed Windows 10 in the last year (several family laptops) are running with Microsoft-Accounts which are Admin-Accounts. Now I read that this is a serious security issue. I would like to...
Hello All, I'm delighted to have found you and after a long day of trying to help myself i am now requiring your much appreciated assistance please!:cry: I'm not a techy person at all and am hoping someone can help:) Last week my husband purchased...
I have not found anything like my problem on any forum or thread. In my Administrator Account the Windows Store opens and I can install Apps. I expected those same Apps I just installed to appear in my User Account, they did not. Both my Admin and...

Tags for this Thread

Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 22:30.
Find Us