Windows 10: How to make Win10 Pro act more like Enterprise when disabling UAC?

Page 2 of 2 FirstFirst 12
  1.    1 Week Ago #11

    We are potentially on to something here I think!
    I will start testing first thing tomorrow. I've had the issue since first using W10 on 16xx. I always believed it was intentional by Microsoft. Even on PCs that are prebuilt I've had the issue.
    So I'm beginning to believe it may be a localisation bug with Pro. I would have to double check the iso for Enterprise as I'm not 100% sure if it is a localised or US version.
      My ComputerSystem Spec

  2.    1 Week Ago #12

    Ok well sadly installing the US version I still have the same problem.
    But Installing the W10 Pro N edition, it does not have this problem. Unfortunately that means buying different keys and that won't be possible.

    I have used the GPEDIT suggestion in your Previous post and this does have the desired effect so I will go ahead and use these settings for our Environment for now, until such time I can test this further and get a better understanding.

    I would still love to know what ISO you used if you kept it, then I can test using that one.

    Thanks for your help
      My ComputerSystem Spec

  3. xTL's Avatar
    Posts : 212
    Windows 10 Pro 64-Bit (1809) 17763.1
       1 Week Ago #13

    AGTDenton said: View Post
    We are potentially on to something here I think!
    I will start testing first thing tomorrow. I've had the issue since first using W10 on 16xx. I always believed it was intentional by Microsoft. Even on PCs that are prebuilt I've had the issue.
    So I'm beginning to believe it may be a localisation bug with Pro. I would have to double check the iso for Enterprise as I'm not 100% sure if it is a localised or US version.
    I wish you good luck! :)


    AGTDenton said: View Post
    Ok well sadly installing the US version I still have the same problem.
    But Installing the W10 Pro N edition, it does not have this problem. Unfortunately that means buying different keys and that won't be possible.

    I have used the GPEDIT suggestion in your Previous post and this does have the desired effect so I will go ahead and use these settings for our Environment for now, until such time I can test this further and get a better understanding.

    I would still love to know what ISO you used if you kept it, then I can test using that one.

    Thanks for your help
    Nps AGTDenton, im glad i could at least help you out a little bit :)
    If i find my .iso i'll make sure to send you a PM & also update this post here with the .iso details.
    But i'm pretty sure the .iso was located on my 4TB WD red that i dropped ( because i suck ) so not possible for me to check
      My ComputerSystem Spec

  4.    1 Week Ago #14

    FWIW I tried on 1809 with UAC turned off for Pro upgraded from 1803 and PfW clean installed.
    Both are en-US.

    Without UAC both open administrator powershell (from + X, A) fine without prompt. Running cmd brings up standard in both cases and opening cmd elevated via right click opends without prompt.

    I don't have Enterprise so can't check it but if it is automatically opening a program an administrator then I think that is a bug. It should open under your user security unless you tell it otherwise - UAC isn't material here - it just affects if you are prompted to authorize running in different security context I think.

    You can bypass it and run everything as Admin with IsolatedCommand and so on but that isn't your question I think.
      My ComputerSystem Spec

  5.    1 Week Ago #15

    Thanks for the reply lx07. xTC has provided the best usable work around for me at the moment.
    I am not having a problem with popups it is to do with elevating privileges not happening when UAC is disabled.
    Because the solution provided is easy to implement with a few reg keys I probably won't investigate any further unless i can find some spare time. I believe there to be a bug based on what xTC has said and the discovery I made with the N edition.
    Cheers
      My ComputerSystem Spec

  6. xTL's Avatar
    Posts : 212
    Windows 10 Pro 64-Bit (1809) 17763.1
       1 Week Ago #16

    AGTDenton said: View Post
    Thanks for the reply lx07. xTC has provided the best usable work around for me at the moment.
    I am not having a problem with popups it is to do with elevating privileges not happening when UAC is disabled.
    Because the solution provided is easy to implement with a few reg keys I probably won't investigate any further unless i can find some spare time. I believe there to be a bug based on what xTC has said and the discovery I made with the N edition.
    Cheers
    i am now xTC from xTL
    xTL ~ xTC
    xD
      My ComputerSystem Spec

  7.    1 Week Ago #17

    xTL said: View Post
    i am now xTC from xTL
    xTL ~ xTC
    xD
    Ooooh,
    Sorry late nights of making Windows images for a new client :)
      My ComputerSystem Spec

  8. xTL's Avatar
    Posts : 212
    Windows 10 Pro 64-Bit (1809) 17763.1
       1 Week Ago #18

    AGTDenton said: View Post
    Ooooh,
    Sorry late nights of making Windows images for a new client :)
    No worries =P
    how come i think of bitcoins when i see xTC ?
      My ComputerSystem Spec


 
Page 2 of 2 FirstFirst 12

Related Threads
Hello, I would like to know, does disabling automatic updates works on Windows 10 v1607 (Anniversary Update)? I would like to set it to ask me before installing updates. I tried set it via Edit group policy on Win10 Enterprise LTSB 2016 in...
Solved Upgrading From Win7 Enterprise to Win10 in Installation and Upgrade
I'm trying to beat the MSoft clock that runs out on 7/29 for the free upgrade to Win10. Wouldn't you know it, of all the hiccups I would get is the error saying "Can't update from Win 7 Server, or Enterprise to Win10. See Admin." Well, I AM THE...
I'm so frustrated by Windows 10 constantly changing the default printer, and changing the setting that allows it to do so, but I admit whilst I've experience in scheduling tasks and running basic .bat files, the solution offered over at...
Hi this may seem like a stupid question (I feel kind of stupid for asking it haha) but I need help DISABLING the address bar in windows explorer. I only need it to be temporary. The reason I need to disable the address bar is when I'm...
Does anybody know if Microsoft is aware of all the network problems people are having with Win10? I kind of like Win10 but I am not going to use it when it constantly disables my network every few hours.
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 08:28.
Find Us