Windows 10: Access is denied in wmic Solved

  1.    13 Mar 2018 #1

    Access is denied in wmic


    A Windows server 2008 R2 with the name "delta" use Workgroup "WORKGROUP" (So is not member of a domain).
    On system "delta", beside account "administrator", an other account "sysadmin" is created with account type Administrator.
    The other Windows system has the name "gamma".
    It is possible to access the system "delta" from system "gamma" with remote desktop.
    This access succeeds both with the accounts "administrator" and "sysadmin" and the corresponding passwords.
    From system "gamma", with the command, "wmic" data can be requested from system "delta".
    This works correct with account "administrator".

    C:>wmic
    wmic:root\cli>/node:delta /user:administrator /password:xxxxx cpu get name
    Name
    Intel(R) Xeon(R) CPU E3-1220 V2 @ 3.10GHz

    For account "sysadmin" the command "Dcomcnfg" is started on system "delta".
    Expand Component Service – Computers – My computer
    Open the properties of My Computer and select “COM Security” tab.
    Under COM Security, click "Edit Limits" for "Access Permissions".
    The account "sysadmin" got "Remote Access".
    Click "Edit Limits" for "Launch and Activation Permissions".
    The account "sysadmin" got "Remote Launch" and "Remote Activation" permissions.

    Expand Component Service – Computers – My computer - CDOM Config
    Open the properties of "Windows Management and Instrumentation".
    Choice tab "Security"
    Click "Edit" for "Launch and Activation Permissions".
    The account "sysadmin" got "remote Launch" and "Remote Activation" permissions.
    Click "Edit" for "Access Permissions".
    The account "sysadmin" got "Remote Access" permissions.

    Still I get "Access is denied" with wmic from system "gamma" to system "delta".

    C:>wmic
    wmic:root\cli>/node:delta /user:sysadmin /password:yyyyy cpu get name
    Node - delta
    ERROR:
    Description = Access is denied

    How can I solve this problem?
      My ComputerSystem Spec

  2.    13 Mar 2018 #2

    There's a bunch of good stuff on this available, courtesy of Bing:
    troubleshooting wmic permissions for remote access - Bing

    The first 5 items look spot on. Hope you find some relief in one or more of them.
    HTH,
    --Ed--
      My ComputersSystem Spec

  3.    19 Mar 2018 #3

    The problem was solved after adding permissions for the user "sysadmin" on system "delta" to the
    WMI namespace.

    Open WMImgmt.msc on system "delta"
    Go to the Properties of WMI Control
    Go to the Security Tab
    Select "Root" "CIMV2" and open "Security"
    Add user "sysadmin"
    Ensure "sysadmin" has "Execute Methods",
    "Provider Write" and "Enable Account" right;

    Thanks.
      My ComputerSystem Spec

  4.    19 Mar 2018 #4

    Glad you got it sorted. Great detective work!
    Best wishes,
    --Ed--
      My ComputersSystem Spec

  5.    01 Apr 2018 #5

    This WMI stuff is over my head but I have a problem that led me here. I cannot choose the default app I want to use in some cases. Brink suggests I reregister apps. But, In Powershell, I cannot run Get-AppXPackage -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}. It gives me an error "Access is denied." Reading another site "You have to grant that user WMI permissions." My question is - Am I on the right track. I read a tutorial by Shawn Brink (https://www.tenforums.com/tutorials/3175-reinstall-re-register-apps-windows-10-a.html#option1) but there was no mention of "Access is denied" error.
      My ComputerSystem Spec

  6.    02 Apr 2018 #6

    Never mind. I got it. I needed to run Powershell with admin priv.
      My ComputerSystem Spec


 

Related Threads
Access is denied in User Accounts and Family Safety
I'm trying to free on space on Drive C: and cannot get into "Documents and Settings" or see what space it's using. Just "not accessible Access is Denied". It looks like it's a shortcut, not a folder. Guess it's a Win 10 thing ? Can I get...
While searching the web for a number of things using Microsoft Edge, Chrome and Avast SafeZone I came across: Access Denied You don't have permission to access "http://www.baskinrobbins.com/" on this server. Reference...
Access denied in User Accounts and Family Safety
How do I let Windows 10 know that when it comes to this computer, I am the owner, the administrator, the decision maker and the boss; and that I don't need anyone's permission to do what I want as long as the system is able to do it and it is legal.
Access denied in General Support
As a windows 10 administrator (the only one) I keep getting access denied when I try to open the application data folder. My Win 10 was an upgrade from win 7. This is as frustrating as h--l! Can anyone sort it for me. Make sure you describe...
Access is denied in General Support
43942Hi when I go to This pc-Local Disc c-Users-admin there are a lot of short cuts that bring up an error message43943can these be deleted or can someone explain what they are. Cheers............
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 12:29.
Find Us