DISM - Add or Remove Drivers on an Offline Image  

Page 5 of 9 FirstFirst ... 34567 ... LastLast
  1. hsehestedt's Avatar
    Posts : 2,090
    Windows 10 Pro, 20H2
       #40

    techquest,

    That error message is referencing an image. You need to run that command against the folder to which you copied the contents of the image on the hard drive or SSD.

    To summarize:

    You should be copying the contents of a Windows 10 ISO image or DVD to a folder on the hard drive. Then run the attrib command referencing that folder.

    As an example, suppose you have a Windows 10 ISO image. Right-click the image and choose mount. Go to the drive letter that the image is mounted as, select all the files and copy them to a location on the hard disk. Use that folder to perform all further operations. In fact, you can right click the drive letter that the ISO image was mounted to and select eject at this point since you don't need it any longer.

    Apologies if that is already what you are doing. It's just that it sounds like you are working on the image rather than the files copied from that image.
      My Computers

  2. techquest's Avatar
    Posts : 1,602
    W10 Enterprise
       #41

    hsehestedt said:
    techquest,

    That error message is referencing an image. You need to run that command against the folder to which you copied the contents of the image on the hard drive or SSD.

    To summarize:

    You should be copying the contents of a Windows 10 ISO image or DVD to a folder on the hard drive. Then run the attrib command referencing that folder.

    As an example, suppose you have a Windows 10 ISO image. Right-click the image and choose mount. Go to the drive letter that the image is mounted as, select all the files and copy them to a location on the hard disk. Use that folder to perform all further operations. In fact, you can right click the drive letter that the ISO image was mounted to and select eject at this point since you don't need it any longer.

    Apologies if that is already what you are doing. It's just that it sounds like you are working on the image rather than the files copied from that image.

    Thanks, no apologies needed as you never know, but I can confirm I was working on the correct copied files in the correct folder. I also thought, just to be sure it wasn't anything to do with the external ssd, of going through everything again using a partition on the same drive as C: , so I did but sadly the same result as before. So now I'm going to try Kari's suggested repair install as there seems to be nowhere else to go at this point. As said earlier I will let you guys know how it goes after the event.

    - - - Updated - - -

    Decided to do clean install W10 1903 so back up and operational now.



    This is why I've got a smile and thought you would want to know after all the efforts that have gone into this, it's gold:


    :\WINDOWS\system32> DISM /Mount-image /imagefile:N:\ISO_Files\sources\install.wim /Index:3 /MountDir:N:\Mount
    Deployment Image Servicing and Management tool
    Version: 10.0.18362.1

    Mounting image
    [==========================100.0%==========================]
    The operation completed successfully.



    Thanks to you both for your efforts and I have enjoyed working with you and the learning curve that stuff like this moves me through. Will be playing The Star Spangled Banner tonight for sure, Hendrix style (Woodstock) and Whitney Houston (Super Bowl XXV) if that's okay with you, sorry Kari but it will be with a bottle of good old JD rather than a SM.
      My Computer

  3. hsehestedt's Avatar
    Posts : 2,090
    Windows 10 Pro, 20H2
       #42

    W10 1903, 'eh? Just be careful with that - it's entirely possible that a new ADK will be released once 1903 is actually finalized in May.

    It's good to see that Microsoft is leaving it with Windows Insiders for further testing for a good while this time to hopefully catch any major bugs before release. 1809 was not a good initial release.

    In any case, glad to hear that it is working for you.

    I have a question for you:

    I have written a program that completely automates certain processes such as adding all the latest Windows updates into a Windows image. Actually, it can update as many images as you want all automatically. I'm currently working on writing the code to automate the whole process of adding drivers to Windows images as well. Would you be interested in trying this out when I have completed it?
      My Computers

  4. techquest's Avatar
    Posts : 1,602
    W10 Enterprise
       #43

    hsehestedt said:
    W10 1903, 'eh? Just be careful with that - it's entirely possible that a new ADK will be released once 1903 is actually finalized in May.

    Been using it in Hyper V for a while now without any real issues, slow ring, so thought I would try it out for real and see how it goes. If it turns out to be a problem then I will just do another new install of 1809, which again I didn't have any real issues with, until the beginning of this thread.

    It's good to see that Microsoft is leaving it with Windows Insiders for further testing for a good while this time to hopefully catch any major bugs before release. 1809 was not a good initial release.

    In any case, glad to hear that it is working for you.

    I have a question for you:

    I have written a program that completely automates certain processes such as adding all the latest Windows updates into a Windows image. Actually, it can update as many images as you want all automatically. I'm currently working on writing the code to automate the whole process of adding drivers to Windows images as well. Would you be interested in trying this out when I have completed it?
    On your question, sounds good to me as updates and drivers always seem to be the most lengthily processes. So when your ready just PM and we can take it from there, if I can help you by trying it out that's fine by me.
      My Computer

  5. Kari's Avatar
    Posts : 17,434
    Windows 10 Pro
    Thread Starter
       #44

    hsehestedt said:
    W10 1903, 'eh? Just be careful with that - it's entirely possible that a new ADK will be released once 1903 is actually finalized in May.
    Just a personal opinion: I recommend always using the latest ADK Insider Preview, currently build 18362: Download Windows Insider Preview ADK

    This way, you always have the absolute latest ADK.

    Kari
      My Computer

  6. techquest's Avatar
    Posts : 1,602
    W10 Enterprise
       #45

    Kari said:
    Just a personal opinion: I recommend always using the latest ADK Insider Preview, currently build 18362: Download Windows Insider Preview ADK

    This way, you always have the absolute latest ADK.

    Kari
    Thanks Kari will take a look at that tomorrow going to take the rest of the night off and chill some. Have a good weekend.

    - - - Updated - - -

    Just when all seemed to be going well!

    I went through the rest of the tut with no issues with drivers cmdlet

    dism /Image:N:\Mount /Add-Driver /Driver:N:\XPS_Drivers /Recurse

    100% successful

    save when I got to 5.1, using the following cmdlet:

    dism /Unmount-Image /MountDir:N:\Mount /Commit

    100% successful.

    The problem is N:Mount is empty! Just to be sure I went through the process 3 times, same result each time. Why would this be, I thought the changes would all be saved as the tut suggests. So what went wrong, any suggestions please?
      My Computer

  7. Kari's Avatar
    Posts : 17,434
    Windows 10 Pro
    Thread Starter
       #46

    techquest said:
    The problem is N:Mount is empty! Just to be sure I went through the process 3 times, same result each time. Why would this be, I thought the changes would all be saved as the tut suggests. So what went wrong, any suggestions please?
    Of course the Mount folder is empty after you have committed (saved) the changes to WIM image!

    The Mount folder is just a temporary folder containing the mounted WIM, a Windows image. You mount install.wim to this temporary folder, meaning it will be unpacked. You service it, like adding drivers, then commit (save) the changes. This means that the changes will be written to your WIM image file.

    Mount folder is just a temporary storage location. It should be empty before you mount a WIM file, it will be empty after you unmount it.

    When dismounting, Mount folder will always be emptied. That is how it should be. The drivers you added are now included in your install.wim file.

    Kari
      My Computer

  8. techquest's Avatar
    Posts : 1,602
    W10 Enterprise
       #47

    Kari said:
    Of course the Mount folder is empty after you have committed (saved) the changes to WIM image!

    The Mount folder is just a temporary folder containing the mounted WIM, a Windows image. You mount install.wim to this temporary folder, meaning it will be unpacked. You service it, like adding drivers, then commit (save) the changes. This means that the changes will be written to your WIM image file.

    Mount folder is just a temporary storage location. It should be empty before you mount a WIM file, it will be empty after you unmount it.

    When dismounting, Mount folder will always be emptied. That is how it should be. The drivers you added are now included in your install.wim file.




    Kari

    Thanks for the explanation Kari , having looked at the wim file now I can see that it has grown by about 1.1GB and didn't realize that the 15GB (80 drivers) would be compressed to that extent when being put into the wim file, and I missed the resized wim, guess I should have thought about it before the post. Oh well we live and learn.
      My Computer

  9. Hoolm's Avatar
    Posts : 492
    OS 10 64
       #48

    I am a Little stuck here need help
    please

    DISM - Add or Remove Drivers on an Offline Image-screenshot_100.png

    whats next Please ?

    - - - Updated - - -

    DISM - Add or Remove Drivers on an Offline Image-screenshot_101.png

    All my drivers are there but cant open iso folder to copy and past content

    - - - Updated - - -

    DISM - Add or Remove Drivers on an Offline Image-screenshot_102.png

    - - - Updated - - -

    [Log removed by Admin - if you need to post that much text again post is as a .txt attachment]
      My Computer

  10. hsehestedt's Avatar
    Posts : 2,090
    Windows 10 Pro, 20H2
       #49

    According to the logs, DISM is failing to find some DLL files.

    Try this:

    Make sure that you have the latest Windows ADK installed. Only the deployment tools component is needed.

    Goto Start > All Apps > Windows Kits > right-click Deployment and Imaging Tools Environment > More > Run as Administrator.

    Now try to run "dism /get-wiminfo /wimfile:d:\ISO_Files\Sources\install.wim" once again. Does that work now?

    NOTE: As an altrnative, from your elevated command prompt change directories like this:

    cd "C:\Program Files (x86)\Windows Kits\10\Assessment and Deployment Kit\Deployment Tools\amd64\DISM"

    Now try to run the command again.

    You likely have multiple copies of DISM on your system so we want to be sure we are running the one that comes with the ADK.

    Let's start with that.

    Only other answer I have so far:

    You wanted to know if you should use GPT or MBR partition scheme. If your system is BIOS based, use MBR. If it is UEFI based, use GPT.

    While you do that, I'll look at the rest of your post to see what else I can determine.
      My Computers


 
Page 5 of 9 FirstFirst ... 34567 ... LastLast

Tutorial Categories

DISM - Add or Remove Drivers on an Offline Image Tutorial Index Network & Sharing Instalation and Upgrade Browsers and Email General Tips Gaming Customization Apps and Features Virtualization BSOD System Security User Accounts Hardware and Drivers Updates and Activation Backup and Restore Performance and Maintenance Mixed Reality Phone


  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 00:05.
Find Us




Windows 10 Forums