DISM - Add or Remove Drivers on an Offline Image  

Page 4 of 9 FirstFirst ... 23456 ... LastLast
  1. techquest's Avatar
    Posts : 1,602
    W10 Enterprise
       #30

    Kari said:
    Mounting WIM requires both read and write permissions. You cannot mount a WIM file that is on write protected device, or in device which system cannot write / save to. A mounted ISO is like a virtual DVD-R, you cannot write to it.

    Short: to mount a WIM file, it must be copied from DVD or virtual DVD (mounted ISO) to HDD / SSD.

    Kari
    Understand what your saying re read/ write permissions.

    So do I just use Disk Management and under the Action tab create VHD and mount to that or can you suggest another way/program to create a VirtualDVD?

    - - - Updated - - -

    DISM - Add or Remove Drivers on an Offline Image-screen-shot-n_iso_files.png
      My Computer

  2. Kari's Avatar
    Posts : 17,434
    Windows 10 Pro
    Thread Starter
       #31

    techquest said:
    Understand what your saying re read/ write permissions.

    So do I just use Disk Management and under the Action tab create VHD and mount to that or can you suggest another way/program to create a VirtualDVD?
    A virtual DVD is a mounted ISO, no VHDs required. It is even shown in Explorer as DVD, like here a mounted Windows 10 ISO:

    DISM - Add or Remove Drivers on an Offline Image-image.png

    Right click a Windows ISO file, select Mount, select all content, copy to a folder.

    Kari
      My Computer

  3. Kari's Avatar
    Posts : 17,434
    Windows 10 Pro
    Thread Starter
       #32

    techquest said:
    - - Updated - - -
    OK, your screenshot reveals something. At the beginning, you told that you get path not found error, although you have checked the correct path in File Explorer:

    techquest said:
    Here's the correct paths copied from file explorer

    "N:\iso\sources\install.wim"
    Let's compare the command you told you used which produced the error to what your screenshot reveals.

    You told this command causes error:

    Dism /Mount-Image /ImageFile:N:\iso\sources\install.wim /Index:3 /MountDir:N:\mount

    But your screenshot shows that correct path in correct command should be this:

    Dism /Mount-Image /ImageFile:N:\ISO_Files\sources\install.wim /Index:3 /MountDir:N:\mount

    So, maybe the DISM command would not give a path not found error if you used the correct path?

    Kari
      My Computer

  4. techquest's Avatar
    Posts : 1,602
    W10 Enterprise
       #33

    Kari said:
    OK, your screenshot reveals something. At the beginning, you told that you get path not found error, although you have checked the correct path in File Explorer:



    Let's compare the command you told you used which produced the error to what your screenshot reveals.

    You told this command causes error:

    Dism /Mount-Image /ImageFile:N:\iso\sources\install.wim /Index:3 /MountDir:N:\mount

    But your screenshot shows that correct path in correct command should be this:

    Dism /Mount-Image /ImageFile:N:\ISO_Files\sources\install.wim /Index:3 /MountDir:N:\mount

    So, maybe the DISM command would not give a path not found error if you used the correct path?

    Kari

    Sorry Kari that was just a typo error in my post but just to reassure you I copied and pasted your line into PS and here's the output:

    PS C:\WINDOWS\system32> Dism /Mount-Image /ImageFile:N:\ISO_Files\sources\install.wim /Index:3 /MountDir:N:\mount

    Deployment Image Servicing and Management tool
    Version: 10.0.17763.1

    Error: 3

    The system cannot find the path specified.

    It's midnight here now so need to get some sleep and take break from this. But thanks once again for your help, input and patience.

    - - - Updated - - -

    This is a screenshot of my Mounted ISO G: as shown in the shot. It is the ISO I downloaded as you suggested in an earlier post as I wanted to reassure you what is happening is happening. I'm learning lots of stuff from you and that is good for me, hope it's not to troubling for you though.

    DISM - Add or Remove Drivers on an Offline Image-capture-mounted-g.png
      My Computer

  5. Kari's Avatar
    Posts : 17,434
    Windows 10 Pro
    Thread Starter
       #34

    techquest said:
    It's midnight here now so need to get some sleep and take break from this. But thanks once again for your help, input and patience.
    In Command Prompt or PowerShell, enter the following command and tell what the output is:

    dir N:\ISO_Files\Sources\install.wim

    Kari
      My Computer

  6. techquest's Avatar
    Posts : 1,602
    W10 Enterprise
       #35

    Kari said:
    In Command Prompt or PowerShell, enter the following command and tell what the output is:

    dir N:\ISO_Files\Sources\install.wim

    Kari
    Windows PowerShell
    Copyright (C) Microsoft Corporation. All rights reserved.

    PS C:\WINDOWS\system32> dir N:\ISO_Files\Sources\install.wim



    Directory: N:\ISO_Files\Sources


    Mode LastWriteTime Length Name
    ---- ------------- ------ ----
    -a---- 04/04/2019 23:49 4605412841 install.wim


    PS C:\WINDOWS\system32>

    This is the correct info, don't know where the last paste came from!

    - - - Updated - - -

    Reached that phase now Kari where I have to crash. So is there anything else you need before I go?
      My Computer

  7. Kari's Avatar
    Posts : 17,434
    Windows 10 Pro
    Thread Starter
       #36

    There are not many options left. My recommendation is to perform a repair install, to be sure system is OK.
      My Computer

  8. techquest's Avatar
    Posts : 1,602
    W10 Enterprise
       #37

    hsehestedt said:
    I don't give up easily either .

    I recall running into a problem once myself because my computer has more than one version of DISM on it. To make sure that the correct version is being run, try this:

    Change directories to C:\Program Files (x86)\Windows Kits\10\Assessment and Deployment Kit\Deployment Tools\amd64\DISM

    I'm assuming 64-bit Windows here. You can substitute arm\DISM, arm64\DISM, or x86\DISM if needed.

    Now try running the command once again.

    If that still does not work, try making sure that there is not still some image mounted by DISM by running these command and then try again:

    dism /unmount-image /mountdir:n:\mount /discard
    dism /cleanup-wim

    Make sure to run the commands from the location noted above.

    Thanks once again for your response hsehestedt. I tried to respond to your post but my reply kept adding as an update in thread I was talking to Kari, my guess is that it was seen as an update to that conversation. You can see this in this post below (...updated...) as I left it as is this time.

    Anyway I tried out all your suggestions but sadly the result was the same error 3.

    As you can see Kari did his utmost to try resolving the issue and sadly there seems to be no way around it other than to carry out a repair install, as he suggests. I don't like to think of my system having some kind of defect that could in some way leave it vulnerable to whatever, so I'm happy to do as he suggests. It will be interesting to see if the issue goes away at that point. In any event I want to add the drivers to an offline image so that I can create a complete recovery partition for the system and future needs. Hope that goes more smoothly.

    Meantime I'm still trying.

    - - - Updated - - -

    Kari said:
    There are not many options left. My recommendation is to perform a repair install, to be sure system is OK.

    Thanks for your efforts yesterday Kari. I will try the repair install and see if that fixes the issue and let you know.
      My Computer

  9. hsehestedt's Avatar
    Posts : 2,090
    Windows 10 Pro, 20H2
       #38

    techquest,

    I have one more idea here. Something Kari said reminded me of this. It also turns out that I wrote a program that automates processes like injecting updates into a Windows image and my notes from that project reminds me that I ran into a similar problem that you are encountering.

    As Kari had noted, the files and folders need to have read and write access. I had found that when I copied filed from my ISO image they were still not writable. I had to remove the read-only attribute from the files. In fact, I put comments about this in my program.

    To make sure that the files are writable, run this command. Note that I am assuming that you have copied the contents of your ISO image or your DVD to N:\ISO_Files:

    Code:
    attrib -r N:\ISO_Files\*.* /s /d
    See if this helps!
      My Computers

  10. techquest's Avatar
    Posts : 1,602
    W10 Enterprise
       #39

    hsehestedt said:
    techquest,

    I have one more idea here. Something Kari said reminded me of this. It also turns out that I wrote a program that automates processes like injecting updates into a Windows image and my notes from that project reminds me that I ran into a similar problem that you are encountering.

    As Kari had noted, the files and folders need to have read and write access. I had found that when I copied filed from my ISO image they were still not writable. I had to remove the read-only attribute from the files. In fact, I put comments about this in my program.

    To make sure that the files are writable, run this command. Note that I am assuming that you have copied the contents of your ISO image or your DVD to N:\ISO_Files:

    Code:
    attrib -r N:\ISO_Files\*.* /s /d
    See if this helps!
    Ran the code from elevated command.

    Error: 0xc1510111

    You do not have permissions to mount and modify this image.
    Verify that you have Read/Write permissions or mount the image using the /ReadOnly option. Note that you cannot commit changes to an image with read-only permissions.

    So will try Kari's recommendation of repair install next and get back to you all after I have completed it.
      My Computer


 
Page 4 of 9 FirstFirst ... 23456 ... LastLast

Tutorial Categories

DISM - Add or Remove Drivers on an Offline Image Tutorial Index Network & Sharing Instalation and Upgrade Browsers and Email General Tips Gaming Customization Apps and Features Virtualization BSOD System Security User Accounts Hardware and Drivers Updates and Activation Backup and Restore Performance and Maintenance Mixed Reality Phone


  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 22:20.
Find Us




Windows 10 Forums