Use DISM to Repair Windows 10 Image  

Page 28 of 60 FirstFirst ... 18262728293038 ... LastLast

  1. Posts : 2
    Windows 10.586
       17 Aug 2016 #270

    Cannot get a clean install of Windows 10

    G'day, folks!
    I am new to this forum, and have spent many hours reading some of these tutorials. What a fantastic resource!
    What set me looking was a chance encounter with sfc, which piqued my curiosity, and led me down a sad path.
    I tried to get some answers from MS Community, but a very helpful Brad over there suggested that this might be a better place. And having seen what's here, I am sure he is right.
    I'm having (similar) problems with a number of computers, but one at a time...
    This is a Dell 780 desktop (Legacy BIOS), Intel CPU, 16GB ram, Samsung 256GB 840PRO SSD plus additional 400GB HDD.
    Problem: sfc always comes back with "could not repair some files". Dism (in all its options) always comes back with a set of files for which "source files could not be found". I have tried pointing it at DVD iso (from techbench back (in Feb 2016)when my version of W10 was still there), USB thumbdrive created from MCT (ditto), and by putting the .wim and .esd files from there onto C:. Always the same final result (although when \Source pointed to DVD or thumbdrive, I could find no record whatsoever in the Dism log of it actually trying to access the external storage, whereas when I put the wim/esd on C:, it clearly did try).

    There are six recalcitrant files. All are of the form .lnk, and all sit in WinSxS. All are version 10.0.10586.494 - and that may be the problem since on examining the wim/esd of my install media, only 10.0.10586.0 seems to be there. (I had initially assumed that all of the "correct" versions were reachable online by Dism from WU, but apparently not. And since (I also assume) that the versions of some of these files on my PC change with every update, does that not make the use of original installation media quite limited? I seem to have scores. if not hundreds, of .494 files in WinSxS).

    I have tried almost all of the suggestions in (28 pages of!) the above thread, many times. One last possibility, alluded to in some comments, is restoring my files from a known good computer. It happens that I do have another desktop, similar configuration, that scans clean and has the same file versions in WinSxS. But I can't just replace the files in my problem machine, as I can't get the right permissions (well, not easily, anyhow). And even then that may not be enough, as when CBS log says

    Hashes for file member \SystemRoot\WinSxS\amd64_microsoft-windows-speech-userexperience_31bf3856ad364e35_10.0.10586.494_none_88de9ec8aafab0c2\Speech Recognition.lnk do not match actual file [l:22]"Speech Recognition.lnk

    it may in fact be the stored hash (wherever that is) that may be the problem, and not the actual file itself. (Or is there some compressed version of the file itself saved away somewhere in the "Reserved" partition?) Either way, that would need attention also. And now I am well beyond the limits of my knowledge and googling ability....
    (Yes, I know, on my desktop "speech recognition" is totally irrelevant, but that's not the point of my query).
    I accept that I could make these problems go away (maybe?) if I simply upgraded everything to the anniversary edition. But that way I don't learn anything - and I'm not sure I want to go that edition yet, anyway.

    So, the questions which I am hoping someone can answer for me are
    1. How can I use a "known good" PC to fix my problem child? and,
    2. Is there something else to try instead?

      My ComputerSystem Spec

  2.    17 Aug 2016 #271

    I tried @Brink tutorial but nothing worked for me. Either trying without source or with it I end up with error 0x800f081f. :/
      My ComputerSystem Spec

  3. Brink's Avatar
    Posts : 34,585
    64-bit Windows 10 Pro build 18290
    Thread Starter
       17 Aug 2016 #272

    Hello Drummer, and welcome to Ten Forums. :)

    Error: 0x800f081f
    The source file could not be found.

    Did you use an ISO file downloaded from OPTION ONE below as the source in the DISM command?
      My ComputersSystem Spec

  4.    17 Aug 2016 #273

    Yes sir I did, thanks for the warm welcome!
      My ComputerSystem Spec

  5. Brink's Avatar
    Posts : 34,585
    64-bit Windows 10 Pro build 18290
    Thread Starter
       17 Aug 2016 #274

    Ok. Go ahead and post a screenshot showing the command prompt after running the command to see if anything may stand out.
      My ComputersSystem Spec

  6.    17 Aug 2016 #275

    Here's Dism /Online /Cleanup-Image /RestoreHealth :Click image for larger version. 

Name:	zM7WKka.png 
Views:	198 
Size:	20.4 KB 
ID:	96719
    Here's Dism /Online /Cleanup-Image /RestoreHealth /Source:wim:Full Path to install.wim file:1: Click image for larger version. 

Name:	fyR6VGR.png 
Views:	81 
Size:	23.5 KB 
ID:	96721

    And here's Dism /Online /Cleanup-Image /RestoreHealth /Source:wim:Full Path to install.wim file:1 /limitaccess: Click image for larger version. 

Name:	CkcopSb.png 
Views:	76 
Size:	24.1 KB 
ID:	96723

    I'm mounting the .iso with Windows instead of having it on a USB drive, does that can cause the issue?
      My ComputerSystem Spec

  7. Brink's Avatar
    Posts : 34,585
    64-bit Windows 10 Pro build 18290
    Thread Starter
       17 Aug 2016 #276

    I noticed that the ISO image version is for build 10586 in the screenshots. The current ISO build is 14393 version 1607 Windows 10.

    Is that the same build that you currently have installed?
      My ComputersSystem Spec

  8.    17 Aug 2016 #277

    I currently have 10586.545 and version 1511 installed, I guess that's the problem?
      My ComputerSystem Spec

  9. Brink's Avatar
    Posts : 34,585
    64-bit Windows 10 Pro build 18290
    Thread Starter
       17 Aug 2016 #278

    A 10586 ISO should still work with your current build though.

    Do you have Home or Pro installed?

    Go ahead and run the command below in an elevated command prompt for the ISO on I: to see its index.

    dism /Get-WimInfo /WimFile:I:\sources\install.wim
      My ComputersSystem Spec

  10.    17 Aug 2016 #279

    I have Pro installed and here's what I get with your command: Name:  xENDFdk.png
Views: 188
Size:  12.9 KB.
      My ComputerSystem Spec

Page 28 of 60 FirstFirst ... 18262728293038 ... LastLast

Tutorial Categories

Use DISM to Repair Windows 10 Image Tutorial Index Network & Sharing Instalation and Upgrade Browsers and Email General Tips Gaming Customization Apps and Features Virtualization BSOD System Security User Accounts Hardware and Drivers Updates and Activation Backup and Restore Performance and Maintenance Mixed Reality Phone

Related Threads
SFC Scannow or DISM/RestoreHealth using Image in Performance & Maintenance
Windows 10 user. Having some trouble with my system after coming back from a weekend. Nothing major...just having trouble playing some games that require plugins etc Regardless if it's related, I just wanted to run an SFC/Scannow or...
Hello, everyone, I've managed to resolve most of my problems with build 10041 by making SFC work. I've opened a thread on Windows Insider's forums explaining how to do it. Check it out:...
I've just upgraded Windows 7 64-bit HP OEM to Windows 10 Technical preview 64-bit. Extracted the install while booted within 7, install went smoothly, opted to keep all my files, and once the install was finished it went to boot Windows 10. It hung...
I installed the 32 bit version of W10 on an old Acer laptop to get back up to speed with developments, and one of the first questions or issues that cropped up is when using W10's disk image utility to make a system image. I deliberately wished to...
Windows 10 TP Repair and Recovery Features in Installation and Upgrade
I'm currently running the 10 TP in a virtual machine. I see that the various boot and repair options can be accessed by <shift> Restart from the desktop, however F8 during boot doesn't appear to work. Can someone who is actually running this on...

Tags for this Thread

Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 08:53.
Find Us