Customize Windows 10 Image in Audit Mode with Sysprep  

Page 8 of 70 FirstFirst ... 6789101858 ... LastLast

  1. Posts : 17,661
    Windows 10 Pro
    Thread Starter

    Hi McDougle, welcome to the Ten Forums.

    McDougle said:

    I was wondering what your possible fix was. I have been fighting with this same issue for days now and some of the "workarounds" just don't seem to be working very well.
    The fix, workaround, was too unsure and did not work every time. All signs told that a new build will come any day, I decided to wait.

    OK, we got a new build 10158 a few days ago and to my great pleasure I can tell that now most of the Sysprep issues seem to be solved. I am still testing but I promise to post something conclusive this week.

    At the moment I get CopyProfile=True, relocating Users folder, customizations, everything to work when testing Sysprepping in Audit Mode with various answer files in build 10158 every time when doing it on test Hyper-V virtual machines, but half of my sysprep tests fail when done on real physical hardware. I am still looking for the culprit and possible workarounds, puzzled about why doing this on vm works all the time but real machine fails quite often.

    Anyway, we are getting back there, getting this to work as it did in previous versions of Windows. Personally I am so to say "half pleased", I know now that I can create my customized, sysprepped image in Hyper-V, capture it and deploy to real hardware. But, of course, it should also work on real hardware.

    Now when most of the issues and bugs seem to gone I will be more active in this thread and post whatever I will find.

      My Computer

  2. Posts : 147
    Windows 10 x64

    Seems 10166 has Sysprep issues.

    1. When using Audit Mode as normal with CopyProfile setting:
    A. Some apps, like 3D Builder, will not open at all and open the Store instead. Some other apps have random issues that only happen after Sysprep.

    B. Cannot open apps in Audit Mode, so settings customizations are impossible. Bad for apps like Edge.

    2. When going into Audit Mode, creating a local user for customization, and then using Sysprep:
    A. Some apps, like 3D Builder, will not open at all and open the Store instead. Some other apps have random issues that only happen after Sysprep.

    B. The Store (unsuccessfully) tries to update all apps over and over, for no apparent reason.

    C. All pinned icons to the taskbar are reset to default. This is a different behavior than in Windows 7 and Windows 8.1. In those, if you made a user account before generalizing the machine, the taskbar was left alone. The taskbar was only reverted for new accounts.

    So, Microsoft has a lot of work to do.
      My Computer

  3. Posts : 17,661
    Windows 10 Pro
    Thread Starter

    jfreemont said:
    So, Microsoft has a lot of work to do...
    .. and that's the main reason why I have been so silent

    Sysprep works in 10162 and 10166 without issues, subject to installing Windows without any network connection and connecting it only when arrived to Audit Mode. But, as you have also noticed, Windows when finally booted to OOBE might have some functionality issues.

    In my sysprep tests I mostly get a fully working system, customized as I wish, but occasionally there will be some issues. The most annoying one is that if local accounts are created in the answer file, quite often the Start and Search do not work at all. Any subsequent MS or Domain accounts will have a fully working Start and Search / Cortana but the local accounts created in answer file don't.
      My Computer

  4. Posts : 147
    Windows 10 x64

    Yeah, I had those issues, too.

    Does 3D Builder work for you when you Sysprep? If I don't Sysprep, 3D Builder works. Once I Sysprep, 3D Builder gets corrupted, and the Store opens in its place.
      My Computer

  5. Posts : 147
    Windows 10 x64

    10240 is out. I can't test Sysprep at the moment. Hope someone can do tests with user accounts created before and after generalization.
      My Computer

  6. Posts : 147
    Windows 10 x64

    Tried out a clean install of 10240.

    It looks like there are still issues, especially if you need to create a user account before generalization. Apps like 3D Builder and Solitaire simply show their splash images for several seconds before disappearing completely.

    So, there is no way that we can deploy Windows 10 at launch. Bummer.

    I tried creating a user account after Sysprep, and apps seem to work okay so far in that one.
      My Computer

  7. Posts : 4,027
    Windows 3.1 to Windows 11
      My Computer

  8. Posts : 147
    Windows 10 x64

    So if I am reading that document correctly, we'll have to use that utility to keep our pre-generalization changes whenever a new build is released? I guess we won't be able to update our pre-generalization builds? If so, that really sucks.
      My Computer

  9. Posts : 147
    Windows 10 x64

    I've been experimenting just using Sysprep without Audit Mode (in cases where you might have a computer lab with only one generic user and you want all the computers in the lab to be 100% identical to each other). If anyone wants to reproduce the complete breaking of Windows 10 x64 Pro (Build 101240), do this:

    1. Install Windows and go through all prompts. During installation, create a local user named "test1." Otherwise, take all default installation settings.
    2. When Windows installation is finished, login to the "test1" user account.
    3. Restart the computer.
    4. Log back into the "test1" user account.
    5. Sysprep with these switches: /generalize /oobe /reboot
    6. During the OOBE, take all defaults except create a local user named "test2." You won't use this account, but OOBE requires a user to be created.
    7. When OOBE is complete, login to the "test1" account.
    8. Click the "3D Builder" tile. It opens for a second and then closes.
    9. Click the "Get Office" tile. It opens for a second and then closes.
    10. Click the "Get Skype" tile. It opens for a second and then closes.
    11. Click the "Microsoft Solitaire Collection" tile. It opens for a second and then closes.
    12. Click the "Phone Companion" tile. It opens for a second and then closes.
    13. Click the "Windows Feedback" tile. It never attempts to open.
    14. Click the "Store" tile.
    15. Click the "User" icon beside the search box.
    16. Click the "Downloads" link.
    17. Notice that the Store is (usually unsuccessfully) attempting to update all the Modern apps, whether they need to be updated or not.
      My Computer

  10. Posts : 6
    Windows 10

    So I can boot to my virtual machine, deploy a clean image direct to Audit mode from WDS with some basic customisations and as soon as I install updates = no start menu. (i think you touched on this above)

    I can do the same without updates and sysprep to "OOBE" with Generalization and everything works.

    Unfortunately, I'm looking to sysprep to audit mode with generalize and then capture the image. Upon doing so it creates the same issue - the start menu no longer loads and neither does search (as above).

    Any ideas on ways around either of these issues would be great :)

    Ok so i've confirmed two issues in Build 10240:
    In audit mode if Updates are run then the Start Menu will no longer load
    When Sysprep'd to Audit Mode with Generalization ticked it will also break the Start Menu as well as the "Right-Click" desktop Links to the Settings GUI
    Last edited by cbjason; 24 Jul 2015 at 11:04.
      My Computer


  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 15:59.
Find Us

Windows 10 Forums