Customize Windows 10 Image in Audit Mode with Sysprep  

Page 47 of 70 FirstFirst ... 37454647484957 ... LastLast

  1. Posts : 4
    Windows 10 enterprise and PRO

    Windows 10 Pro Build 1607 // broken Search // MS Apps

    Rockasatwork said:
    Hey everybody, me and my college are trying to create a custom Windows 10 Pro Image for our company. We've done this quite well with Windows 7 using the audit mode creating a default user profile. With Windows 10 we've started with build 1511 and had issues with Windows search and the not working startmenu from the beginning. Few days ago we startet testing with bild 1607. Here the startmenu seems to work correct during Audit mode and after sysprep ... but ... the Windows search stops working till we enter the Audit mode and its broken after sysprep and after Domain join. A second Thing that worked better for us in the earlier build was killing the preinstalled MS Apps and 3rd Party Apps. We've used PS Scripte to deinstall - or block These apps - but after Sysprep the Icons are back without any function.

    Hi Chris,

    Here is what we do (*also from a college using W10Enterprise builds 1507 and 1611):
    First, from a FRESH install, we go directly into AUDIT MODE
    - Unpin ALL apps from the start menu
    - Install all programs (Office, etc...)
    - pin OUR apps (Categorized by group i.e. Internet, Office, Intranet)
    once the start menu looks like we want it to, we then launch PS in elevated (admin) mode and run these scripts:

    Export-StartLayout -Path C:\Temp\LayoutModification.xml
    Export-StartLayout -Path C:\users\administrator\appdata\Local\Microsoft\Windows\Shell\layoutmodification.xml

    Followed by:
    Import-StartLayout -LayoutPath C:\Temp\LayoutModification.xml -MountPath $env:SystemDrive\

    THEN, using Windows Imaging and Configuration Designer, import layoutmodification.xml into a provisioning package project, sellect Common to All Windows Desktop Editions, click on Runtime Settings, Start, Start Layout, export the package, add it to a folder on your imaging machine that would be deleted in SCRIPTS and RUN the package (you only need to do this ONCE and accept the pop-up about coming from a trusted source) - this has NOT failed (yet) to maintain our start menus for staff as well as (different) menus for PUBLIC use.
    Next, to "fix" the search function, first go to CONTROL PANEL, INDEXING OPTIONS, MODIFY and expand the C:\ drive, add check marks to PROGRAM FILES and PROGRAM FILES (x86) (USERS should already be checked) once again using PowerShell in an elevated mode, run this script:
    Get-AppXPackage -Name Microsoft.Windows.Cortana | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

    (If you get the RED ERROR codes saying that Cortana needs to close, just wait until it dies a "natural death" - about a minute or so and re-run the command).

    Gives this command about 30 seconds to complete and then check to make sure the search works in AUDIT mode (start typing WORD and it should show you MS WORD as a result AS WELL AS WORDPAD).
    We also include a CMD file located in the %windir%\setup\scripts directory (SETUPCOMPETE.CMD) that removes ALL instances of your UNATTEND.XML file as well as activates our W10 via our SKMS server - it also removes ALL traces of the default start menu from MS.

    rd C:\Users\Default\AppData\Local\TileDataLayer /q /s
    rd C:\Users\Administrator\AppData\Local\TileDataLayer /q /s
    del /Q /F c:\windows\system32\sysprep\unattend.xml
    del /Q /F c:\windows\panther\unattend.xml
    cscript //B "%windir%\system32\slmgr.vbs" /skms ###.###.###.###
    cscript //B "%windir%\system32\slmgr.vbs" /ato
    icacls %userprofile%\appdata\locallow /setintegritylevel (OI)(CI)L
    icacls %userprofile%\appdata\locallow\microsoft /setintegritylevel (OI)(CI)L
    icacls “%userprofile%\appdata\locallow\microsoft\Internet Explorer” /setintegritylevel (OI)(CI)L


    Run your SYSPREP with your UNATTEND FILE (we use the COPY PROFILE=TRUE without issues).
    After a DOMAIN ADMINISTRATOR first logon (to activate windows and join our domain), RECHECK the start menu (should be same as your image) and the search feature (should work without issues).
    From this point, all subsequent logons WILL work properly.
    We've been successful with this setup with laptops and desktops of different configurations including some using standard drives, some with SSD as well as Hybrid drives.
    (Please note that in ALL our images, the DESKTOP shortcut in the QUICK ACCESS file explorer still points to the ADMIN account, I have yet to get this issue resolved).
      My Computer

  2. Posts : 17
    Windows 10

    rarchamb said:
    (Please note that in ALL our images, the DESKTOP shortcut in the QUICK ACCESS file explorer still points to the ADMIN account, I have yet to get this issue resolved).
    I am not having that issue here.
      My Computer

  3. Posts : 14
    Windows 10


    I have new pcs and i have a problem when I generalise on the windows 1607 update.
    I use this command

    sysprep /generalize /oobe /reboot /unattend:copyprofile.xml

    All is ok, but when i create a new local account, I found my start menu but windows apps won't to work.
    Icons are blank (actualities, financial, etc.):

    Customize Windows 10 Image in Audit Mode with Sysprep-sans-titre.jpg

    Nothing appens when I click on it. But weather apps work.
    Do you know this problem?
      My Computer

  4. Posts : 14
    Windows 10

    In fact, apps bing news and financial are not included in windows 10 build 1607, so they must be installed in all profiles, with a microsoft account. They cannot be generalized.
      My Computer

  5. Posts : 36
    Windows 10 Pro x64

    First boot after SysPrep fails - Windows 10 Pro x64 v1607

    I've built a new VM using the latest 'Anniversary Update' ISO and the first boot (OOBE) after SysPrepping fails.

    After the normal screens, the last of which is this one:

    Customize Windows 10 Image in Audit Mode with Sysprep-oobe-boot.jpg

    it sticks at a screen just like this - with the circular animation going 'round but without any text.

    I'm using exactly the same steps as I'd used previously using a v 1511 ISO and the relevant WADK, so I tried going back and running SysPrep without and mods (no /unattend switch) and it's fine.

    I then added the stuff to passes 4 (OEM details, CopyProfile=true) and 7 (user accounts) and still no problem, but adding the folder redirection stuff to pass 7 causes the boot failure.

    As far as I can tell I'm using the same procedure that worked fine before (as detailed in the Win 7 tutorial as it's not included in this one) and I've gone back and done it again, but still the same result.

    Is there a known issue with this version and folder redirection using SIM to create the answer file?

      My Computer

  6. Posts : 17,661
    Windows 10 Pro
    Thread Starter

    I've done this already countless times with both Anniversary Update version 1607 build 14393, and with the latest Windows Insider build 14901 without any whatsoever issues.

    A bit tired of these "it does not work" comments, I will make a new video using version 1607 later today and post it here.
      My Computer

  7. Posts : 36
    Windows 10 Pro x64

    Kari said:
    A bit tired of these "it does not work" comments...
    That's a bit unfair, Kari. I checked everything I could see and tested it several times before posting and I then gave quite a detailed account of the problem and how I'd narrowed it down.

    It doesn't help anyone by saying "It works for me - I've done it loads of times"

    Last edited by Tolqua; 15 Aug 2016 at 16:47.
      My Computer

  8. Posts : 17,661
    Windows 10 Pro
    Thread Starter

    Tolqua said:
    That's a bit unfair, Kari. I checked everything I could see and tested it several times before posting and I then gave quite a detailed account of the problem and how I'd narrowed it down.
    Please do not get upset now but I just simply disagree.

    Tolqua said:
    It doesn't help anyone by saying "It works for me - I've done it loads of times"?
    In this case I honestly think it "does help", it entitles me to express my opinion.

    Since first Windows 7 beta versions I have done thousands of install / Audit Mode / Sysprep / deployment tests. Since August 2nd, the release of Anniversary Update version 1607 less than two weeks ago I've done over 50 customize in Audit Mode / Sysprep / Deploy tests with version 1607 build 14393. Since the release of latest Insider build 14901 last Friday I've done 10 (+-2, not sure about exact amount) tests with this Insider build.

    I always do these test of mine several times using different hardware and virtual machine setups, to be sure that it works both on physical and virtual machines.

    I repeat and repeat and repeat and repeat my tests. They do not fail, I always achieve what I wanted to. I follow my own instructions to the letter and it just works. Every time.

    You personally have posted multiple posts because ONE (I repeat: ONE) preview website does not work in your tests using a legacy browser. I have recommended that you forget the whole thing, do not play with it anymore.

    In addition, I must mention that most of the reboot loop / sysprep fail issues are caused by user.

    However low you must now think of me, regardless of how many members will report this post to admins and mods of our beloved Ten Forums, I will say this:

    What I said is not least unfair. Let's repeat what I said:

    Sysprep, customizing Windows 10 in Audit Mode works as described in tutorial. It's 17:00 now here where I live, I need to eat something and get some coffee, thereafter I will capture the process in a video and post it here later today.

    A very sincere,

      My Computer

  9. Posts : 17,661
    Windows 10 Pro
    Thread Starter

    I've been capturing the process and now last hours editing the raw two hour material. Past 2 AM here, too much whisky, can't continue now.

    I'll finish it tomorrow and post the video I promised a day late :)
      My Computer

  10. Posts : 3
    Windows 10


    I have successfully created master image using this tutorial for 1511 compilation, but I don't know how can I upgrade my image to 1607? Is it possible?

    Thanks for help.
      My Computer


  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 22:57.
Find Us

Windows 10 Forums