Customize Windows 10 Image in Audit Mode with Sysprep  

Page 21 of 70 FirstFirst ... 11192021222331 ... LastLast

  1. Posts : 8

    Yes thank you Deniise, worked well for me.

    Man I wish they would fix copyprofile & CU, breaking the search bar / quick access desktop shortcut already.
    Does MS not care for corporate roll out of their new OS? I don't get it.
      My Computer

  2. Posts : 3
    Windows 10

    existing users after sysprep


    my location has also taken the approach in all previous versions of windows of creating the users and customizing them and then running sysprep forcing a password change on login. with windows 10 the start menu/cortana does not function. I was forced to put the new image aside and work on other projects but i was just thinking about this today...

    before sysprep i disable the administrator account.

    after sysprep i login to my broken users account and see that the start menu does not work. now i can enable the administrator and login, this forces the user setup to run and the administrator account start menu/cortana works.

    so what if we disable the existing users before sysprep and either have the answer file enable them or write a line of code in the SetupComplete.cmd file that runs after windows setup that will enable the users...

    would doing so force the user setup to run again thus fixing our broken start menu/cortana issue?

    i am about to leave for vacation for a week and am now anxious to try this but will not until i get back if you have time maybe try it and see? or i could be barking up the wrong tree with my idea, but if it worked would be great!


    jfreemont said:
    Kari, if you go into Audit Mode like you always do, create a new user account, log out of the Administrator account, login to that new user account, customize the account, and then Sysprep it like you always do, do you have the Start and Search problem?
      My Computer

  3. Posts : 5
    Windows 10 Pro

    Kari said:
    That being said, guys be careful when sysprepping Build 10547. It seems that once again MS has managed to break the CopyProfile component; since the release of this build yesterday I have some 20+ sysprep runs, various scenarios, all have failed if the CopyProfile was used.

    I have been following this thread, and others, very closely. Here is what I have done/tried. I was able to install Windows 10 Enterprise and enter audit mode, installed apps, did not download updates, syspreped with unattend copyprofile true (all without a network connection). On first boot I logged in with a newly created local account and ran the Microsoft Show or Hide Updates Troubleshooter and as I clicked on the troubleshooter to check for updates I then connected the network cable. This found all the updates available, including driver updates, and I was able to hide them before it automatically downloaded and installed them. I joined the domain, rebooted and all the new accounts have a search bar that is functional.

    A new update (Windows 10 cumulative update 7, KB 3093266) that was pushed out 9/30/2015 broke it again, but when I uninstalled the update the search bar functionality returned.

    Has anyone gotten the search bar to function properly on a Syspreped and Copyprofile'd install with updates applied?
      My Computer

  4. Posts : 4
    Windows 10

    Kari said:
    I am sorry but I do not understand that, "select INSTALL...". You should not have that selection when deploying, you simply mount the deployment image and the installation (deployment) will be automatic.

    • Configure your image in Audit Mode
    • Create the Answer File
    • Sysprep
    • Capture the image
    • Deploy

    That's it. The Microsoft TechNet article I linked to in my previous post explains the procedure.
    Hi Kari,
    I would like to thank him for the statement that you have been helping folks with the construction of customized Windows image in audit mode 10. I apologize again because my English is not very good.
    I have been following since I joined this forum discussion on the deployment and customization of Windows 10 and would like to share the experience I have had in more than seven test scenarios with Sysprep.
    Kari, do not follow exactly the steps of your tutorial, but to my delight it worked: the search bar and the Cortana are functioning perfectly after running Sysprep with the CopyProfile setting in audit mode; including works also support the implementation of programs based on 16-bit architecture.
    I am not going to post images here, just inform the tests I did and what not to do on Windows 10 in audit mode. I would like to emphasize that my last test was performed on a physical machine that originally had been installed the Factory Windows Vista (Laptop HP Pavilion dv-2000). Windows 10 Setup was perfect! I used Windows 10 Home x86.
    In audit mode, as this is an old laptop, I activated the NetFramework 3.5 to support old applications that came in Laptop with Windows Vista, as the Quick Play for example. In the settings menu of "quick access" in "options", choose the option "open the file Explorer in" my computer ", I cleared the privacy options and removed the quick access library items to which they were not indexed to the built-in administrator tasks performed while I was customizing the image. Therefore, when you start the file Explorer would open "my computer" instead of "quick access". It is fully customizable and can restore the defaults that with one click after you create an end user.
    With the aid of PowerShell and PSWindowsUpdate module installed and updated:
    Drivers; Microsoft Visual C++ Runtime Library 2005; Microsoft Visual C++ Runtime Library 2008; Microsoft Visual C++ Runtime Library 2010; Microsoft Visual C++ Runtime Library 2012; Microsoft Visual C++ Runtime Library 2013; NetFrameworks; Flash Player for Internet Explorer; Microsoft Silverlight.
    I used the application Driver Pack Solution to install the latest drivers not found by the PSWindowsUpdate module. Installed the full package of DirectX Web Installer and the latest Java application.
    I rejected all the specific updates for Windows 10 such as security updates and cumulative updates.
    Installed the Office package 2013 updated and activated through KMS. Were also installed and configured applications: Adobe Air, Adobe, Reader, BitTorrent, Format Factory, Audacity, K-Lite Codec Pack Mega, Power2Go, dictionaries, Microsoft Movie Maker, Iobit Smart Defrag, Iobit Driver Booster, Iobit Advanced SystemCare and its tools and Google Chrome.
    I would also like to point out that I had access to the user's customizations after upgrading the drivers and I could insert the icon "this computer" on the desktop. Installed two themes for the desktop. Then I customized the start menu.
    Finally, deleted all temporary files, running Disk Cleanup, I cleaned all traces of tasks performed in Windows in audit mode. With Advanced SystemCare, fix invalid shortcuts and scraps of files and Spyware threats.
    What I did not do and for my tests should be done on Windows 10 in audit mode:
    Clean the registry; Defragment your registry; Optimize the system; Defragment the disk, activate and perform specific updates to Windows System.
    The license key of Windows 10 has been included in the answer file to run with the Sysprep enabling activation after installation and connection to the internet.
    The customizations and settings described above booted the system and then ran the Sysprep with the answer file with the CopyProfile setting. Everything was done connected with the internet. Disconnected only at the time of execution of the Sysprep to network settings were not copied to the default profile for Windows.
    After deploying Windows, during the process of user configuration connected again with the internet, Windows made critical updates normally, and there was no error in the logon.
    Below is a copy of the answer file that I used:

    <?xml version="1.0" encoding="utf-8"?>
    <unattend xmlns="urn:schemas-microsoft-com:unattend">
        <settings pass="generalize">
            <component name="Microsoft-Windows-PnpSysprep" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="" xmlns:xsi="">
            <component name="Microsoft-Windows-Security-SPP" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="" xmlns:xsi="">
        <settings pass="specialize">
            <component name="Microsoft-Windows-Security-SPP-UX" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="" xmlns:xsi="">
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="" xmlns:xsi="">
        <settings pass="oobeSystem">
            <component name="Microsoft-Windows-International-Core" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="" xmlns:xsi="">
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="" xmlns:xsi="">
                    <Link0>%ALLUSERSPROFILE%\Microsoft\Windows\Start Menu\Programs\System Tools\Windows Defender.lnk</Link0>
                    <Link1>%ALLUSERSPROFILE%\Microsoft\Windows\Start Menu\Programs\CyberLink Power2Go 9\CyberLink Power2Go 9.lnk</Link1>
                    <Link2>%ALLUSERSPROFILE%\Microsoft\Windows\Start Menu\Programs\Google Chrome\Google Chrome.lnk</Link2>
                <TimeZone>E. South America Standard Time</TimeZone>
        <cpi:offlineImage cpi:source="wim:e:/operating_systems/win10home_x86/install.wim#Windows 10 Home" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
    The language and keyboard settings in the answer file are in Brazilian Portuguese.
      My Computer

  5. Posts : 2

    Originally Posted by nazar1968
    I am facing issue with computer name after sysprep. My script should ask me computer name after running the sysprep and a script would run that would join the machine to domain. Same settings in the unattended file working fine with Windows 7 and 8.1, but Windows 10 is taking auto generated name of the machine instead of asking the name. CopyName field is empty in the Specialize part of the unattended file. Need your expert opinion.

    Any solution for this please
      My Computer

  6. Posts : 2

    I use mysysprep2 64 bit but still no luck

    with windows 10 its not prompting to enter computername instead creating random name

    if any one know how to fix this please post$b91bf7f9f57a62723ea48ef87fe80e9a$$256380$$2459594$$TnL5HPStwNw-Fyew3n67c7QIxx.0ks1VgA$$$
      My Computer

  7. Posts : 1
    windows 10

    one question :
    what is the difference between this method and taking an image with acronis true image app ?
    what advantages do we have with this method ?
      My Computer

  8. Posts : 13
    Windows 8.1

    Kari said:
    Catch 22: You've found a solution which would work if one of the prerequisites needed would work :). It works alone but is borderline useless if the prerequisites do not work.

    Anyway, nice job there Deniise! Thanks for sharing.
    Word's out from Microsoft that this issue is a bug which is scheduled to be fixed by the next service pack release, November 2015.
      My Computer

  9. Posts : 17,661
    Windows 10 Pro
    Thread Starter

    Deniise91 said:
    Word's out from Microsoft that this issue is a bug which is scheduled to be fixed by the next service pack release, November 2015.
    I've heard the same, didn't believe it but you confirming the rumors make me a bit more hopeful Been testing with build 10565 since it was released on Monday, the same issues are still there. CopyProfile works but the end user gets admin's desktop in Quick Access and admin's recent files for instance.
      My Computer

  10. Posts : 302
    Windows 10 10586

    Kari said:
    I so wholeheartedly wish that people would not state "It won't work!" as a fact when it is so clear that they really do not know. Naturally it does not work if you will do it wrong, naturally you will have problems if you do it wrong.

    I have nothing more to say about this topic. Your machines, your decision, you are of course free to do whatever you want to, as you wish, wrong or correct. I have nothing more to say about this topic. I just finish by answering your original question as clear as I can:

    There is no way for me to know if the Start and Search would work in doing as you suggest because I would absolutely not test that in any circumstances. I have no interest in testing something I know to be wrong.

    Hmmm.... In my Windows 8.1 images, I had app settings from Office to VLC to IE and everything copy over just fine on the target machine. The only remnants were some Admin directories in Office in the Recent list. VLC settings copied just fine... Odd.
      My Computer


Tutorial Categories

Customize Windows 10 Image in Audit Mode with Sysprep Tutorial Index Network & Sharing Instalation and Upgrade Browsers and Email General Tips Gaming Customization Apps and Features Virtualization BSOD System Security User Accounts Hardware and Drivers Updates and Activation Backup and Restore Performance and Maintenance Mixed Reality Phone

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 10:31.
Find Us

Windows 10 Forums