Page 13 of 14 FirstFirst ... 311121314 LastLast
  1.    05 Jul 2016 #120
    Join Date : Apr 2014
    Space coast of Florida
    Posts : 5,245
    Windows 10 Pro X64 15063.483

    Got it, I didn't do the Set-Location. Added that and it works perfectly now. They both now wend up at

    PS C:\Users\rrkurtz\PowerShellScripts>

    I don't want them stored on OneDrive yet. Maybe in the future.
      My ComputersSystem Spec
  2.    06 Jul 2016 #121
    Join Date : Oct 2013
    A Finnish expat in Germany
    Posts : 12,647
    Windows 10 Pro
    Thread Starter

    When it works with ISE and if you want the same to done to normal PowerShell, just copy the Microsoft.PowerShellISE_profile.ps1 file to same folder, rename the copy to Microsoft.PowerShell_profile.ps1 (same name without ISE).
      My ComputerSystem Spec
  3.    06 Jul 2016 #122
    Join Date : Apr 2014
    Space coast of Florida
    Posts : 5,245
    Windows 10 Pro X64 15063.483

    Love it, many thanks Keri.

    Now something for you to think about. Can Powershell communicate with windbg? If so I can see ways to automate a lot more of the basic debugging for BSODs in Windows.
      My ComputersSystem Spec
  4.    07 Jul 2016 #123
    Join Date : Oct 2013
    A Finnish expat in Germany
    Posts : 12,647
    Windows 10 Pro
    Thread Starter

    First, did you notice that the profile will be used also when you open PS session in Command Prompt:
    Click image for larger version. 

Name:	2016_07_07_07_44_271.png 
Views:	31 
Size:	33.0 KB 
ID:	88722

    Here some reading about PS and WinDBG:

      My ComputerSystem Spec
  5.    08 Jul 2016 #124
    Join Date : Apr 2014
    Space coast of Florida
    Posts : 5,245
    Windows 10 Pro X64 15063.483

    Oh wow!!!!! You're like the magic Genie of the Lamp Kari.

    Looks like I have a lot of reading and playing ahead of me.

    Thanks again.
      My ComputersSystem Spec
  6.    08 Jul 2016 #125
    Join Date : Oct 2013
    A Finnish expat in Germany
    Posts : 12,647
    Windows 10 Pro
    Thread Starter

    Sadly everything I am able to find about PS & WinDBG is quite old. All those links I posted are from 2007.
      My ComputerSystem Spec
  7.    09 Jul 2016 #126
    Join Date : Apr 2014
    Space coast of Florida
    Posts : 5,245
    Windows 10 Pro X64 15063.483

    I hope to spend some time today to see if I can get it working. I'll post back with results.
      My ComputersSystem Spec
  8.    13 Jul 2016 #127
    Join Date : Jun 2015
    Posts : 91
    Win 7 Ultimate

    Should there not be some kind of UI for this just the way various Linux package managers do?
      My ComputerSystem Spec
  9.    13 Jul 2016 #128
    Join Date : Oct 2013
    A Finnish expat in Germany
    Posts : 12,647
    Windows 10 Pro
    Thread Starter

    That is a good question to ask Microsoft.
      My ComputerSystem Spec
  10.    05 Jan 2017 #129
    Join Date : Jan 2017
    Posts : 2
    Windows 10 Professional

    Powershell Question


    Hello!

    I am following the video guides for creating Windows 10 images and ran into a small issue using the powershell commands in part 1 -> Windows 10 Install Image - Part 1: Customize Image in Audit Mode - YouTube

    I created the example VM and set everything up as the video shows then tried to install the software automatically as shown in the video. I ran into a couple of issues.

    First off... I will say that I am using Windows 10 build 14393, that is the version of the media I downloaded from Microsoft today (Jan 5, 2017.)

    I had no issue getting the Chocolatey provider. The next step says to run this command:

    Install-Package Paint.net, Opera, GoogleChrome, Firefox, vlc, 7zip, Notepadplusplus, Malwarebytes, Teamviewer, Steam, Rufus.install, Skype -Force

    When I tried running that command, I immediately got an error indicating that too many packages '73' were listed, the max number of packages was '63'. I still don't know what that means, but I assume it meant the command was too long. So I truncated it down by removing the last two entries and ran this command instead:

    Install-Package Paint.net, Opera, GoogleChrome, Firefox, vlc, 7zip, Notepadplusplus, Malwarebytes, Teamviewer, Steam -Force

    This seemed to work. It installed 10 packages, versus 12 that the video showed. About half way through installing (after displaying package firefox was installed) I received another error saying that a required file was not found. I noticed that it had completed software installation up through firefox, so I again truncated the command to only install the packages that it failed to install on the first run.

    Install-Package vlc, 7zip, Notepadplusplus, Malwarebytes, Teamviewer, Steam, Rufus.install, Skype -Force

    The command executed with no issues. So then I ran the command with the last two packages I omitted when I encountered my first error.

    Install-Package Rufus.install, Skype -Force

    This command also executed without issue.

    However, I noticed some things were different when I went to verify software was installed.

    These applications seemed to install correctly:

    Paint.net
    Opera
    7zip
    Notepad++
    Malwarebytes
    Teamviewer
    Steam

    These applications are no where to be found, and also do not show up in Program and Features as installed programs:

    Google Chrome
    Firefox
    vlc
    Rufus

    I tried to run the command, with just the packages that were missing in powershell. It displays that the command executed properly, but I still don't see these programs as being installed in my VM.

    Is there something I am missing? I planned on reading through the entire powershell tutorial in the next couple of days but thought it might be a simple error I'm overlooking.

    Thank you in advance,

    Ron
      My ComputerSystem Spec

 
Page 13 of 14 FirstFirst ... 311121314 LastLast


Similar Threads
Tutorial Category
How to connect/disconnect to a VPN using the command line?
Hi all I have several network connections configured. There is one wifi connection which automatically connects to my WLAN, another cable based LAN connection to a NAS which is used for backups and some L2TP connection connections (used...
Network and Sharing
What powershell command will let me rename my network?
:really:I have a few PCs connected via a bridge on an ethernet LAN. They communicate with each other, not "the internet". I'd like to rename "Unidentified network" to something more reasonable like "DoNotTreadOnMe" (allegorical.) 76590
Network and Sharing
Opening windows store apps from command line
How do I open windows store apps like Hulu from the command prompt?
Software and Apps
Can restore of Win 7 be started from command line ?
For some unknown reason I cannot any more navigate to Update panel from "Einstellungen" - it is blocked. I have to cancel the "Einstellungen" window by the task manager ! So in this moment I cant go forward nor backward any more: cant...
Installation and Upgrade
setting default apps from command line?
in win7, after installation and setting the correct file associations, the correct program would start upon double clicking in win10 however, it popups wanting you to set a ?default app?. ive seen this happen for klite codec pack, firefox,...
Software and Apps
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 00:48.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums