Windows 10: Reset Network Data Usage in Windows 10  

Page 2 of 3 FirstFirst 123 LastLast

  1. Posts : 19,830
    64-bit Windows 10 Pro build 16179
    Thread Starter
       30 Jan 2016 #10

    nIGHTmAYOR said: View Post
    Ops ! I have attempted to do a reset this month and it seems there had been a windows update or so because it worked previously , however after i applied the method the files were never belt back , data usage is now showing 0 kb usage no matter how many times i restarted or enabled/disabled network .
    any body had that too ?
    any work around ?
    Hello nIGHTmAYOR,

    It's still works fine for me. You might see if resetting it again may help.

    If you like, you don't need to manually reset data usage every month since it will only show usage from the last 30 days by default.
      My ComputersSystem Spec

  2.    06 Feb 2016 #11

    the folder contents don't build again , they are now blank , also i can't seem to find a fixit tool in microsoft support . any other suggestions ?
      My ComputerSystem Spec


  3. Posts : 19,830
    64-bit Windows 10 Pro build 16179
    Thread Starter
       06 Feb 2016 #12

    In that case, you could do a repair install that should fix it for you.

    Repair Install Windows 10 with an In-place Upgrade
      My ComputersSystem Spec

  4.    07 Feb 2016 #13

    I think i had it figured , i edited the batch file i use to delete the contents of the sru recently with a new loop i acquired from some webpage , the loop manages to delete and recreate the folder as well , so i think the folder lost permissions to the service responsible for maintaining the usage database .

    I temporarily solved this by giving permission to that folder for "Everyone" and it worked however that's not a safe setting .

    so I suggest brink you leave a remark to never delete the folder itself but the contents .

    also if possible would you care to share a snapshot of the users assigned to that folder and their rules for me to revise which users went missing when the folder was deleted ?
    Last edited by nIGHTmAYOR; 07 Feb 2016 at 18:18.
      My ComputerSystem Spec


  5. Posts : 19,830
    64-bit Windows 10 Pro build 16179
    Thread Starter
       07 Feb 2016 #14

    Hello nIGHTmAYOR,

    The owner of the sru folder is System. Here's a get-acl report for the folder to help.

    Click image for larger version. 

Name:	sru_owner_permissions.png 
Views:	57 
Size:	18.3 KB 
ID:	63017
      My ComputersSystem Spec

  6.    07 Feb 2016 #15

    Brink said: View Post
    Hello nIGHTmAYOR,

    The owner of the sru folder is System. Here's a get-acl report for the folder to help.

    Click image for larger version. 

Name:	sru_owner_permissions.png 
Views:	57 
Size:	18.3 KB 
ID:	63017
    how about the rest of users assigned ? because this haven't solved it yet , i managed to get this error message from event viewer :
    svchost (1432) SRUJet: An attempt to create the file "C:\WINDOWS\system32\SRU\SRUtmp.log" failed with system error 5 (0x00000005): "Access is denied. ". The create file operation will fail with error -1032 (0xfffffbf8).
    i think the attempt is done through another account than system!
      My ComputerSystem Spec


  7. Posts : 19,830
    64-bit Windows 10 Pro build 16179
    Thread Starter
       07 Feb 2016 #16

    I'm not sure what the default permissions are per user since it won't show them unless I take ownership of the folder.

    You could also do a system restore using a restore point dated before this happened to undo it.

    System Restore Windows 10
      My ComputersSystem Spec

  8.    07 Feb 2016 #17

    Brink said: View Post
    I'm not sure what the default permissions are per user since it won't show them unless I take ownership of the folder.

    You could also do a system restore using a restore point dated before this happened to undo it.

    System Restore Windows 10
    I don't use system restore , it beefs up pretty quick for me . no plans on resetting , repair installing , killing it while it sleeps or tossing away a system i have had for 3 years with all installed software and customization , this thing has to fix and it will

    so , i'm talking about the accounts listed under Properties > Security > Group or user names , so its strange they show for me even though i set ownership back to SYSTEM account , might it be you are not using NTFS partition ?

    its where i added Everyone account to allow whatever username the service responsible for data usage management to login by to access folder .

    A side remark all files created inside sru folder are owned by account LOCAL SERVICES , adding it and taking off account Everyone doesn't solve the problem though , i keep getting login errors in event viewer and 0 mb data usage .
      My ComputerSystem Spec


  9. Posts : 19,830
    64-bit Windows 10 Pro build 16179
    Thread Starter
       07 Feb 2016 #18

    Nope. You're seeing it since you previously took ownership and permission, and is no longer set at default permissions.

    You could try running SFC /SCANNOW to see if it may help since it's a system folder.

    https://www.tenforums.com/tutorials/2...dows-10-a.html
      My ComputersSystem Spec

  10.    08 Feb 2016 #19

    Brink said: View Post
    Nope. You're seeing it since you previously took ownership and permission, and is no longer set at default permissions.

    You could try running SFC /SCANNOW to see if it may help since it's a system folder.

    https://www.tenforums.com/tutorials/2...dows-10-a.html
    was my first try , didn't work , says everything is fine , just bottom line , do a warning about deleting the folder .
      My ComputerSystem Spec


 
Page 2 of 3 FirstFirst 123 LastLast

Related Threads
Is there any way to reset the WiFi Data Usage meter each month?
Network & Sharing View Network Data Usage Details in Windows 10 in Tutorials
How View Network Data Usage Details in Windows 10 This tutorial will show you how to view the Wi-Fi and Ethernet network data usage details of apps from the last 30 days on your Windows 10 PC. Here's How:
Solved Network Data Usage Doesn't Show in Network and Sharing
On one of our computers Win 10 home 64 bit, the Network data usage shows "0" while the other 3 (home and pro 32 & 64) all show fine. I only noticed it because the router shows that unit acting as a black hole for data usage even if it sits idle a...
Data Usage - How to Reset ? in Network and Sharing
....... does anybody got an idea how to reset the Data Usage back to 0 ? Any help would be greatly appreciated .......
hi, here my problem. i use usb modem huawei on windows 10 x64 pc. just recently i just notice my data usage not showwing anymore, i do dism ..nothing corrupt..sfc..same..basicly windows didnt corrupt.. so..how do i make it work again ..sorry (bad...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 10:56.
Find Us