DISM - Split install.wim file  

Page 2 of 2 FirstFirst 12

  1. Posts : 17,640
    Windows 10 Pro
    Thread Starter
       #10

    Ztruker said:
    This needs a tutorial written.
    @Martin has made a tutorial for it: Create bootable USB installer if install.wim is greater than 4GB

    Kari
      My Computer


  2. Posts : 13,950
    Windows 10 Pro X64 21H1 19043.1503
       #11

    Thanks Kari, looks good.
      My Computers


  3. Posts : 2
    Windows 8.1
       #12

    Hi,
    I've followed the tutorial till 2.3) Diskpart script but in my case I have one physical hard drive split in two partitions, one with Windows and the other with datas. As I'm abroad travelling for long time I'd like to deploy image on the Windows partition without touching the other partition cause I have a lot of documents that I cannot backup because of no external drive available now. Is it something possible to do or not ?
    UEFI base and GPT disk on Windows 8.1, image to deploy is on SD card.
    Thanks for your answer.
      My Computer


  4. Posts : 4
    Windows 10
       #13

    Can anyone help? I am having some trouble with a scenario where I can only load an image from standard physical 4.5 GB DVDs. My "Dism /apply-image" fails at a certain point because it is expecting to find the next SWM file immediately in the same place (drive E: which is my DVD Drive). What I need is a way for the process to pause until I can insert the next DVD that contains the next SWM file in the series. As you can see, the command below will not work for the scenario that I have described:
    Dism /apply-image /imagefile:E:\install.swm /swmfile:E:\install*.swm /index:1 /applydir:W:\

    - - - Updated - - -

    I figured it out. After the step where you format the drive with Dispart, you can then create a temporary folder to store all of the *.SWM files. Then you can run the Dism Apply-Image command to apply the image from the temp folder. It doesn't matter that the image is applied to the same drive where the temporary files are located. Then when your done, you can delete the temporary folder.
      My Computer


  5. Posts : 17,640
    Windows 10 Pro
    Thread Starter
       #14

    Davegbuf said:
    I figured it out. After the step where you format the drive with Dispart, you can then create a temporary folder to store all of the *.SWM files. Then you can run the Dism Apply-Image command to apply the image from the temp folder. It doesn't matter that the image is applied to the same drive where the temporary files are located. Then when your done, you can delete the temporary folder.
    Yes, that is the only solution. You must create a partition to store all files of a split WIM image, store them on an external hard disk or NAS, or use USB flash drive.

    Kari
      My Computer


  6. Posts : 4
    Windows 10
       #15

    I actually stored the split WIM files in the same partition that I loaded the image on. I used the Diskpart script that was in the article like this:

    Part 1 (260 MB) - Windows EFI/System partition
    Part 2 (16MB ) Microsoft MSR partition
    Part 3 - Windows 10 (OS partition) and assign drive letter W:
    Part 4 500MB Windows RE partition

    Then what that was done, I created a folder under W:\TEMP_IMAGE to store all SWM files until the image is loaded. The "W:\TEMP_IMAGE" folder does not exist in the image so it is OK to image the same partition since it is not going to overwrite anything.
      My Computer


  7. Posts : 32
    windows 100586.164
       #16

    @Kari Thanks for this great tutorial, just a quick note, I've been successfully using swm files to install windows 10 for quite a while. The only issue is, it seems there is a bug with the setup that the copy percentage is only for the fist SWM file, meaning it could stay for a long time at 100% while it is actually still copying over the other SWM parts to the installation disk. I only figured this out by looking at the setupact.log to see why my setup is stuck at 100%

    Some some excerpts from the setupact.log
    2021-04-14 16:08:02, Info IBS SetSelectedImageInfoOnBB:no FLAGS field retrieved for image; hr = 0x80070490
    2021-04-14 16:08:02, Info [0x060088] IBS CheckAdditionalMediaRequirements:Image part count is [3]
    2021-04-14 16:08:02, Info [0x060089] IBS CheckAdditionalMediaRequirements:Looking for image file [C:\Sources\install2.swm]
    2021-04-14 16:08:02, Info [0x06008a] IBS CheckAdditionalMediaRequirements:Found image file [C:\Sources\install2.swm]
    2021-04-14 16:08:02, Info [0x06008c] IBS CheckAdditionalMediaRequirements:Image file is not a match[gle=0x00000490]
    2021-04-14 16:08:02, Info [0x060089] IBS CheckAdditionalMediaRequirements:Looking for image file [C:\Sources\install3.swm]
    2021-04-14 16:08:02, Info [0x06008a] IBS CheckAdditionalMediaRequirements:Found image file [C:\Sources\install3.swm]
    2021-04-14 16:08:02, Info [0x06008c] IBS CheckAdditionalMediaRequirements:Image file is not a match[gle=0x00000490]
    2021-04-14 16:13:40, Info [0x0a0029] UI progress task ProgressInfo\CopySetupFiles received 201 steps but was only supposed to receive 100.
    2021-04-14 16:13:43, Info [0x0a0029] UI progress task ProgressInfo\CopySetupFiles received 202 steps but was only supposed to receive 100.
    2021-04-14 16:13:49, Info [0x0a0029] UI progress task ProgressInfo\CopySetupFiles received 203 steps but was only supposed to receive 100.
    2021-04-14 16:13:51, Info [0x0a0029] UI progress task ProgressInfo\CopySetupFiles received 204 steps but was only supposed to receive 100.
    2021-04-14 16:13:52, Info [0x0a0029] UI progress task ProgressInfo\CopySetupFiles received 211 steps but was only supposed to receive 100.
    2021-04-14 16:13:53, Info [0x0a0029] UI progress task ProgressInfo\CopySetupFiles received 212 steps but was only supposed to receive 100.
    2021-04-14 16:13:58, Info [0x0a0029] UI progress task ProgressInfo\CopySetupFiles received 213 steps but was only supposed to receive 100.
    2021-04-14 16:13:59, Info [0x0a0029] UI progress task ProgressInfo\CopySetupFiles received 214 steps but was only supposed to receive 100.
    2021-04-14 16:14:02, Info [0x0a0029] UI progress task ProgressInfo\CopySetupFiles received 215 steps but was only supposed to receive 100.
    2021-04-14 16:14:05, Info [0x0a0029] UI progress task ProgressInfo\CopySetupFiles received 216 steps but was only supposed to receive 100.

    2021-04-14 16:14:09, Info [0x0a0029] UI progress task ProgressInfo\CopySetupFiles received 217 steps but was only supposed to receive 100.
      My Computer


 

Tutorial Categories

DISM - Split install.wim file Tutorial Index Network & Sharing Instalation and Upgrade Browsers and Email General Tips Gaming Customization Apps and Features Virtualization BSOD System Security User Accounts Hardware and Drivers Updates and Activation Backup and Restore Performance and Maintenance Mixed Reality Phone


  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 19:04.
Find Us




Windows 10 Forums