Getting Code 10 error on usb microphone

Page 1 of 2 12 LastLast
  1.    #1

    Getting Code 10 error on usb microphone

    I have a editor keys sl300, which works on another computer. When I plug it into my computer though, I get a message saying "troubleshoot device" in devices and printers. The troubleshoot says that there is a problem with the drivers, which I have reinstalled multiple times. Under task manager, it says that it it caused by:

    This device cannot start. (Code 10)

    {Operation Failed} The requested operation was unsuccessful.

    How would I fix this?

    I have tried reinstalling drivers, changing USB ports, uninstalling and disabling the microphone to no avail.

    Thanks in advance.
      My ComputerSystem Spec

  2.    #2

    Have you downloaded the driver from the vendor's site, for Win 10?

    Here is a statement on the vendor's site about this:

    Windows 8 and 10 - 64bit Driver:
    The microphone works perfectly with Mac and PC with no drivers required. If you're running Windows 8.1 or Windows 10 64bit, some systems now required signed drivers to enable the microphone. *To enable this for your 64bit Windows machine, simply download this driver:*64bit Extreme Driver.*
    Here is the link to the site
    The SL300 Condenser USB Microphone - Both Mac PC Compatible - Used by thousands of professional recording artists | Editors Keys

    (I have a recording studio using Cakewalk Sonar, but I don't use USB mic's).
      My ComputersSystem Spec

  3.    #3

    Yes I have, and have reinstalled it as well. It dosesn't solve the problem unfortunatley.
      My ComputerSystem Spec

  4.    #4

    Did you install the drivers first and then connect the mic? If you connect the mic first and then the drivers the installation usually fails.

    If you have a System Restore point that is BEFORE you first tried to install the mic, use that to go back (gives a clean start) and then install the drivers first then connect the mic and see if it works.

    If you don't have a restore point, connect the mic, go to the Device Manager, uninstall the mic and the drivers in the device manager. Disconnect the mic and reboot the PC. After Windows starts, try another installation, installing the drivers first.
      My ComputersSystem Spec

  5.    #5

    I installed the drivers first, but still getting the same issue
      My ComputerSystem Spec

  6.    #6

    Select "Run as Administrator" when you install the drivers and see if that makes any difference. Also, since drivers are also for Win 8.1, install the drivers in a Win 8.1 compatibility mode and see if that makes any difference.
      My ComputersSystem Spec

  7.    #7

    So after trying that, it now recognised the correct microphone, rather than "USB audio", and says it is working correctly for a few seconds, then reverts to:

    This device cannot start. (Code 10)The I/O request was canceled.
      My ComputerSystem Spec

  8.    #8

    Go to They have a lot of useful utilities. One I believe is called USBDeviceView. May help you troubleshoot. In my case I was constantly getting USB device disconnect dings for no reason, all my devices were working properly. I was able to find a USB device that didn't exist and deleted it.
      My ComputerSystem Spec

  9.    #9

    Thanks for the reply. I've tried uninstalling the mic from USBDeviceView, but i'm still getting the same error. Everything else looks normal.
      My ComputerSystem Spec

  10.    #10

    You're welcome. Sorry it didn't help.
    Of interest, is blocked by the company I support. Some of the utilities look as if they could be used by hackers.
      My ComputerSystem Spec

Page 1 of 2 12 LastLast

Related Threads
anyone run this one before? I am not currently using a WIFI device. Error 16393 Log Name: System Source: Microsoft-Windows-Bits-Client Date: 12/8/2015 3:05:05 PM Event ID: 16393 Task Category: None Level: ...
Hello all, I have an issue with my WIndows Updates, I am getting error code 0x80040154 and all the sites I checked did not help. Here is my Windows Update log: Got 9482F4B4-E343-43B6-B170-9A65BC822C77 redir SecondaryServiceAuth URL:...
During Windows backup, which wants to backup the 'C' drive and my games drive 'E' (for some reason), I get the following error message after the 'C' backup has completed but not the 'E': 'The backup operation that started at...
I am on my 4th SSD in my Windows 10 laptop that has been getting SMART error 2000-0151. We have replaced the motherboard, the SSD, and the connector cable between the SSD and motherboard. One thing is that I've been using Macrium Reflect to clone... I have tried what I believe to be everything at this point. Clearing out the update download folder and retrying the update does not help whatsoever. Forcing the update through a command prompt just gets the...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 12:43.
Find Us