Creators Update refusing to install DTS sound

  1.    #1

    Creators Update refusing to install DTS sound

    Damn MS !!! not a single time without a hiccup ...
    broke my DTS sound + .....control panel disappeared ....& cannot trace its identity even i install manufacturer drivers( HP laptop - I installed the same driver few days back which installed DTS control panel automatically) but not now....
    looks like MS & Dolby to break stuff so that we would purchase shitty artificial sounding Dolby access( which they added as a new option in sound settings- clearly advertising Dolby even if it is not installed)!!!!

    Update - i even grabbed the DTS software seperate package from the manufacture driver package...& even downloaded it seperately from net....It simply refuses to install saying. You already have a DTS technology installed on this system. The product will not be installed

    Update 2 -
    Sorry 4 confusion, believing in manufacturer as it was stable for me upto aniversary...didn't bother to check out realtek new drivers ..Realtek latest driver solved d issue....seems like Microsoft ended support 4 those age old manufacturer drivers
    Last edited by sreekantt; 12 Apr 2017 at 14:39.
      My ComputerSystem Spec

  2. Posts : 414
    Windows 7 Home Premium x64

    You could also try the v6.0.1.8067 driver from HP, which should also work on your HP computer.
      My ComputerSystem Spec


Related Threads
Source: Windows 10 Creators Update and Creators Update SDK are Released - Building Apps for WindowsBuilding Apps for Windows :arrow: Windows 10 Creators Update version 1703 (build 15063) now available from Windows 10 Update Assistant. ...
Hi, I use Microsoft Virtual Server 2005, but have a strange problem. It says that this application cannot run on my system but ran perfectly when I was on Windows 7. Please help!
I have a Lenovo G780, it came with Windows 8 Home originally but I hated it and bought a copy of 7 Pro to install on it. That was back in early 2013. Anyway, when MS announced the Windows 10 upgrade thing I reserved my copy, and everything went...
It downloads, but it just fails to install. This has been going on for about 3 weeks now. It still runs, but it simply won't update. Do I have to remove it completely and re-install it? Getting this error: 44883
As above my rig updated to build 10130 I had no sound (SoundBlaster Zx) played around a bit but couldn't get it to work, so I uninstalled it and now it will not reinstall. I have run a cleaner so it got rid of all creative stuff tried again but no...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 16:15.
Find Us