Realtek Network Driver + All USB Audio devices = Audio Stutter

  1. Quexos's Avatar
    Posts : 158
    WIN10 LTSC, Linux
       #1

    Realtek Network Driver + All USB Audio devices = Audio Stutter


    I've been having audio stutter/micro-dropout ever since I built my Ryzen PC. Long story short, I have found that having a Realtek Network driver installed (all of them from 2017-now) and playing audio with any USB based device causes it. Switching to the default MS Windows driver seems to "fix" the audio stutter. Using onboard Realtek Audio does not stutter.

    My usb audio devices:
    1. FocusriteScarlett 2i4
    2. Plantronics 515HD headset
    3. Asus Xonar SE PCIe soundcard (has C-Media USB2.0 6620A Sound Processor + Realtek S1220A DAC via Asmedia ASM1142 3.1 USB Controller). Yep, even my PCIe sound card is USB and stutters over the optical/SPDIF connection to my receiver!

    All those devices stutter during network activity, but onboard Realtek ALC892 audio does not. Listening to music while browsing the web, playing an online game, watching a youtube video, Hell, just listening to music while Windows does it's sneaky thing in the background.

    I guess just using the default Windows driver can be considered a fix...but I am sure I'll find a problem with that soon. Bad network performance, bittorrent crashing when too many connections made (experienced that a long time ago with other network drivers).

    So, does anyone know which of the million and two settings in the advanced tab of the Realtek card's device manger settings are safe or recommended to disable? Which ones might cause little CPU spikes or interference somehow with USB so I could use them without usb audio stuttering?
      My Computer


  2. Posts : 869
    Windows 10
       #2

    Too many "moving parts" to diagnose the underlying issue.

    I would take out the xonar card and headset out of the equation first. So diagnose motherboard + 2i4 first.

    AMD chipset drivers?
      My Computer

  3. Quexos's Avatar
    Posts : 158
    WIN10 LTSC, Linux
    Thread Starter
       #3

    Chipset drivers (B450 Chipset 2.10.13.408) are the latest, but the problem has persisted through about 4 versions of them. The headset and 2i4 are out of the equation for now. At one point I tried to switch to the 2i4 as main audio device because I thought the problem was the Xonar SE or it's drivers. So for now, I am trying to sort it with the Xonar SE via optical output as main audio.

    The only thing I have identified as a potential cause is the Realtek Ethernet drivers (probably only during actual network activity). If only the built in Windows driver is used, the problem goes away. One of the older Realtek Ethernet drivers,10.023.1003.2017 (current on ASRock page for my B450 Gaming K4), seems to greatly reduce the stuttering but it still happens a bit. The newer ones up to 10.045.0928.2020 are much worse, with a stutter/dropout happening about every 10-20 seconds, and the dropouts seem longer, more obvious.

    I'm going to try changing these settings and see what happens:

    Advaned EEE = disabled
    Energy Efficient Ethernet = disabled
    Flow Control = disabled
    Gigabit Lite = disabled
    Green Ethernet = disabled
    Interupt Moderation = disabled
    Priority & VLAN = disabled
    Receive Side Scaling = disabled

    Edit: None of those settings helped. I guess I am stuck with the default Windows driver...which is fine by me as long as I don't find a new problem from using that.
    Last edited by Quexos; 03 Nov 2020 at 15:53.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 10:10.
Find Us




Windows 10 Forums