VIA HD Audio doesn't switch between speakers/headphones

Page 1 of 3 123 LastLast

  1. Posts : 2
    Windows 10
       #1

    VIA HD Audio doesn't switch between speakers/headphones


    This is just a small problem, but pretty annoying one.

    I recently updated to Win 10, and the first thing I noticed was that the sound settings were weird. Both speakers and headphone sounds work perfectly fine, but they don't automatically switch when I plug/unplug the headphones. I have to manually go into sound and set one device or another to default.

    Not too tech savvy, any help?
      My Computer


  2. Posts : 2,499
    Win 11 Pro
       #2

    I don't have a link but I've seen some posts that the VIA sound drivers need updating for Windows 10. May be the problem.
      My Computers


  3. Posts : 500
    windows 10 (x64) Home 20H2 19042.844
       #3

    I am also having VIA in ASUS S400CA. For me mic was not even working. Now after uninstalling and reboot helped mic to work. But however OP problem of speaker/headphone persists.
      My Computer


  4. Posts : 2
    W10
       #4

    Hello,
    Same problem here, any solution would be appreciated
      My Computer


  5. Posts : 2
    Windows 10
       #5

    Tomas said:
    Hello,
    Same problem here, any solution would be appreciated
    I'm also having the same problem. I've played around with drivers, but couldn't get it to work. It seems silly having to manually switch the default speaker whenever I want to put in headphones.
      My Computer


  6. Posts : 1,572
    Windows 7 Home Premium x64
       #6

    can you guys with VIA audio try this big driver package recently posted online? the zip file is almost 300Mb in size. VIA doesn't have that posted on the VIA downloads site and their web site does not even list Windows 10 on there.
      My Computers


  7. Posts : 2
    W10
       #7

    erpster4 said:
    can you guys with VIA audio try this big driver package recently posted online? the zip file is almost 300Mb in size. VIA doesn't have that posted on the VIA downloads site and their web site does not even list Windows 10 on there.
    It fixed the problem, thank you
      My Computer


  8. Posts : 37
    Windows 10 Home 64bit
       #8

    Tomas said:
    It fixed the problem, thank you
    With that big driver package, the switch problem is fixed, but the mic doesn't work for me (Asus VivoBook S400CA with Windows 10 Home 64bit)
      My Computers


  9. Posts : 26
    Windows 10 & Linux Mint 17.2
       #9

    UniqueID said:
    This is just a small problem, but pretty annoying one.

    I recently updated to Win 10, and the first thing I noticed was that the sound settings were weird. Both speakers and headphone sounds work perfectly fine, but they don't automatically switch when I plug/unplug the headphones. I have to manually go into sound and set one device or another to default.

    Not too tech savvy, any help?

    Download the new windows 10 driver, it was barely released yesterday!

    VIA Drivers and Support Packages Download




    This solved the problem for me as well, it was really annoying until yesterday! One thing I've noticed wrong with it is HD Vdeck does not seem to work. I also had a problem where Audio Enhancements were creating audio problems, but it all seems fixed now ( below is an image of what it said added to the non automatic switching ). ** Just make sure your codec is listed before downloading and installing for example mine is VT 2021!**
    Attached Thumbnails Attached Thumbnails VIA HD Audio doesn't switch between speakers/headphones-screenshot-1-.png   VIA HD Audio doesn't switch between speakers/headphones-screenshot-2-.png  
      My Computer


  10. Posts : 500
    windows 10 (x64) Home 20H2 19042.844
       #10

    Mine is also ASUS S400CA. With new driver mic not working.
    I tried old method of uninstalling all drivers and rebooing. Then also mic is not working.
    Now more problem than solution.
    Last edited by lvgandhi; 19 Aug 2015 at 21:24.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 17:26.
Find Us




Windows 10 Forums