Trying to re-enable X-Fi MB2 with more recent Realtek HDA drivers...


  1. Posts : 2
    Win 10 Pro
       #1

    Trying to re-enable X-Fi MB2 with more recent Realtek HDA drivers...


    ... than v. 6.0.1.6699 (that being the last driver "official" driver offered by Asus for my Gene V/Z77 motherboard).

    Hi all,

    I've been looking to restore the "Creative Sound Blaster X-Fi MB2" software functionality (on an older, secondary system) after upgrading to Windows 10 (v. 1909 b.18363.900) from 7 Sp.1+ (I held out as long as I reasonably could, sorry).

    I'm able to install said "official" drivers (Realtek HDA v. 6.0.1.6699... from 2012), along with said "Creative..." software package, and have the specific "sound enhancements" (EAX, EQ, THX, etc.) function, but said "enhancements" stop functioning if I attempt to update the drivers, even modestly.

    This issue also occurred (though resolvable-y) under Windows 7 - which (if I recall correctly) was resolved by: stopping any interfering startup/service applications (namely, the "Creative" ones); installing the desired driver (in this case, 6.0.1.7982); rebooting; re-enabling the startup/service applications; and, rebooting once more. Said resolution, however, doesn't appear to work under Windows 10.

    The HDXMB2O.inf files for each of the subsequent Realtek drivers I've tried (x.8186, x.8036, x.7982) all appear to contain the correct Hardware Ids (HDAUDIO\FUNC_01&VEN_10EC&DEV_0899&SUBSYS_1043846B) for the "High Definition Audio Device" in this motherboard, and said drivers appear to correctly install (via the setup.exe or manually through Device Manager) the specific driver files that (ostensibly) allow the "X-Fi MB2 sound enhancements" to function under Windows 10. The device's specific event log shows nothing awry. And yet: bupkis... the "sound enhancements" cease enhancing.

    I've gone down several online rabbit holes that appear related to the issue I'm having, and have tried the hacks and mods and whatnot, but I keep circling back to the commonality of said "driver files" between driver versions and this niggling feeling that there is something simple that just needs switching/modifying/finessing on the "Creative..." software side of the equation.

    Any thoughts?

    Thank you for your time and energy!
      My Computer


  2. Posts : 427
    Windows 11 pro X64 latest
       #2

    Try the 2.81 realtek driver and tell the results.
    -https://www.techspot.com/drivers/driver/file/information/18084/


    1)Uninstall all realtek and X-fi mb drivers.
    2)install realtek 2.81
    3)install x-fi mb
      My Computers


  3. Posts : 2
    Win 10 Pro
    Thread Starter
       #3

    Thank you for your reply, boombastik.

    I believe the Realtek R2.81 driver is the same as the Realtek 6.0.1.8036 driver (downloaded from the MUC), which I've tried, but I will try the package found on TechSpot (again?)... perhaps that'll make the difference, or perhaps I just missed something the first time around?

    Should I be using any third-party uninstallers/driver cleaners, or should I trust that both the old x.6699 drivers and the "Creative..." software will uninstall cleanly before reinstalling said R2.81 drivers and said "Creative..." software?

    Thank you again!
      My Computer


  4. Posts : 427
    Windows 11 pro X64 latest
       #4

    Dont use third party uninstallers. Use the built in uninstallers from realtek and creative software.
    The Driver version: 6.0.1.8036 is the realtek 2.82 that has a bug with control panel so install the 2.81 from my link.
      My Computers


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 22:55.
Find Us




Windows 10 Forums