HDMI Audio not working after upgrade to Windows 10


  1. Posts : 2
    Windows 10
       #1

    HDMI Audio not working after upgrade to Windows 10


    Hi All,

    I've searched and found similar problems to mine, but none of those solutions worked so I'm reaching out here.

    I currently have an Asus Vivopc desktop that I use as an htpc and it is connected directly to my LG LB5800 tv. The PC has onboard speakers which sound terrible and when I connect the tv via HDMI, the video works fine but no sound comes from the tv. I still get sound from the PC but no matter what I can see, there is no option whatsoever to have the TV as a playback device. It isn't listed at all. I've reinstalled the intel and realtek drivers but that didn't work. I've opened up the playback devices, shown disabled devices and it didn't show up either.

    With Windows 8 it worked flawlessly. With Windows 8.1 it would only work when I rebooted the computer with the TV on, otherwise the device would disappear as soon as it was turned off. With Windows 10, it just isn't there at all.

    The computer is a celeron 1007u with intel hd graphics (which also takes care of the sound portion). Drivers are updated, I've tested the hdmi cable and it works....No where in my control panel does it list anything related to intel hdmi audio.

    Please help, this is super annoying!
      My Computer


  2. Posts : 17,371
    Windows 11 Pro
       #2

    What do you have in Device Manager under Sound, video, and game controllers, especially with the TV plugged in and turned on?

    Are you trying to use this driver:
    http://dlcdnet.asus.com/pub/ASUS/mis...17525_WHQL.zip
      My Computer


  3. Posts : 2
    Windows 10
    Thread Starter
       #3

    Under Sound, Video, and Game Controllers there are:
    Intel(R) Display Audio
    Realtek High Definition Audio

    Under Audio Input and outputs:
    Realtek Digital Output
    Speakers

    Digital Media Devices:
    TV LG LB5800

    Yes that is the driver I have installed.
      My Computer


  4. Posts : 3,257
    Windows 10 Pro
       #4

    What is your video card? What video driver are you using?
      My Computer


  5. Posts : 4,457
    Win 11 Pro 22000.708
       #5

    I see that Asus lists Windows 10 drivers for the Intel graphics:

    http://dlcdnet.asus.com/pub/ASUS/mis...1018154248.zip

    This isn't the same link as supplied in post #2. May be worth a try.
      My Computers


  6. Posts : 3,502
    Win_8.1-Pro, Win_10.1607-Pro, Mint_17.3
       #6

    Kail said:
    I've opened up the playback devices, shown disabled devices and it didn't show up either.

    Try enabling Disconnected devices view.

    Also please post screen shots of your Sound dialog windows. I'm not sure what to look for right now, but post the playback screens (some are property pages).

    There is another suggestion to try that I can't recall right now - I'll post that if I find it.
    HDMI Audio not working after upgrade to Windows 10-sndplayback.png

    Post any screen shots of devices in Dev Mgr that flagged.

    Try running the Control Panel > Troubleshooting > Troubleshoot audio playback

    You can also try turning off both devices, power up the TV, set to HDMI, power up the PC. The TV has to be listening on the HDMI port before the PC is turned on.

    I used to have to do this in Win7, Win8 - similar to your comment With Windows 8.1 it would only work when I rebooted the computer with the TV on, otherwise the device would disappear as soon as it was turned off. ... but it sounds as though this doesn't work on your machine.
      My Computer


  7. Posts : 1
    Windows 10
       #7

    HDMI sound not working


    :
    bobkn said:
    I see that Asus lists Windows 10 drivers for the Intel graphics:

    http://dlcdnet.asus.com/pub/ASUS/mis...1018154248.zip

    This isn't the same link as supplied in post #2. May be worth a try.
    Thanks this worked for me :)
      My Computer


  8. Posts : 30
    windows 10J40700
       #8

    i know that this is a bit late, but i have had a similar problem (HDMI sound un-plugged) with my Lenovo IdeaPad Laptop, and i figured out that the problem was the Realtek update i installed recently, as this never installed the Video Drivers required. So to fix i did the following

    Went to Lenovo Site and downloaded the Intel VGA driver (this should fix any 'intel' laptop with the same problem), and installed that driver, and during setup I noticed that it installed the Video Sound Driver, then downloaded from the same site the Realtek HD sound drivers and installed ... now i have a plugged in HDMI Sound icon when i connect to my TV via HDMI.

    However, one small issue remains, that when i plug in the HDMI the sound only comes into the TV when i disable the Realtek sound driver, which makes the HDMI driver kick in. its a small price to pay, but it works.

    All Links are for Windows 10 - 64 bit machines
    Link for Intel VGA driver: https://download.lenovo.com/consumer...s/3hb305af.exe
    Link for AMD VGA driver: https://download.lenovo.com/consumer...s/3hb403af.exe
    Link for Realtek HD Sound Driver: https://download.lenovo.com/consumer...s/3hb502af.exe

    Tip - Never upgrade your device drivers if they work just fine.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 01:25.
Find Us




Windows 10 Forums