USB speakers lose sound after Sleep - OK after reboot.

  1. Moggyman's Avatar
    Posts : 5
    Windows 10
       #1

    USB speakers lose sound after Sleep - OK after reboot.


    Apologies if I'm putting this int he wrong place - this is my first post here, be gentle with me.

    I've set up a new Dell Optiplex 5070 tower with Windows 10 and it's all patched up to current levels as of 30th Jan. I'm not currently in front of the box, hence no Windows version number.

    I have some small USB-powered speakers attached and all is fine until the PC enters Sleep mode. When it wakes up, the speakers are still shown OK i.e. Device Manager can still see them, I can still use the volume control etc, I see no errors or warnings anywhere, but I get no sound from them. The internal speaker still works. If I restart the PC the sound comes back.

    I have looked all over the Device Manager and disabled any options I've found which suggest that it's OK for USB devices to be turned off - if I've missed 'the' one then it must be well hidden! I've checked the BIOS for any similar settings and tried a couple but without success, so I've reset those.

    The PC has four USB 3 ports on the back and two USB 2 - I've tried plugging the speakers into all of those but still no joy. Now the really weird thing.....on the front of the PC there are two USB 2 ports, one USB 3 port and a USB-C(?) socket. I get no joy from the USB 3 port and one of the USB 2 ports. However, when I plug the speakers into the remaining USB 2 port I get sound OK after the PC wakes up. I've got no issues with any other devices I've got connected to the USB ports (mouse, keyboard, webcam, 1TB passport disk, printer) so I can't see how it could be a hardware problem per se. I'd be happy to replace the speakers but if this is just Windows 10 being daft then I'd be wasting money.

    Can anyone suggest what the issue might be?

    Thanks
      My Computer

  2. Slippery's Avatar
    Posts : 272
    Win 10 pro 64 bit Vs. 20H2 Build 19042.630
       #2

    Hi @Moggyman, did you check the advanced power settings in the old control panel?
    Welcome to the "Ten Forums".
    Attached Thumbnails Attached Thumbnails USB speakers lose sound after Sleep - OK after reboot.-power-settings.png  
      My Computer

  3. Moggyman's Avatar
    Posts : 5
    Windows 10
    Thread Starter
       #3

    Slippery said:
    Hi @Moggyman, did you check the advanced power settings in the old control panel?
    Welcome to the "Ten Forums".
    Hello! Thank you for stopping by.

    Yes, I've disabled that setting.
      My Computer

  4. Moggyman's Avatar
    Posts : 5
    Windows 10
    Thread Starter
       #4

    Update - I'm using Win 10 Pro version 1909
      My Computer

  5. Slippery's Avatar
    Posts : 272
    Win 10 pro 64 bit Vs. 20H2 Build 19042.630
       #5

    Me too
      My Computer

  6. Moggyman's Avatar
    Posts : 5
    Windows 10
    Thread Starter
       #6

    Does anyone else have any possible solutions or advice? I've never had a situation where an external device will only work from one particular port when other similar port types are also available.

    Thanks
      My Computer

  7. Moggyman's Avatar
    Posts : 5
    Windows 10
    Thread Starter
       #7

      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 23:58.
Find Us




Windows 10 Forums