Sound System on New Dell Inspiron PC 1909


  1. Posts : 24
    Win10 Pro
       #1

    Sound System on New Dell Inspiron PC 1909


    Just moved my old WMP library over to the new Win10 PC and I was glad to see a meta services feature to bring back art work,ect. Not as good as the old one, but better than nothing.

    I have to say I am not so pleased with the new sound system. Dell Inspiron with the Realtek RtlUpd64.exe October 2018 driver.

    I did delete Dell Audio, perhaps I should not have? I was thinking about uninstalling the MaxAudio Pro.... would it be safe to do that?

    Any advice would be appreciated!
      My Computer


  2. Posts : 762
    Windows 10
       #2

    You can do whatever you want, what else can your computer go wrong at this stage?

    You already deleted Dell Audio and then caused your computer speakers to have statics when browsing in the other thread.
      My Computer

  3. sygnus21's Avatar
    Posts : 5,304
    Win 10 Pro (x64) 20H2 (19042.906)
       #3

    You need to understand this is what Dell gave you as a sound system.

    As for the quality of the software and should it be removed or not I can't say because I don't own a Dell. However, I would advise you consider purpose of the software in regards to the sound chip installed. And that you actually look to the "Dell" forums before you willy nilly go uninstalling stuff you have questions about.

    While this site has well knowledgeable members, sometimes it's better to visit a specialist. When I have specific questions on my motherboard, I visit that board's dedicated forum.

    All that said, if you have questions about updating the Realtek drivers go here - Latest Realtek HD Audio Driver Version. However, most of the discussion there is focused on desktops; hence again, why I suggest Dell's forums (or a dedicated Dell laptop forum).

    My two cents.
      My Computers


  4. Posts : 24
    Win10 Pro
    Thread Starter
       #4

    sandyt said:
    You can do whatever you want, what else can your computer go wrong at this stage?

    You already deleted Dell Audio and then caused your computer speakers to have statics when browsing in the other thread.
    Thanks for your help.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 01:41.
Find Us




Windows 10 Forums