P7P55D-E LX Asus Motherboard's VIA HD Audio issues after upgrading  


  1. Posts : 25
    Windows 10 1909 (18363.592)
       #1

    P7P55D-E LX Asus Motherboard's VIA HD Audio issues after upgrading


    Recently went from 7 to Windows 10 Pro 64 bit. version 1909 (18363.592)

    My audio still works, but sometimes it stutters a bit if I'm doing certain things. (For instance if I'm listening to music and open up the personalise window, it will stall and then maybe give an error saying it's not working properly.

    On startup I get a VDeck Error which says "VIA HD Audio Deck does not support this OS version. Please update the audio driver." But I think I'm on the latest driver that was released for the P7P55D-E LX, they don't have drivers for Windows 10 either.

    Not sure where to go from here, it's not a huge deal but I'd like to fix it if possible.
      My Computer


  2. Posts : 4,453
    Win 11 Pro 22000.708
       #2

    You could try the latest drivers directly from VIA (version 10.1200A, from 7 Nov. 2012): https://d34vhvz8ul1ifj.cloudfront.ne.../v10_1200a.zip

    Support is only listed through Windows 8.1, but I hope that they are better than the ones at Asus (9 Nov., 2010). Many drivers that support 8.1 also work on 10.
      My Computers


  3. Posts : 25
    Windows 10 1909 (18363.592)
    Thread Starter
       #3

    I managed to fix it, I tried to manually load Via audio deck, it asked if I wanted to run it in compatibility mode, now it works and the error is gone. Honestly. :/
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 04:47.
Find Us




Windows 10 Forums