I recently updated from 1803 to 1909 and I've noticed that the Volume Mixer does not store volume levels for any apps and instead just resets them to 100% if they are restarted.

This was not an issue I experienced with 1803, I've already tried seeing if it was just an issue with my user profile/registry by testing on a newly created user profile, as well as attempting to fix it by adding a missing registry key as suggested in this reddit post.

I've also tried simpler steps such as reinstalling my audio drivers and using a headset with a USB soundcard (HyperX Cloud II's) but these were also unhelpful.

Any help would be appreciated

- - - Updated - - -

Actually, ignore this - I created the registry key mentioned in the reddit post above under HKEY_LOCAL_MACHINE instead of HKEY_CURRENT_USER, creating the keys in the correct location and restarting my PC fixed the issue.

For anyone else with the same issue just follow the steps in the reddit post given in the OP, i.e. create the following registry key(s) manually:
HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\LowRegistry\Audio\PolicyConfig\PropertyStore