Realtek/Audio problems with new computer Asus TUF Gaming (565GE-AL365)

Page 1 of 3 123 LastLast

  1. Posts : 11
    windows 10
       #1

    Realtek/Audio problems with new computer Asus TUF Gaming (565GE-AL365)


    Hi, I already posted on another forum but got no answers, so here's the link for full details :

    Realtek/Audio problems with new computer Asus TUF Gaming (565GE-AL365) | TechPowerUp Forums

    In short, I bought a new laptop with no OS, installed windows with a USB + activation key from my uni. Got no problems at first (or didn't notice). I used a program to update my drivers (www.driverscloud.com) (I've been using this for ages with no problems. A friend of mine got the same laptop, used driverscloud with no issues).

    Then I tried to use Discord with friends and noticed that my microhpone wasn't recognized (Hyper X Cloud I). As I faced a similar problem on an old laptop, I guessed that I needed to update audio drivers. It's also worth noticing that the sound was coming from speakers and headset.

    So I tried to download realtek drivers and it didn't go well, tried several, had no sound at all at some point, only from the speakers, ...

    Please refer to the other thread for informations as I got more into details.

    As of right now, the driver in use is named Realtek(R) Audio and its version is : 10.0.18362.356
    Isn't it a generic windows audio driver?

    Sound is working but microphone isn't. Since it's a laptop with a single jack, I use an audio splitter coming from Hyper X.

    Any help would be appreciated.

    Maxime

    EDIT :
    I also got a driver named Nvidia Virtual Audio device (Wave Extensible) (WDM). Could it be the issue?
      My Computer


  2. Posts : 958
    Windows 10
       #2

    (1) download 8716 from asus website.
    (2) unzip the file
    (3) run the batch as admin

    check device manager to see if you have this

    Realtek/Audio problems with new computer Asus TUF Gaming (565GE-AL365)-screenshot.png

    If yes, then run Microsoft Store to download the realtek app

    (4) go to Microsoft update catalog, search for "realtek 1903 media" and download the latest 8773 driver. Unzip the file and install using device manager.

    (5) go to Microsoft update catalog, search for realtek 1903 and download the latest software component Hardware Support Application which is something like 11.0.6000.195 (the larger 15.5 mb download) Unzip the file and update ALL realtek software components (in your case 4 software components) using device manager.

    (6) run the Microsoft store, go to get updates and the store app will download the latest realtek app.

    (7) all your audio features will be assessed by the realtek audio console (or control) app.
      My Computer


  3. Posts : 11
    windows 10
    Thread Starter
       #3

    Thank you, I'll try this when I'll get home.

    should I uninstall the driver first?

    I guess I download the Asus' driver from ASUS TUF565GD ? It's only 21 Mb, is it normal?

    Here you can see all the Software Components and the Sound, Video and Game controllers I have at the moment in the device manager (before I tried anything).
    https://i.imgur.com/dhd1f6j.png
      My Computer


  4. Posts : 958
    Windows 10
       #4

    All new drivers (graphics, audio, etc...) are smaller because all the extra "features" are in the separately downloaded app.

    Since you already have those items, go to step 4 directly.

    Do you have the realtek (or asus-branded) audio console app downloaded from the Microsoft store?

    The configuration is now done through the "app". Go to Microsoft settings, systems and sound to test your microphone and test cortana. Remember you can't hear yourself unless you unmute microphone playback.

    Since you have a laptop, the computer may have a problem trying to figure out using the laptop's built-in microphone or your headset microphone. So test that first (i.e. skype using built-in speaker and microphone). Your problem will most likely be solved by telling your laptop not to use the built-in microphone when you are using headset.

    - - - Updated - - -

    If you have the old "realtek hd audio manager", uninstalled it by going to settings, then apps.
      My Computer


  5. Posts : 11
    windows 10
    Thread Starter
       #5

    Hello, I couldn't find the time yesterday to try. Will try today but I'm at work and don't have a mic.

    I already have those drivers you mentioned but I think that the current "realtek" driver (named as such under Sound, video and game controller) isn't really from realtek. See screenshot below.

    https://i.imgur.com/NfHJj9n.png
    https://i.imgur.com/iZGRqA7.png (Casque means Headset and atm, some micless earphones are plugged in.)

    Is it really from Realtek or is it a generic windows driver? This one came up when I uninstalled a wrong driver and rebooted.

    I had at first the Realtek HD Audio Manager (the one from the Microsoft store? It launches like an microsoft app? Named Realtek Audio Console?). But wasn't working when I found it out. When I tried to launch it, it came up with the following error : Impossible to connect to the RPC service.

    After multiple uninstallations and cleaning, it disappeared.

    If I got it correctly, drivers using this interface are UAD vs HDA?

    So what's the current driver that I'm using? Should I upgrade from it by begining from your step 4?

    Thank you for the quick answers btw.
      My Computer


  6. Posts : 958
    Windows 10
       #6

    I think you can start at (4) because you already have the software components installed (it means you had the new UAD drivers). Unable to connect to RPC means that you had the app (which is the new UAD drivers).

    Go to windows settings (press windows key on the keyboard and i) and apps. If you see Realtek HD audio manager, then uninstall it.
      My Computer


  7. Posts : 1,573
    Windows 7 Home Premium x64
       #7

    when uninstalling the Realtek audio drivers (whether HDA or UAD), use the Display Driver Uninstaller (DDU) tool to do the job.

    uninstalling them thru Device Manager, especially UAD drivers, is really cumbersome and does not remove UAD drivers completely [HDA drivers, on the other hand, can be safely removed from Device Manager].

    from the DDU tool on the right hand section that says "---Select device type---", choose Audio, then select "Realtek (WIP)" on the section below, then on the left hand side of the DDU tool, click on either "Clean and restart" or "Clean and do NOT restart" (when choosing this option, you'll need to restart manually to remove the Realtek audio driver).
      My Computers


  8. Posts : 8,632
    Mac OS Catalina
       #8

    Discord has been having issues for some time. See this https://www.reddit.com/r/HyperX/comm...y_not_working/
    Discord wants to blame everything but their software. Where'd my Audio Input go? (+ Various Voice Issues) – Discord
      My Computer


  9. Posts : 958
    Windows 10
       #9

    He did have a problem with the Realtek audio console app not connect to rpc. So there is no way for him to configure his audio settings.

    He could have avoided the whole problem by just directly going to ASUS website and download the driver.

    You bought a brand new computer. Conventional wisdom says that computer manufacturer is going to have the proper drivers. You are not trying to find drivers for a 5 year old computer which driverscloud may be useful, but I would advise to stay away from driver downloading app.
      My Computer


  10. Posts : 8,632
    Mac OS Catalina
       #10

    Exactly Sandy, but posting here allows for these issues to be discussed and a solution found so that others in the future will be driven to these type of posts through web searches.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 17:35.
Find Us




Windows 10 Forums